Ankündigung

Einklappen
Keine Ankündigung bisher.

Apache mit PHP 5 und Mysql

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Apache mit PHP 5 und Mysql

    Huhu zusammen,

    ich versuche einen Apache Webserver zu lokalen Testzwecken mit PHP5 und mit Mysql zu installieren. Das Problem ist: es will auf Tod und Teufel nicht wirklich funktionieren. Bevor mich jemand auf Google verweisen will: Da habe ich wirklich einiges von probiert. Leider hat keine Anleitung, die Manuals und derartiges nicht gefruchtet. Ich scheine irgendwo einen Fehler zu machen, ich finde ihn jedoch nicht. Ich möchte auch XAMPP nicht installieren, da ich den Server auch gern von Hand einrichten können möchte.

    Um es auszuschließen...
    • Ja, der Apache läuft auf Port 80 korrekt soweit
    • Ja, der Mysql Server läuft und ist z.B. über eine Java Applikation ansprechbar
    • Ja, Php läuft soweit, eine phpinfo() gibt eine valide Seite aus
    • Ja, auf der phpinfo Seite werden sowohl das mysql als auch das mysqli Modul als geladen angezeigt
    • Ja, laut phpinfo() wird auch die php.ini genutzt die ich verlinkt habe


    Der error - sowie der access.log im Anhang sind beide von kurz nach dem Aufruf meiner "dbtest2.php" mit der ich einfach nur eine Verbindung zur Datenbank testen möchte. Die Seite läd ewig und präsentiert dann keine Ausgabe. Ok, soweit nicht ungewöhnlich. Im Erfolgsfall soll es ja auch keine geben. Jedoch kann ich den Benutzernamen und das Passwort zu völligen Unsinn ändern und es erscheint trotzdem keine Fehlermeldung. Im access.log wird zudem ein 500er Statuscode zurückgegeben, was ja einen internen Serverfehler bezeichnet. Leider steht im error.log soweit nichts was da helfen könnte.

    Allgemeine Daten
    Apache http: 2.2.8
    php: 5.2.13 ( von PHP For Windows: Binaries and sources Releases
    Exakter Download: VC6 x86 Non Thread Safe (2010-Mar-04 20:11:06) )
    Mysql: 5.1.48
    Betriebssystem: Windows 7 Professional - 32 Bit

    dbtest2.php
    PHP-Code:
    <?php
    $verbindung 
    mysql_connect ("localhost","root""root")
    or die (
    "keine Verbindung möglich.
     Benutzername oder Passwort sind falsch"
    );
     
    ?>
    PHP - Konfiguration
    php.ini

    Apache - Konfiguration
    httpd.conf

    phpinfo() Ausgabe
    phpinfo()

    error.log
    Code:
    [Thu Jul 08 07:56:57 2010] [notice] Apache/2.2.8 (Win32) PHP/5.3.2 configured -- resuming normal operations
    [Thu Jul 08 07:56:57 2010] [notice] Server built: Jan 18 2008 00:37:19
    [Thu Jul 08 07:56:57 2010] [notice] Parent: Created child process 1780
    [Thu Jul 08 07:56:57 2010] [notice] Child 1780: Child process is running
    [Thu Jul 08 07:56:57 2010] [notice] Child 1780: Acquired the start mutex.
    [Thu Jul 08 07:56:57 2010] [notice] Child 1780: Starting 64 worker threads.
    [Thu Jul 08 07:56:57 2010] [notice] Child 1780: Starting thread to listen on port 80.
    access.log
    Code:
    127.0.0.1 - - [08/Jul/2010:07:57:20 +0200] "GET /dbtest2.php HTTP/1.1" 500 -
    Ich hoffe mal jemand nimmt sich die Zeit mal nachzuschauen. Ich weiß echt nicht mehr weiter.

    Danke für die Mühen im voraus.

    ~Makenshi


  • #2
    Wo hast du denn <script language="php"> aufgeschnappt? Nimm
    PHP-Code:
    <?php
    $verbindung 
    mysql_connect ("localhost","root""root")
    or die (
    "keine Verbindung möglich.
     Benutzername oder Passwort sind falsch"
    );
    die(
    "funktioniert");
    ?>
    Und setz das error_reporting auf E_ALL | E_STRICT.
    "Mein Name ist Lohse, ich kaufe hier ein."

    Kommentar


    • #3
      Okai:

      PHP-Code:
      <?php
      error_reporting
      (E_ALL E_STRICT);
      $verbindung mysql_connect ("localhost","root""root")
      or die (
      "keine Verbindung möglich.
       Benutzername oder Passwort sind falsch"
      );
       
      ?>
      Ok, das steht drin:
      Code:
      [08-Jul-2010 10:40:40] PHP Fatal error:  Maximum execution time of 30 seconds exceeded in C:\server\apache\htdocs\dbtest2.php on line 4
      
      [08-Jul-2010 10:42:16] PHP Warning:  mysql_connect(): [2002] Ein Verbindungsversuch ist fehlgeschlagen, da die Gegenstelle na (trying to connect via tcp://localhost:3306) in C:\server\apache\htdocs\dbtest2.php on line 3
      
      [08-Jul-2010 10:42:16] PHP Warning:  mysql_connect(): Ein Verbindungsversuch ist fehlgeschlagen, da die Gegenstelle nach einer bestimmten Zeitspanne nicht richtig reagiert hat, oder die hergestellte Verbindung war fehlerhaft, da der verbundene Host nicht reagiert hat.
      
       in C:\server\apache\htdocs\dbtest2.php on line 3
      
      [08-Jul-2010 10:42:16] PHP Fatal error:  Maximum execution time of 30 seconds exceeded in C:\server\apache\htdocs\dbtest2.php on line 4
      Heisst der Server kann nicht erreicht werden. Seltsam.

      Edit:

      Also die Mysql GUI Tools kommen auf den Server.
      Mein Hibernate Beispiel unter Java ebenfalls. Laut Portscan ist der Port auch offen.
      Ein Konfigurationsfehler in der php.ini schätze ich?

      Kommentar


      • #4
        Ich seh hier nirgendwo den Port.
        Schuss ins blaue. Eventiell das?

        Kommentar


        • #5
          Der Port ist der Standardport, den scheint php auch automatisch dranzuhängen. Trotz fehlendem Eintrag in der php.ini.

          Aber nun geht es anscheinend. Das Problem war das ich beim Serverstring nicht "localhost" sondern "127.0.0.1" schreiben musste. Nun geht es wie geschmiert. Anscheinend klappte die Auflösung nicht.

          Danke für eure Hilfen.

          Kommentar


          • #6
            Das mit 127.0.0.1 und localhost liegt an Windows 7. Vista hatte da auch schon Probleme gemacht. Kannst aber die host Datei änderen dann geht auch localhost.

            Kommentar


            • #7
              Wirklich? Was für Probleme gibt es hier?

              Ich hatte nur Probleme mit dem Port Apache, Windows7 und der Port 80 | ragtek

              Kommentar


              • #8
                Firewall?
                --

                „Emoticons machen einen Beitrag etwas freundlicher. Deine wirken zwar fachlich richtig sein, aber meist ziemlich uninteressant.
                Wenn man nur Text sieht, haben viele junge Entwickler keine interesse, diese stumpfen Texte zu lesen.“


                --

                Kommentar


                • #9
                  Windows 7 und Vista lösen Standardmäßig localhost nicht nach 127.0.0.1 auf. Da der Eintrag in der host Datei fehlt.

                  Kommentar


                  • #10
                    Richtig. Durch die fehlende Auflösung konnte natürlich keine Verbindung zu der Mysql Server Instanz aufgebaut werden. Dadurch das die Auflösung aber noch im Browser und ähnlichem funktioniert, denkt man da jedoch nicht daran. Offensichtlich weil hier die Auflösung schon durch das Programm stattfindet. Nicht jedoch so bei PHP.

                    Ich bin auf jeden Fall dankbar für den Tipp mal das Logging hochzustellen. Dadurch sah ich überhaupt erst das der Server nicht erreicht wird. Auch wenn das schon angedeutet wurde durch die lange Verbindungsdauer.

                    Kommentar


                    • #11
                      Hast du dich jetzt tatsache nur zum Spammen angemeldet ? ... Armes Ding.
                      [URL="https://gitter.im/php-de/chat?utm_source=share-link&utm_medium=link&utm_campaign=share-link"]PHP.de Gitter.im Chat[/URL] - [URL="https://raindrop.io/user/32178"]Meine öffentlichen Bookmarks[/URL] ← Ich habe dir geholfen ? [B][URL="https://www.amazon.de/gp/wishlist/348FHGUZWTNL0"]Beschenk mich[/URL][/B].

                      Kommentar

                      Lädt...
                      X