Ankündigung

Einklappen
Keine Ankündigung bisher.

.htaccess bei Xampp

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • .htaccess bei Xampp

    Hallo,

    ich bin momentan dabei ein neues Projekt zu machen und irgendwie funktioniert meine .htaccess ncht
    zur Info:
    - Ich habe Xampp mit VirtualHosts
    nun habe ich eine page Datei als sozusagen Index datei erstellt und eine .htaccess Datei mit folgendem Inhalt:
    Code:
    DirectoryIndex page
    
    ForceType application/x-httpd-php
    
    <FilesMatch "\.(gif|jpe?g|png|js|css|swf|pdf|ico|xml|rss|txt)$">
    
     ForceType None
    
    </FilesMatch>
    Leider wird meine page nicht aufgerufen und die .htaccess funktioniert nicht

    woran könnte das liegen?


  • #2
    Erklärst du bitte mal, was du damit überhaupt bezwecken willst?

    Wenn es lediglich darum geht, eine Datei namens page per PHP parsen zu lassen - wieso pfuschst du dann an den Type-Zuordnungen aller anderen Ressourcen herum?

    Kommentar


    • #3
      also eigenlich geht es hauptsächlich darum, dass die page datei immer aufgerufen wird .... damitt ich später so eine url formatierung habe_ example.de/page/xyz/
      noch eine Idee woran es liegen könnte ist, das es an den VirtualHosts liegt und hier irgendwas falsch ist:
      Code:
      <VirtualHost 127.0.0.1>
          ServerName www.xxx.site
          ServerAlias xxx.site
          AddType text/html .shtml
          AddHandler server-parsed .shtml
          ServerAdmin webmaster@domain.dd
          DocumentRoot "c:/Server/xampp/htdocs_domain/xxx"
          ScriptAlias /cgi-bin/ "c:/Server/xampp/htdocs_domain/xxx/cgi-bin/"
      
          <Directory "c:/Server/xampp/htdocs_domain/xxx">
          Options Indexes FollowSymLinks
          Options +Includes
      #   Options +
          AllowOverride FileInfo
          AllowOverride None
          Order allow,deny
          Allow from all
          DirectoryIndex index.php index.shtml index.html index.htm 
          </Directory>
      </VirtualHost>

      Kommentar

      Lädt...
      X