Ankündigung

Einklappen
Keine Ankündigung bisher.

Apache - php - Mysql Problem

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Apache - php - Mysql Problem

    Hi,

    ich habe nach einem update von Apache(??) ein Problem mit der DB-Verbindung.

    Apache 1.3 funktioniert tadellos, Apache 2.0 will nicht so richtig (in beiden Fällen ist PHP als Modul installiert.)
    Die Konfiguration sieht in beiden Fällen ident aus:

    Code:
    ./configure' 
    '--with-apxs=/usr/local/apache_1.3.31-test/bin/apxs' 
    '--enable-exif' 
    '--enable-track-vars' 
    '--with-calendar=shared' 
    '--enable-safe-mode' 
    '--disable-magic-quotes' 
    '--enable-trans-sid' 
    '--enable-wddx' 
    '--enable-ftp' 
    '--with-mysql' 
    '--disable-posix' 
    '--enable-memory-limit' 
    '--with-mysql=/mysql'
    Code:
    './configure' 
    '--with-apxs2=/usr/local/apache-2.0.50/bin/apxs' 
    '--enable-exif' 
    '--enable-track-vars' 
    '--with-calendar=shared' 
    '--enable-safe-mode' 
    '--disable-magic-quotes' 
    '--enable-trans-sid' 
    '--enable-wddx' 
    '--enable-ftp' 
    '--with-mysql' 
    '--disable-posix' 
    '--enable-memory-limit' 
    '--with-mysql=/mysql'
    In beiden Fällen wird auf die gleiche Datei zugegriffen, die lediglich folgendes macht:
    Code:
          if( !($dbLink = mysql_connect("mysqlserver", "user", "pass")) ) {
             echo("connection failed
    ");
             exit();
          }
    Bei Apache 1.3 macht er weiter (legt table an), bei Apache 2.0 bricht er ab.
    Der MySQL-Server ist also prinzipiell erreichbar (und funktionstüchtig.)
    Auch die php.ini sieht in beiden Fällen ident aus.

    könnt ihr mir hier weiterhelfen? bin nämlich schön langsam am verzweifeln

    lg
    thomas


  • #2
    was sagt denn ein mysql_error() unter dem script?

    Kommentar


    • #3
      Welche PHP Version? Falls 4.3.7 dann Update auf 4.3.8.

      Kommentar


      • #4
        hi,

        php 4.3.8 macht das gleiche...
        mysql_error liefert einfach nur:

        2003: Can't connect to MySQL server on 'mysqlserver' (2)
        db fehler

        wenn ich apache_1.3.31 starte (der auf das gleiche verzeichnis auf die gleiche datei usw. zugreift) funktioniert das ganze.

        MySql Version verwenden wir übrigens 3.23.38....im php script (bzw. in der ini), hab ich socket und port auch schon versucht anzugeben...funzt trotzdem nicht. ich hab auch versucht statt den servernamen die ip anzugeben...nicht

        das scripte sieht übrigens so aus:
        $conn = mysql_connect("mysqlserver", $dbuser, $dbpass);
        echo mysql_errno() . ": " . mysql_error(). "\n";

        lg
        tomi

        Kommentar


        • #5
          pfff.....

          der apache 2.0 war mit der laufzeitumgebung "worker" kompiliert....
          hab das ganze nun mit prefork versucht und siehe da es funktioniert.

          haben php 4.3.8 (und auch php5) probleme in threads zu laufen. wüsste nicht warum. obwohl wenn ich mit die hilfe zu "configure" ansehe in der steht:
          --with-apxs2[=FILE] EXPERIMENTAL: Build shared Apache 2.0 module
          dann erklärt das einiges.

          kennt ihr ähnliche probleme?? eventuell funktioniert das ganze besser, wenn ich php statisch oder als cgi installiere.

          lg
          tomi

          Kommentar

          Lädt...
          X