Ankündigung

Einklappen
Keine Ankündigung bisher.

Apache Processe ... ganz viele

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Apache Processe ... ganz viele

    Hallo zusammen, wenn ich ps -auxww in meiner Console eingebe, dann sehe ich viele von diese Processe:

    wwwrun 29272 0.0 0.9 27568 9676 ? S 12:19 0:00 /usr/sbin/httpd2 -f /etc/apache2/httpd.conf -k start
    wwwrun 29273 0.0 0.9 27560 9660 ? S 12:19 0:00 /usr/sbin/httpd2 -f /etc/apache2/httpd.conf -k start
    wwwrun 29275 0.0 1.1 29296 11776 ? S 12:19 0:00 /usr/sbin/httpd2 -f /etc/apache2/httpd.conf -k start
    wwwrun 29305 0.0 1.1 29248 11756 ? S 12:19 0:00 /usr/sbin/httpd2 -f /etc/apache2/httpd.conf -k start
    wwwrun 32573 0.0 1.1 28940 11424 ? S 12:21 0:00 /usr/sbin/httpd2 -f /etc/apache2/httpd.conf -k start
    wwwrun 379 0.0 0.9 27560 9656 ? S 12:21 0:00 /usr/sbin/httpd2 -f /etc/apache2/httpd.conf -k start
    wwwrun 380 0.0 0.9 27560 9656 ? S 12:21 0:00 /usr/sbin/httpd2 -f /etc/apache2/httpd.conf -k start
    wwwrun 384 0.0 1.1 29308 11832 ? S 12:21 0:00 /usr/sbin/httpd2 -f /etc/apache2/httpd.conf -k start

    mysql 27840 0.0 0.5 29924 5852 ? S 12:40 0:00 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/lib/mysql/mysqld.pid --skip-locking
    Irgendwie startet sich dieser Process jede Minute? Was ist das? Wie kann ich das beheben, meine Seite stürzt andauernd ab und das finde ich nicht gut

    Ich bedanke mich!


    Zusätzlich wenn der Apache nicht mehr erreichbar ist sehe ich dieses in den error-log:

    [Sat Dec 17 12:46:47 2005] [warn] child process 24752 still did not exit, sending a SIGTERM
    [Sat Dec 17 12:46:47 2005] [warn] child process 27938 still did not exit, sending a SIGTERM
    [Sat Dec 17 12:46:47 2005] [warn] child process 24755 still did not exit, sending a SIGTERM
    [Sat Dec 17 12:46:47 2005] [warn] child process 4743 still did not exit, sending a SIGTERM
    [Sat Dec 17 12:46:47 2005] [warn] child process 24757 still did not exit, sending a SIGTERM
    Gruss
    Nik[/quote]


  • #2
    das apache mehrere prozesse startet die dann auch laufen das ist ja wohl nur wünschenswert, also normal.

    was machst du denn mit deinem apache wenn er nicht mehr will?

    Kommentar


    • #3
      Also was ich eigentlich mache ist einen:

      apachectrl2 stop -> start und dann läuft es, aber das ist schrecklich

      So was ich gestern gemacht habe ist, dass ich einigen Werten in meinem httpd.conf geändert hatte:

      Z.B :

      MaxClients: von 40 auf 256 und StartServer: von 2 auf 20

      So dann sah später alles in Ordnung, bis ich Heute gesehen habe das der Server seit 3 Uhr Morgens nicht mehr funktioniert mit der Fehlermeldung:

      [error] (12)Cannot allocate memory: fork: Unable to fork new process

      Brrrrrr das ist schlimmer

      Also das ist meine Configuration in den httpd.conf. Kann mir jemand sagen wie ich die Einstellungen optimal machen kann?

      Ich habe übrigens MaxClients jetzt auf 100 gesetzt unt StartServers auf 5, mit der Hoffnung, das alles normal läuft:


      KeepAlive On
      MaxKeepAliveRequests 150
      KeepAliveTimeout 15

      <IfModule prefork.c>
      StartServers 5
      MinSpareServers 5
      MaxSpareServers 10
      MaxClients 100
      MaxRequestsPerChild 0
      </IfModule>

      <IfModule worker.c>
      StartServers 5
      MaxClients 100
      MinSpareThreads 25
      MaxSpareThreads 75
      ThreadsPerChild 25
      MaxRequestsPerChild 0
      </IfModule>

      <IfModule beos.c>
      StartThreads 10
      MaxClients 100
      MaxRequestsPerThread 10000
      </IfModule>


      Also so als kleine Information: wenn 66 User online sind gibt es 55 Processe von Apache Das würde bedeuten ich kann nicht mehr als 256 User online haben???? Das ist unmöglich!

      Ich bedanke mich im voraus:


      Gruss
      Nik

      Kommentar


      • #4
        mhm..
        auf was für ner kiste haste den apache denn laufen?

        Kommentar


        • #5
          Das ist ein Virtueller Server bei Evanzo und als OS habe ich Suse Linux aber wie kann ich sehen, was für eine Kiste das ist?

          Danke!

          Kommentar


          • #6
            na wenns nen vserver is...

            was sagen denn so sachen wie "df -h" oder "free -m" oder "cat /proc/cpuinfo" ?

            Kommentar


            • #7
              Also:

              df -h

              Filesystem Size Used Avail Use% Mounted on
              /dev/vzfs 1.5G 1.4G 135M 92% /

              free -m

              total used free shared buffers cached
              Mem: 1006 948 57 0 84 90
              -/+ buffers/cache: 773 232
              Swap: 3024 1280 1743


              cat /proc/cpuinfo

              processor : 0
              vendor_id : GenuineIntel
              cpu family : 15
              model : 2
              model name : Intel(R) Pentium(R) 4 CPU 2.80GHz
              stepping : 9
              cpu MHz : 2792.942
              cache size : 512 KB
              fdiv_bug : no
              hlt_bug : no
              f00f_bug : no
              coma_bug : no
              fpu : yes
              fpu_exception : yes
              cpuid level : 2
              wp : yes
              flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
              bogomips : 5570.56

              Kommentar


              • #8
                schaut doch gut aus...
                der RAM würde mir zu denken geben... 1GB ram is echt bissl wenig... der server wo mein vserver drauf läuft hat 3GB RAm.. vielelicht liegts ja da dran.

                und.. warum haste jetzt die maxclients noch oben geschraubt?
                lass das doch erstmal so wie es ist.. ich kan mir nicht vorstellen das es daran liegt...
                andererseits hab ich mir bis heute auch noch nicht apache 2 angeschaut...
                mach doch apache 1.4 drauf.. oder lighttpd, der soll wohl 10000 gleichzeitige zugriffe verkraften

                Kommentar


                • #9
                  Na ja nachdem ich diese Fehlermeldung im Error-log von Apache gesehen habe:

                  [error] server reached MaxClients setting, consider raising the MaxClients setting

                  dann musste ich etwas tun

                  Aber leider hilft das nicht! Ich habe momentan den Wert auf 150 gesetzt und immer wieder kommt der Server auf diesen Wert und stürzt zusammen!

                  Kann mir jemand einen Tipp geben, was ich da machen kann?


                  Was ich beobahte ist, dass im Processlist sich httpd Processe aufhalten die älter von 2 Stunden sind und kommischer Weise werden die nicht gekillt! Soll ich mir selber jetzt einen Script schreiben, der diese Processe killt oder hat Apache so etwas?

                  Gruss
                  Nik

                  Kommentar

                  Lädt...
                  X