Ankündigung

Einklappen
Keine Ankündigung bisher.

Apache und IIS?

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Apache und IIS?

    Hallo,

    vorgestern habe ich meinen Laptop formatiert und habe diesmal .NET 2003 draufgespielt bevor ich den Apache am laufen habe. Für .NET 2003 benötigt man einen laufenden IIS. Das Problem ist nun, dass ich den Apache nicht installieren kann. Ganz zum Schluss der Installation kommt in einem Dosfenster erst die Fehlermeldung, dass der Apache nicht installiert werden konnte (wg. nicht freien Ports oder so was) und dann in einem neuen Fenster die Meldung, dass der Dienst Apache nicht gestartet werden konnte, weil er nicht vorhanden ist.

    Apache trägt sich wirklich nicht unter Dienste ein, das habe ich überprüft. Man kann die Datei Apache.exe ausführen, dann startet er ja von Hand glaube ich (so war das früher unter win9. Das ist aber auf Dauer sehr nervig.

    Kann sich jemand vorstellen, wie man das hinbekommt, dass er sich wieder richtig installiert? Das mit dem IIS ist nur ne Vermutung - kann das jemand bestätigen? Muss man den IIS vielleicht während der Apache-Installation ausschalten? Wenn ja wo geht das?

    Fragen über Fragen.....


  • #2
    Dein Problem wird wohl sein, dass das Installationsscript versucht, den Apache so einzurichten, dass er auf Port 80 lauscht (das Standardverhalten). Das funktioniert aber deswegen nicht, weil schon der IIS hier am Arbeiten ist.
    Versuche es mal so, dass du den IIS vor der Installation des Apache stoppst, dann den Apache installierst und nach erfolgreicher Installation einen der beiden Webserver so umkonfigurierst, dass er auf einem anderen als Port 80 lauscht. Für den Apache kannst du die Direktive Listen in der httpd.conf editieren.

    Kommentar

    Lädt...
    X