Ankündigung

Einklappen
Keine Ankündigung bisher.

Komische Marsianer...

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Komische Marsianer...

    Hallo zsuammen!

    Ich versteh' da etwas nicht, vielleicht hat ja jemand einen kleinen Tip und nimmt mir die Tomaten von den Augen.
    Hier die Situation:

    Stellt Euch von es gibt ein LAN (10.0.12.x/24). Zentraler Router in ein Pinguin (Susi9.3), der per DSL die Internet-Anbindung stellt.
    An diesen Router möchte ich ein Gadget betreiben, das auch Netzwerkanschluss haben soll, per USB. Also richte ich ein Netzwerk über USB ein (macht SuSE ja automatisch). Der Router hat IP 10.0.12.47, das Gadget statisch 10.0.12.51. Erster Versuch ist ein gegenseitiger Ping zwischen Router und Gadget.
    Vom Router aus passiert gar nichts (not route to host), vom Gadget aus auch nicht, allerdings fällt mir hier in /var/log/messages auf, das pro Ping exakt ein Martian Packet geloggt wird. Daher also kein Erfolg beim Ping. Also überprüfen mit ethereal.
    Hmm... Packete sehen alle ok aus, aber eben kein Erfolg mit dem Ping. Nur diese Logeinträge: die behaupten, dass Marsianer von usb0 hereinkommen, mit Source 10.0.12.47 und Destiny 10.0.12.51. !?! Von usb0 aus? Source 10.0.12.47?
    Das sieht doch mehr so aus, also ob die Antworten auf das Ping, die ja vom Router ausgehen irgendwie ganz quer laufen !?!
    Komisch, alles andere an Netz klappt auf dem router ohne Probleme.

    Hier ein 'ifconfig' auf dem Router:

    --- schnippel ---
    dsl0 Link encap:Point-to-Point Protocol
    inet addrxx.xxx.xxx.xxx P-t-Pxx.xxx.xxx.xxx Mask:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
    RX packets:2387 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2077 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:1282429 (1.2 Mb) TX bytes:248040 (242.2 Kb)

    eth0 Link encap:Ethernet HWaddr yy:yy:yy:yy:yy:yy
    inet addr:10.0.12.47 Bcast:10.0.12.255 Mask:255.255.255.0
    inet6 addr: zz::zz:zz:zz:zz/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:2444 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2175 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1338423 (1.2 Mb) TX bytes:299172 (292.1 Kb)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:136 errors:0 dropped:0 overruns:0 frame:0
    TX packets:136 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:9359 (9.1 Kb) TX bytes:9359 (9.1 Kb)

    usb0 Link encap:Ethernet HWaddr yy:yy:yy:yy:yy:yy
    inet addr:10.0.12.47 Bcast:10.0.12.255 Mask:255.255.255.0
    inet6 addr: zz:zz:zz:zz:zz/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:4 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    --- schnippel ---

    Auffällig ist dabei 'errors:4' unter usb0.....

    Was mache ich falsch?
    Danke, arkascha


  • #2
    mhm.. meinste das is gut wenn eth0 und usb0 die selben ip adressen benutzen?
    kannst denen beiden nicht eine andere zuweisen?
    und mach mal zwischen durch /etc/inet.d/networking restart oder wie das bei suse heisst

    Kommentar


    • #3
      Hmm,
      warum soll das Probleme machen, wenn verschiedenen Interfaces die geiche IP-Adresse zugewiesen ist? Das Interface hat ja selber keine IP inne, es fungiert ja nur als "Sprachrohr" des Kernels. Ich mache das in mehreren Netzwerken ohne Probleme.
      Andernfalls hiesse das ja auch, dass prinzipiell ein Rechner mit mehreren Interfaces auch zwangsweise über ebensoviele IP-Adressen angesprochen werden müsste. Das würde schnell etwas unübersichtlich werden, oder?... Allerdings hast Du Recht, wenn ich über ein Interface *mehrere* Netzwerke anbinden möchte, dann kann ich der Karte gleichzeitig mehrere IP-Adressen zuweisen, sie also praktisch virtuell als mehrere Interfaces verwenden.
      Tatsächlich besitzt der Router zwei weitere Interfaces. Sinn eines Routers ist doch, als Knotenpunkt in einem Netzwerk zu fungieren, so dass alle Rechner miteinander in einem Netz kommunizieren können, *egal* über welches Interface sie zugreifen.
      Wichtiger ist doch, dass das Routing stimmt, spricht der Kernel muss wissen, über welches Interface er Packete rausschickt, damit sie ankommen. Hier scheint ja eher das Gegenteil der Fall zu sein: die Pakete werden ja gerade moniert, *weil* sie über das eigentlich *richtige* Interface laufen. Das ist der Punkt, den ich nicht verstehe.

      Neustart der Netzwerkschicht hilft auch nicht. Dadurch werden die Settings ja erst geladen, so dass ich sie mit 'ifconfig' sehe...

      Kommentar


      • #4
        man is das technisch...
        vielelicht steckt bei dir der iptable-teufel drin? :/

        Kommentar


        • #5
          kann ich mal die ifconfig vom gadget haben?
          Gruß
          Hekto

          Kommentar


          • #6
            Sorry, ich war zwei Tage lang unterwegs, daher erst jetzt die angefragte ifconfig-Ausgabe:

            lo Linkencap:Local Loopback
            inet addr:127.0.0.1 Mask 255.0.0.0
            inet6 addr. ::1/128 Scope:hosst
            UP LOOPBACK RUNNING MTU:17436 Metric:1
            RX packets:16 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0
            RX bytes:1792 (1.7 KiB) TX bytes:1792 (1.7 KiB)

            usb0 Link encap:Ethernet HWaddr E2:9FB:F4:9B:E1
            inet addr: 10.0.12.51 Bcast:10.0.12.255 Mask:255.255.255.0
            inet6 addr: fe80::e09f:dbff:fef4:9be1/64 Scope:Link
            UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
            RX packets:2 errors:0 dropped:0 ovverruns:0 frame:0
            TX packets:23 errors:0 dropped:0 ovverruns:0 carrier:0 collisions:0 txqueuelen:1000
            RX bytes:192 (192.0 B) T / X bytes:1134 (1.1KiB)


            looks ok to me...
            Mir ist aber in den Logfiles des Routers noch etwas aufgefallen, dummerweise sagt mir das garnichts:
            kernel: NETDEV WATCHDOG: usb0: transmit timed out
            Das hört sich nicht gesund an!

            Ach ja, hier noch das Zitat der Marsianer:
            Nov 15 23:07:27 xxxxx kernel: martian source 10.0.12.47 from 10.0.12.51, on dev usb0
            Nov 15 23:07:27 xxxxx kernel: ll header: ff:ff:ff:ff:ff:ff:e2:9f:db:f4:9b:e1:08:06
            Nov 15 23:07:28 xxxxx kernel: martian source 10.0.12.47 from 10.0.12.51, on dev usb0
            Nov 15 23:07:28 xxxxx kernel: ll header: ff:ff:ff:ff:ff:ff:e2:9f:db:f4:9b:e1:08:06

            Kommentar


            • #7
              Habe folgendes fuer dich gefunden....

              da mischen wohl zu viele dienste mit....

              schau mal dort:


              http://www.linuxforen.de/forums/show....php?s=&thread id=98669&highlight=martian+source



              http://www.linuxforen.de/forums/show....php?s=&thread id=18358&highlight=martian+source


              gruss hekto
              Gruß
              Hekto

              Kommentar

              Lädt...
              X