Ankündigung

Einklappen
Keine Ankündigung bisher.

Problem beim installieren von php5

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Problem beim installieren von php5

    Hallo zusammen!!!

    Ich richte mir gerade ein neues LAMP ein, oder besser gesagt ich versuche es!!
    Linux ist SUSE 9.3 (war bei einem Helft dabei)
    MySQL 5 (mysql-standard-5.0.13-rc-linux-i686.tar.gz)
    und
    Apache2 (httpd-2.0.54.tar.gz)
    funktionieren bereits

    Nun versuche ich php5 zu installieren
    Version: php-5.0.5.tar.gz

    Bei „make install“ briecht die Installation recht schnelle ab.
    Die Fehlermeldung:

    Code:
    suse:/usr/local/php-5.0.5 # make install
    Installing PHP SAPI module:       apache2handler
    /usr/local/apache2/build/instdso.sh SH_LIBTOOL='/usr/local/apache2/build/libtool' libphp5.la /usr/local/apache2/modules
    /usr/local/apache2/build/libtool --mode=install cp libphp5.la /usr/local/apache2/modules/
    libtool: install: error: cannot install `libphp5.la' to a directory not ending in /usr/local/php-5.0.5/libs
    apxs:Error: Command failed with rc=65536
    der Hinweis: apxs:Error lässt doch auf ein Apacheproblem schließen???? Oder???

    Wer kann mir helfen?? Wer weiß da Rat??

    Danke und Gruß an Alle

    Klaus ;-(


  • #2
    apxs hat in der tat was mit apache zu tun...
    mhm.. du bist jetzt schond er 2. mit einem apxs problem...

    beschreib doch mal genau was du bis jetzt geamcht hast und was du jetzt vor hast


    und guter rat nebenbei... nimm NICHT suse... dir sollte schon aufgefallen sein, das suse anders ist

    Kommentar


    • #3
      Hi@Sclot

      Ok, was hab ich bis jetzt gemacht!!!

      Ich habe mir SUSE 9.3 besorgt und installiert.
      Standardpakete, mit keines Office, und Samba.

      Anschließend habe ich von der SUSE DVD apache2, php (leider nur 4 vorhanden), und MySQL(4.x) installiert.

      Hat auch funktioniert, nur!!!!
      - meine php-scripte / Webseiten liefen nicht sauber (vermutlich irgendwas in der Konfiguration)
      - MySQL lief nur mit dem root Passwort -> ungünstig -> eine Änderung wollte MySQL nicht akzeptieren

      Resultat -> Apache, php, MySQL entfernen.

      Anschließend habe ich die Module selber kompiliert und installiert.
      MySQL 5
      Apache2
      php5 -> mit dem bereits geschilderten Ergebnis

      ach ja,, so Sachen wie gd, openssl, jpeg*, freetype habe ich von SUSE übernommen.

      Die Installation von MySQL war OK, somit schildere ich dir mal die Installation von Apache und php.

      Apache -> httpd-2.0.54.tar.gz
      - entpackt einem Dummyverzeichnis (weiß nicht mehr wo)
      anschließend:
      Code:
      ./configure \
      --prefix=/usr/local/apache2 \
      --enable-modules=all \
      --enable-ssl \
      --enable-so \
      --with-ssl=/usr/include/openssl 
      
      make
      
      make install
      
      cp /usr/local/apache2/bin/apachectl  /etc/init.d/apacheStart
      
      cd /etc/rc.d/rc2.d
      ln -s ../apacheStart S20apacheStart
      ln -s ../apacheStart K20apacheStart
      cd ../rc3.d
      ln -s ../apacheStart S30apacheStart
      ln -s ../apacheStart K30apacheStart
      in der Datei /etc/services den Port für Apache ergänzen
      Code:
      http             80/tcp    # World Wide Web HTTP
      http             80/udp    # World Wide Web HTTP
      der Apche life nun auch und liegt im Verzeichnis /usr/local/apache2


      php5 -> php-5.0.5.tar.gz
      - entpackt nach /usr/local/php-5.0.5
      anschließend:

      Code:
      cd /usr/local/php-5.0.5
      
      ./configure \
      --with-apxs2=/usr/local/apache2/bin/apxs \
      --with-mysql=/usr/local/mysql \
      --with-zlib-dir=/usr/lib \
      --with-gd=/usr/local/gd \
      --with-config-file-path=/usr/local/lib/php.ini \
      --enable-versioning \
      --enable-track-vars=yes \
      --enable-url-includes \
      --enable-sysvshm=yes \
      --enable-ftp \
      --enable-calandar \
      --enable-shared=yes \
      --enable-static=yes  \
      --enable-fast-install=yes \
      --with-gnu-ld \
      --disable-libtool-lock  \
      --with-pic
      
      make
      
      make install
      make install -> und hier trat die Fehlermeldung auf!!!!

      *** die Einstellungen wie ich sie dir hier angegeben habe sind exakt jene, mit der ich auch installiert haben!!! Ich habe alles einem Shell-Script geschrieben!! ***

      Was könnte ich nun machen / wie könnte ich das Problem lösen!!!
      Alternative 1: es liegt ggf daran das der Apache2 kein „mod_php5“ hat -> habe zumindest keines gefunden in der Datei /usr/local/apache2/includes (da sind noch andere Module drin, wie z.B mod_ssl.h). Ich muss mal im Internet suchen ob ich da einen Hinweis finde ob php5 ein solches Modul benötigt.

      Alternative 2: es könnte daran liegen, dass ich auf dem System vorher die Standardkomponenten Apache, php von SUSE installiert hatte, und diese nicht komplett deinstalliert wurden. Somit könnte ich das Gesamte System neu installieren um anschließend eine neue und hoffentlich saubere Installation von LAMP zu erzielen.

      Alternative 3: Wenn alles nichts hilft, dann installiere ich LAMP mit dem Apache 1.3!!

      Zu deinen Guten Rat!!!
      Warum nicht SUSE??? Und welches System sollte ich dann nehmen??? Habe noch eine alter Version von Debian und RedHeat, sowie von Mandrake. Aber die sind mindestens 4 Jahre alt!!! Was ist wenn ich SUSE nur als Grundversion nehme und darauf ein Apache, mysql und php aufsetze??

      Gruß und Danke
      Klaus!!

      Kommentar


      • #4
        et hatt jeklappt!!!!!!!!

        Hallo erstmal, un habich es endlich am laufen!!

        Vermutete Ursache:
        in der ersten Installation habe ich php5 und apache unter /usr/local/** installiert. So hab ich es in einigeb Foren / Tutorials gelesen und mich danach orientiert.

        Nach der Standardinstallation von SUSE, also mit dem YAST und so, liegen php(4) und apache unter /usr/share/***.

        Die Pfade hab ich dann auch für mein Apache2 und php5 genommen.
        Und dannnnnnn ..... hats geklappt!!!
        Warum???? keine Ahnung!!!
        Die configure-Parameter waren jeweils die selben, mit Ausnahme der Pfade !!

        Danke an alle!!

        )

        Kommentar

        Lädt...
        X