Ankündigung

Einklappen
Keine Ankündigung bisher.

[Erledigt] apache Verzeichnisstrucktur

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Erledigt] apache Verzeichnisstrucktur

    hi

    sagt mal wie bekomme ich die verzeichnisstrücktur ausgeblendet, die ich erhalte wenn ich auf den server zugreife?

    also ich bekomme da die ganzen ordner so angezeigt und auch die scripts. man kann die sogar speichern auf dem eigenen rechner. das gefällt mir garnicht...wie sagt man apache, dass es das nicht anzeigen darf?

    liebe grüße,
    fabians


  • #2
    Nicht anzeigen?: hau ne index.html rein und gut.
    Sperren: .htaccess.
    Diese Erweiterung ist EXPERIMENTELL.
    [...]
    Seien Sie gewarnt und verwenden Sie diese Erweiterung auf eigenes Risiko..

    Kommentar


    • #3
      Options -Indexes
      In der httpd.conf nach Options suchen. Wo/In welchen Abschnitten wird Indexes bereits gesetzt?
      Beispiel
      Code:
      <Directory />
          Options FollowSymLinks -Indexes
          AllowOverride All
      </Directory>
      Für sämtliche Verzeichnisse den Autouindex unterbinden.


      http://httpd.apache.org/docs/2.0/mod/mod_autoindex.html

      Kommentar


      • #4
        Schreibe in die httpd.conf (bzw. ersetze):
        IndexIgnore *

        Kommentar


        • #5
          Das sagt dem Apache: Zeige die Verzeichnisliste an, ausgenommen alle Dateien/Verzeichnisse. Also "Wasch mich, aber mach mich nicht naß"
          Dann doch besser komplett abschalten

          Kommentar


          • #6
            Zitat von Bruchpilot
            Das sagt dem Apache: Zeige die Verzeichnisliste an, ausgenommen alle Dateien/Verzeichnisse. Also "Wasch mich, aber mach mich nicht naß"
            Dann doch besser komplett abschalten
            mh... also das mit .htaccess hört sich gut und sicher an. also was muss ich in die .htaccess reinschreiben? weil die user sollen ja noch an die html-dokumente drankommen...

            liebe grüße,
            fabians

            Kommentar


            • #7
              Code:
              IndexIgnore *
              Option -Indexes
              Die Rechte dafür können auf höherer Ebene eingeschränkt sein. Dann kannst Du an dieser Stelle nichts mehr ändern bis die Rechte freigeschaltet werden.

              Kommentar


              • #8
                thx

                Kommentar


                • #9
                  So, dann eben nochmal hier meine Frage wegen der Struktur, da das eigentlich Thema ja schon wieder im Müll ist.

                  Ich hab das so geändert.



                  .. und ich hab den Apache neu gestartet. Aber es geht nicht. Wieso?!?

                  Kommentar


                  • #10
                    Was heißt "geht nicht"?

                    Kommentar


                    • #11
                      Dass das Verzeichnis immer noch angezeigt wird, obowhl ich das - gesetzt habe.

                      Kommentar


                      • #12
                        Datei gespeichert & Apache neu gestartet?

                        Kommentar


                        • #13
                          Ja ...

                          Kommentar


                          • #14
                            Und was erwartest du jetzt von uns für eine Antwort?

                            Das ist der richtige Befehl. Du hast ihn offenbar falsch umgesetzt.
                            http://www.lugbz.org/documents/smart...html#beprecise

                            Kommentar


                            • #15
                              Sorry ja?!

                              Du kannst nix dafür. Aber der nette Admin hier, hat meinen ersten Beitrag in den Müll verbannt.
                              Da komm mir bitte nicht, wie man richtig Fragen stellt.

                              Kommentar

                              Lädt...
                              X