Ankündigung

Einklappen
Keine Ankündigung bisher.

[Erledigt] Wie starte ich PHP ?

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Erledigt] Wie starte ich PHP ?

    Hallo zusammen,
    seit gestern habe ich apache 2.2.8 am Laufen und jetzt auch den:
    php 5.2.6-win32-installer geholt und installiert (habe XP).
    So und jetzt frage ich mich, wie starte ich das oder wie muß ich das machen, daß ich eine .php Datei aufrufen kann !?
    Bei der Installation habe ich den apache zwar angegeben, aber wie ich das ganze jetzt zum Laufen bringe ist mir nicht ganz klar !?
    In der config ist das Modul apache22.dll eingetragen.

    Besten Dank für jeden Tip !
    Der Indianer ist nicht das Problem, vielmehr sein Pferd !


  • #2
    Mach den Browser auf und gib http://localhost ein. Der Apache muss natuerlich gestartet sein.

    Auch mal hier vorbeischauen:
    apache friends - xampp
    "Mein Name ist Lohse, ich kaufe hier ein."

    Kommentar


    • #3
      Ohjee ...

      Hallo Chriz,
      unter localhost kommt bei mir nix !?
      Ich hab mir jetzt das XAMPP geholt und installiert, komischerweise zeigt es mir im Kontrollfenster bei apache nur START an. Wenn ich starte wechselt es nicht, der apache scheint aber zu laufen !? MYSQL hat die Admin Funktion und läuft. Der apache beharrt auf Port 80, obgleich ich ihm in der conf den 8888 zugewiesen habe - also das verstehe wer will ...
      Auf jeden Fall geht jetzt gar nüschd mehr.

      Vorher hatte ich ja den apache 2.2.8 alleine installiert und da kam ich auf Anhieb vom Internet aus drauf. Nur das mit php hat nicht geklappt.

      Was meinste soll ich jetzt machen ?
      Der Indianer ist nicht das Problem, vielmehr sein Pferd !

      Kommentar


      • #4
        Der apache beharrt auf Port 80, obgleich ich ihm in der conf den 8888 zugewiesen habe - also das verstehe wer will ...
        Bei jeder Änderung der Konfiguration muss der Apache neugestartet werden.#


        Ich hab auch bei meinem XAMPP Probleme den Apache zu starten/stoppen, aber nur wenn der Apache als Service (svc) läuft.

        Kommentar


        • #5
          Neuinstallation

          So, jetzt habe ich das Geraffel entfernt und wieder den 2.2.8 installiert, das läuft einwandfrei und ich komme wieder übers Internet auf meinen Server !

          Dann fange ich jetzt mit php neu an und installiere nochmal php5.2.6 und melde mich wieder ...
          Der Indianer ist nicht das Problem, vielmehr sein Pferd !

          Kommentar


          • #6
            guckst du hier: http://www.php.de/php-einsteiger/164...e-ausgabe.html

            Kommentar


            • #7
              php installiert

              So, php ist wieder drauf (bei der Installation habe ich
              angegeben für apache 2.2)
              und jetzt kommt die Meldung (im DOS Fenster):

              Could not open input file: PEAR\go.pear.phar

              Apache läuft und in der Config steht:
              PHPIniDir "C:/PHP/"
              LoadModule php5_module "C:/PHP/php5apache2_2.dll"

              Fehlt hier noch die Angabe des PEAR Verzeichnisses oder
              woran kann das liegen, daß er das nicht findet ?
              Der Indianer ist nicht das Problem, vielmehr sein Pferd !

              Kommentar


              • #8
                wenn Du die Dateien von da startest? /htdocs/

                K.-D.

                Kommentar


                • #9
                  das geht ...

                  dann kommt im Browser: It works!
                  Das kommt auch, wenn ich übers Internet reinkomme !
                  Der Indianer ist nicht das Problem, vielmehr sein Pferd !

                  Kommentar


                  • #10
                    Wann, dann?
                    --

                    „Emoticons machen einen Beitrag etwas freundlicher. Deine wirken zwar fachlich richtig sein, aber meist ziemlich uninteressant.
                    Wenn man nur Text sieht, haben viele junge Entwickler keine interesse, diese stumpfen Texte zu lesen.“


                    --

                    Kommentar


                    • #11
                      Soll ich mich jetzt selbst zitieren? Ok!

                      Kommentar


                      • #12
                        Ich verstehe die Frage nicht "Wann, dann" !?
                        Der Indianer ist nicht das Problem, vielmehr sein Pferd !

                        Kommentar


                        • #13
                          Zitat von sakamoto Beitrag anzeigen
                          Ich verstehe die Frage nicht "Wann, dann" !?
                          Er will wissen wie du vorgehst um "it works" zu sehen, also im Prinzip ob bei dir das gleiche ist wie bei dem Thread den ich dir schon 2 mal gepostet hab

                          Kommentar


                          • #14
                            Wenn ich http://localhost oder http://apache.mslife.net eingebe komme ich auf meinen Server und dann kommt die Anzeige. Hier kommt auch wenn ich es konfiguriert habe meine Homepage drauf - das funktioniert einwandfrei. Serverseitig habe ich kein also Problem, nur mit php komme ich keinen Schritt weiter, ich weis noch nicht einmal wo ich phpinfo() usw. eingeben soll, denn das Einzige das ich habe ich ein kleiner apache Monitor zum Starten und Stoppen.
                            Ich hab also wirklich 'noch' keine Ahnung von der Geschichte und brauche immer irgendwas wo funktioniert, damit ich damit 'basteln' kann. Dann sehe ich auch was heraus kommt, nur Momentan sehe ich nix.
                            Ich habe einige .php Dateien, die ich gerne laufen lassen würde, aber wenn ich die Aufrufe passiert nichts, weil php offensichtlich nicht läuft. Dafür fehlt mir die Kontrolle, bzw. auch so ein Monitörchen ...
                            Der Indianer ist nicht das Problem, vielmehr sein Pferd !

                            Kommentar


                            • #15
                              Ich habe einige .php Dateien, die ich gerne laufen lassen würde, aber wenn ich die Aufrufe passiert nichts, weil php offensichtlich nicht läuft. Dafür fehlt mir die Kontrolle, bzw. auch so ein Monitörchen ...
                              Und warum igonierst Du cycaps Postings? Im verlinkten Thread wird genau das erklärt.
                              --

                              „Emoticons machen einen Beitrag etwas freundlicher. Deine wirken zwar fachlich richtig sein, aber meist ziemlich uninteressant.
                              Wenn man nur Text sieht, haben viele junge Entwickler keine interesse, diese stumpfen Texte zu lesen.“


                              --

                              Kommentar

                              Lädt...
                              X