Ankündigung

Einklappen
Keine Ankündigung bisher.

php 8.0.13 Extension API missmatch

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • php 8.0.13 Extension API missmatch

    Hallo
    Habe mir die 8.0.13 (php-8.0.13-Win32-vs16-x64) von php.net geladen.
    Kann keine der benötigten Erweiterungen laden, da ich immer die Meldung bekomme, dass die API nicht übereinstimmt. Dachte eigentlich, dass das alles passen müsste, wenn man es direkt von php.net lädt.

    Beim Start von Apache erhalte ich folgende Log-Einträge

    Code:
    Zend OPcache requires Zend Engine API version 320190902.
    The Zend Engine API version 420200930 which is installed, is newer.
    Contact Zend Technologies at http://www.zend.com/ for a later version of Zend OPcache.
    
    PHP Warning:  PHP Startup: bz2: Unable to initialize module\nModule compiled with module API=20190902\nPHP    compiled with module API=20200930\nThese options need to match\n in Unknown on line 0
    PHP Warning:  PHP Startup: mbstring: Unable to initialize module\nModule compiled with module API=20190902\nPHP    compiled with module API=20200930\nThese options need to match\n in Unknown on line 0
    PHP Warning:  PHP Startup: openssl: Unable to initialize module\nModule compiled with module API=20190902\nPHP    compiled with module API=20200930\nThese options need to match\n in Unknown on line 0
    PHP Warning:  PHP Startup: sockets: Unable to initialize module\nModule compiled with module API=20190902\nPHP    compiled with module API=20200930\nThese options need to match\n in Unknown on line 0
    php.ini
    Code:
     extension_dir = "ext"    
     extension=bz2
    ;extension=curl
    ;extension=ffi
    ;extension=ftp
    ;extension=fileinfo
    ;extension=gd
    ;extension=gettext
    ;extension=gmp
    ;extension=intl
    ;extension=imap
    ;extension=ldap
    extension=mbstring
    ;extension=exif    
    
     ; Must be after mbstring as it depends on it
    
    ;extension=mysqli
    ;extension=oci8_12c  
    
    ; Use with Oracle Database 12c Instant Client
    ;extension=oci8_19  
    
    ; Use with Oracle Database 19 Instant Client
    ;extension=odbc
    extension=openssl
    ;extension=pdo_firebird
    ;extension=pdo_mysql
    ;extension=pdo_oci
    ;extension=pdo_odbc
    ;extension=pdo_pgsql
    ;extension=pdo_sqlite
    ;extension=pgsql
    ;extension=shmop  
    ; The MIBS data available in the PHP distribution must be installed. ; See http://www.php.net/manual/en/snmp.installation.php
    ;extension=snmp  
    ;extension=soap
    extension=sockets
    ;extension=sodium
    ;extension=sqlite3
    ;extension=tidy
    ;extension=xsl  
    
    zend_extension=opcache
    apache.conf
    Code:
     #
    # XAMPP settings
    #
    
    <IfModule env_module>
        SetEnv MIBDIRS "C:/xampp/php8.0.13/extras/mibs"
        SetEnv MYSQL_HOME "\\xampp\\mysql\\bin"
        SetEnv OPENSSL_CONF "C:/xampp/apache/bin/openssl.cnf"
        SetEnv PHP_PEAR_SYSCONF_DIR "\\xampp\\php8.0.13"
        SetEnv PHPRC "\\xampp\\php8.0.13"
        SetEnv TMP "\\xampp\\tmp"
    </IfModule>
    
    #
    # PHP-Module setup
    #
    LoadFile "C:/xampp/php8.0.13/php8ts.dll"
    LoadFile "C:/xampp/php8.0.13/libpq.dll"
    LoadModule php_module "C:/xampp/php8.0.13/php8apache2_4.dll"
    
    <FilesMatch "\.php$">
        SetHandler application/x-httpd-php
    </FilesMatch>
    <FilesMatch "\.phps$">
        SetHandler application/x-httpd-php-source
    </FilesMatch>
    
    #
    # PHP-CGI setup
    #
    #<FilesMatch "\.php$">
    #    SetHandler application/x-httpd-php-cgi
    #</FilesMatch>
    #<IfModule actions_module>
    #    Action application/x-httpd-php-cgi "/php-cgi/php-cgi.exe"
    #</IfModule>
    
    
    <IfModule php_module>
        PHPINIDir "C:/xampp/php8.0.13"
    </IfModule>
    
    <IfModule mime_module>
        AddType text/html .php .phps
    </IfModule>
    
    ScriptAlias /php-cgi/ "C:/xampp/php8.0.13/"
    <Directory "C:/xampp/php8.0.13">
        AllowOverride All
        Options None
        Require all denied
        <Files "php-cgi.exe">
              Require all granted
        </Files>
    </Directory>
    
    <Directory "C:/xampp/cgi-bin">
        <FilesMatch "\.php$">
            SetHandler cgi-script
        </FilesMatch>
        <FilesMatch "\.phps$">
            SetHandler None
        </FilesMatch>
    </Directory>
    Der Unterschied zwischen dem richtigen Wort und dem beinahe richtigen ist derselbe Unterschied wie zwischen dem Blitz und einem Glühwürmchen.


  • #2
    MOD: Verschoben von PHP Einsteiger

    Kommentar


    • #3
      dann hast du wohl deine php version upgedated aber nicht die extensions.
      diese müssen übereinstimmen und die meisten sind auch im download für windows enthalten.
      sorry, shift-taste kaputt

      Kommentar


      • #4
        Zitat von Meister1900 Beitrag anzeigen
        dann hast du wohl deine php version upgedated aber nicht die extensions.
        diese müssen übereinstimmen und die meisten sind auch im download für windows enthalten.
        Ich habe alle Dateien vollständig aus dem Download übernommen. Um auch wirklich Sicher zu sein, dass nichts aus einer anderen PHP-Version geladen werden kann, habe ich alle PHP-Ordner umbenannt.
        Hab inzwischen 8.0.12 geladen und damit überhaupt kein Problem. Löst aber das eigentliche Problem nicht.
        Der Unterschied zwischen dem richtigen Wort und dem beinahe richtigen ist derselbe Unterschied wie zwischen dem Blitz und einem Glühwürmchen.

        Kommentar

        Lädt...
        X