Ankündigung

Einklappen
Keine Ankündigung bisher.

500-er Fehler - cgi-Skript kann auf dem Apacheserver nicht ausgeführt werden.

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • 500-er Fehler - cgi-Skript kann auf dem Apacheserver nicht ausgeführt werden.

    Ich bin gerade dabei, Ruby zu lernen. Ich habe meinen Apacheserver auf Windows laufen, und nicht auf Linux.


    Nun bin ich gerade dabei, ein Rubytutorium (auf tutorialspoint.com) zu machen, und ich beabsichtige, folgendes cgi-Script durch den Aufruf von localhost/test.cgi laufen zu lassen. Die Datei test.cgi habe ich in htdocs hineinkopiert, ihr Inhalt ist folgender:


    Code:
    #!/usr/bin/ruby
    
    
    require "cgi"
    
    cgi = CGI.new("html4")
    
    cgi.out {
    
    cgi.html {
    
    cgi.head { "\n"+cgi.title{"This Is a Test"} } +
    
    cgi.body { "\n"+
    
    cgi.form {"\n"+
    
    cgi.hr +
    
    cgi.h1 { "A Form: " } + "\n"+
    
    cgi.textarea("get_text") +"\n"+
    
    cgi.br +
    
    cgi.submit
    
    }
    
    }
    
    }
    
    }
    Ich habe die httpd.conf-Datei wie folgt modifiziert und freilich den Server neu gestartet.

    #
    # "C:/xampp/cgi-bin" should be changed to whatever your ScriptAliased
    # CGI directory exists, if you have that configured.
    #

    Code:
    <Directory "C:/xampp/cgi-bin">
    
    AllowOverride All
    
    Options None
    
    Options +ExecCGI
    
    AddHandler cgi-script .cgi .pl .py
    
    Require all granted
    
    </Directory>
    Ich bekomme aber einen 500-er Fehler, woher könnte dieser rühren?





  • #2
    Code:
    #!/usr/bin/ruby
    (..)
    Code:
    AddHandler cgi-script .cgi .pl .py
    Ich habe meinen Apacheserver auf Windows laufen,
    (..)
    Ich bekomme aber einen 500-er Fehler, woher könnte dieser rühren?
    sollte ja im erroir log stehen, denke aber nicht, du hast /usr/bin/ruby auf windows so am start -
    https://editrocket.com/articles/ruby...e_windows.html

    Kommentar


    • #3
      Danke, ich kuck mal

      Kommentar

      Lädt...
      X