Ankündigung

Einklappen
Keine Ankündigung bisher.

image wird nur binär angezeigt

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • image wird nur binär angezeigt

    Hello, ich habe folgendes Problem: Ein in der Datenbank gespeichertes jpeg soll korrekt angezeigt werden. Bekomme aber nur die Fehlermeldung es sei kaputt.
    Wenn ich den header auskommentiere zeigt mir der Browser binärcode an. Hab überprüft ob das image in der DB kaputt ist, aber irfan view z.B zeigt mir ein fehlerfreies
    Bild an. Hab die Klasse showPicture in der ich über mysql das bild lade. Doch beim Ausgeben mit echo ist es angeblich kaputt.

    hab als Vorlage für meine website Reimers und Thies PHP und Mysql. ich weiss, ist alt aber na ja


  • #2
    Naja, wenn du nicht den passenden HTTP-Header ausgibst, woher soll der Browser wissen, dass er ein Bild darstellen soll?

    Kommentar


    • #3
      wenn ich den header image/jpeg ausgebe, bekomme ich die Fehlermeldung dass die Grafik Fehler enthält.
      die meldung ist ein <alt> welches der browser erzeugt.

      Kommentar


      • #4
        Entweder ist es kein jpg, oder du hast vor oder nach dem Bild noch andere Ausgaben. Poste ggf. eine Screenshot vom Anfang der Ausgabe. (dem "binärcode")

        Kommentar


        • #5
          Zitat von Kraftnerz Beitrag anzeigen
          wenn ich den header image/jpeg ausgebe, bekomme ich die Fehlermeldung dass die Grafik Fehler enthält.
          Dann gibst du wohl keine gültigen Bilddaten aus. Also solltest du dir diese Daten mal anschauen, ob diese korrekt sind.

          Kommentar


          • #6
            @erc
            so sieht es aus wenn ich den header auskommentiere:
            ÿØÿàJFIFÿþ l a±œ’[æ'=F¯Èÿø*_‚Lš‡ sª¹qÀ@ˆ9,ê[Û> üñ‡ÅMZ3¤h7zDV{6– ChÙ.fš_Ý*€ÎBáâgBSš‚RrsJÑWî¯éo’>úž"œ)©NJ6KW£oed÷è‘ñ ‹x{UÔî'k;Y™™Óˆ•r?‰¶ª… gs¼pE5¼#®ÛH>Ñj¢&ô¬Þ\q‡ÎÂC*3Œ…RªÌ¿0#9Ÿ¼³þ̾ø{¡Û¶£ ö¹HÌš…̶r]IªF!f‹hbT.ÐÛWhù+â>‡ðªÈܬZºëÃdŒ‹[kH`PJ©†Ò0ˆTÝç8+°çåÀ–:4Ûu çÈäã?u¥m“{»;hµ×±¶3ö“²‹åÙ>Wv¯kÝh¶¾ú§ê|àí/QtÔôøg³ q'˜>ugSœ£²©Ä¦ ÈûÇôöÔõ 2çQðö£æÆc”Ër²JÈUÊs’ ¨,¨VÏÊ—ž<Ò|%us>–ºCß©hâQ ¼åVBÈíó+À’ Ëd$ÀJ¬*å•õÙïâ2Úøµuy,ÚîîiwKR!9<ÄÃnÐÄlRB™U€Và‚\mRJ Sž&2i+F6ZêÝõz½=;–/þÍZUTcÐq…ìÛ¼¯µ¬’èïs÷ƒÃ×°Íƒv;ÏÉXRsÀ råAÅz¥‡Št}9Ò9µm2ÚHÊ™’KØ‘”¤³—'Ëþ,ƒ“µKð ð}÷Çoiž’æ™W[6æ5·-=¼ê6–rû±rNcÉÞ¸1Ÿ¼¿x‡ö†ñÓÜMozc˜L}-º"d!w†&Õ'p# `>³¿²Ô!ÅNWQ¥{Ôå²÷š‹••Ÿ[i*™ÂEãý¢¥¡

            und so weiter,

            hellbringer
            die bilder in der Datenbank sind JPG, lassen sich mit irfan view usw anzeigen, nur der browser zeigt mir nix an

            Kommentar


            • #7
              Zitat von Kraftnerz Beitrag anzeigen
              hab als Vorlage für meine website Reimers und Thies PHP und Mysql. ich weiss, ist alt aber na ja
              Ich kenne das Buch nicht aber es scheint ein uraltes PHP5-Buch zu sein - das hat schon seinen Grund warum das für keine zwei Euro verramscht wird …

              Zitat von Kraftnerz Beitrag anzeigen
              so sieht es aus wenn ich den header auskommentiere: […]
              Das scheint mir kein gültiger Anfang einer jpg-Datei zu sein wobei ich nicht ausschließen würde dass das Forum da was kaputt gemacht hat - auch wenn das »JFIF« vorhanden ist, wenn auch an der falschen Stelle. Aber ohne sich das ganze live anschauen zu können wird das wohl nichts werden, evtl. hilft es erstmal auch den Code zum Speichern und Auslesen der Bilder zu kennen (auf das allernötigste gekürzt, nicht einfach alles! Und nicht als Bild sondern als Text (als Quelltext markieren)!). Achja: du lieferst das Bild schon als separaten Request aus, oder? Zusammen mit dem HTML-Code geht nicht bzw. nur als Data-URI.

              Aber: was machen die Bilder überhaupt in der Datenbank? Da gehören die imho nicht hin …

              Kommentar


              • #8
                Das sieht nach einem jpg aus, aber nicht nach einem Screenshot. Ich bin mir aber auch nicht sicher, ob man das Problem überhaupt auf Screenshot sehen würde. Du kannst davon ausgehen, du hast vor der Ausgabe des Bildes noch Zeichen stehen wie z.B. Zeilenumbrüche, Leerzeichen, Tabs etc.
                Eine häufige Ursache dafür sind schließende PHP Tags in includeten Dateien.

                Z.B. angenommen du hast eine db.php die du in dein Script includest. Wenn in der db.php hinter den schließenden Tag etwas steht, dann wird das mit ausgegeben.

                PHP-Code:
                <?php
                //db zeugs
                ?>

                //Denk dir die Zeile Weg. Das Forum entfernt Zeilenumbrüche am Ende von Codeblöcken.
                Die zwei Zeilenumbrüche am Ende werden mit ausgegeben. Aus dem Grund hat es sich als Standard etabliert, keine schleißende PHP Tags am Ende von PHP Dateien zu verwenden

                PHP-Code:
                <?php
                //db zeugs


                //Denk dir die Zeile Weg.
                Die Zeilenumbrüche am Ende sind "PHP Code" und werden vom Interpreter übersprungen/ignoriert.

                Sollte das Problem nicht so offentichtlich sein, und ggf. viele includes oder ähnliche suasgeführt werde, kannst du mit quer durch den Code gestreuten echos das Problem eingrenzen.

                Dein Bild Script:
                PHP-Code:
                <?php
                echo 1;
                include(
                'db.php');
                echo 
                2;
                include(
                'foo.php');
                echo 
                3;

                machwas();
                machnochwas();
                echo 
                4;

                bildausgeben();
                An der Stelle wo zwischen den Zahlen ein Lücke auftaucht musst du genauer schauen.

                Kommentar

                Lädt...
                X