Ankündigung

Einklappen
Keine Ankündigung bisher.

Website im localhost nicht mehr erreichbar.

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Website im localhost nicht mehr erreichbar.

    Hallo,

    ich habe meine Website von PHP5.6 auf PHP7.3 aktualisiert. Hierzu habe ich immer wieder die Seite im localhost aufgerufen, was problemlos ging.
    Seit neuestem geht leider aber nichts mehr. Bekomme lediglich folgende Meldung:

    Serverfehler!

    Die Anfrage kann nicht beantwortet werden, da im Server ein interner Fehler aufgetreten ist. Der Server ist entweder überlastet oder ein Fehler in einem CGI-Skript ist aufgetreten.

    Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
    Error 500 localhost
    Apache/2.4.39 (Win64) OpenSSL/1.1.1c PHP/7.3.8
    Unter xampp habe ich nur einen Ordner cgi-bin gefunden mit den Dateien cgi.cgi und prltest.cgi. Aber die können doch nicht gemeint sein? Mir sagen sie nichts.
    Bisher lief ja alles problemlos, sogar nach der neuesten xampp-Installation (mit php7.3).

    Habe jetzt xampp neu installieren wollen und bekam die Meldung, daß die UAC stört. Also hab ich es ganz herunter geregelt, Virusscanner gestoppt und Windows-Firewall abgeschaltet und erst dann als Administrator installiert. Dann natürlich alles wiederhergestellt.

    Ich kann im xampp Control Panel Apache (Ports 80, 443) und Mysql (Port 3306) problemlos starten.
    Über http://localhost/phpmyadmin/index.php bekomme ich auch einwandfrei Zugriff auf die Datenbank.

    Aber auf die Hompage habe ich keinen Zugriff, auch über 127.0.0.1 nicht. Anmelde-Parameter habe ich überprüft, die sind OK. Auch unter Windows/system32/Drives/etc/hosts
    scheint alles i.O. zu sein. Eintrag:
    # localhost name resolution is handled within DNS itself.
    # 127.0.0.1 localhost
    # ::1 localhost
    Ich bin am Ende meiner (evtl. nicht vorhandenen) Weisheit. Am PC ist nichts geändert worden und wie gesagt, bisher alles normal funktioniert. Kann bitte jemand helfen?


  • #2
    Was steht in den Fehler-Logs?
    Debugging: Finde DEINE Fehler selbst! | Gegen Probleme beim E-Mail-Versand | Sicheres Passwort-Hashing | Includes niemals ohne __DIR__
    PHP.de Wissenssammlung | Kein Support per PN

    Kommentar


    • #3
      Zitat von Hardyy Beitrag anzeigen
      Auch unter Windows/system32/Drives/etc/hosts
      scheint alles i.O. zu sein. Eintrag: [...]
      Das sind alles Kommentare ... Aber wie schon geschrieben: schau ins Errorlog.

      Kommentar


      • #4
        Bei den hosts muss das Doppelkreuzzeichen weg sonst ist es ein Kommentar.
        Code:
        # localhost name resolution is handled within DNS itself.
        127.0.0.1 localhost
        ::1 localhost

        Kommentar


        • #5
          In der default_error_stack-002174-000000.txt - Datei von heute habe ich diesen Eintrag, der mir leider überhaupt nichts sagt.

          [ *** Error Stack Dump BEGIN *** ]
          ---------------------------------------
          ...Stack Protected Flag:...............[1].
          ...Stack Expandable Flag:..............[1].
          ...Stack Size Limited Flag:............[1].
          ...Stack Size Limit Size:..............[256].
          ...Stack Internal Error Flag:..........[0].
          ...Stack Max Entries:..................[16].
          ...Stack Entries Count:................[2].
          ...Stack Entries Address:..............[00000000010589E0].
          ---------------------------------------
          ......ERROR ENTRY: [0]
          ---------------------------------------
          .........User Interface Flag:..........[1].
          .........Offending Item:...............[system\currentcontrolset\services\esrv_queencreek].
          .........Proposed Solution:............[Please Check Your Start Key / Values Specifications.].
          .........Reported Inline:..............[0].
          .........Out Of Cycle Flag:............[1].
          .........Thread ID:....................[8796].
          .........Last System Error Code:.......[0x0].
          .........Error Path:...................[APPLICATION PATH].
          .........Error Severity:...............[UN-RECOVERABLE].
          .........Untranslated Error Code:......[670].
          .........Error Code:...................[670: Unable To Check The List Of Granted vs. Required Consents.].
          .........Error Sample:.................[0].
          .........Error Elapsed Time (in ms):...[0].
          .........Error Time:...................[Tue Aug 20 11:38:21 2019].
          .........Error File:...................[(...)\driver.c].
          .........Error Line:...................[25868].
          ---------------------------------------
          ......ERROR ENTRY: [1]
          ---------------------------------------
          .........Reported Inline:..............[0].
          .........Out Of Cycle Flag:............[1].
          .........Thread ID:....................[8796].
          .........Last System Error Code:.......[0x0].
          .........Error Path:...................[APPLICATION PATH].
          .........Error Severity:...............[RECOVERABLE].
          .........Untranslated Error Code:......[607].
          .........Error Code:...................[607: Unable To Open A Registry Key.].
          .........Error Sample:.................[0].
          .........Error Elapsed Time (in ms):...[0].
          .........Error Time:...................[Tue Aug 20 11:38:21 2019].
          .........Error File:...................[(...)\driver.c].
          .........Error Line:...................[25875].
          ---------------------------------------
          [ *** Error Stack Dump END *** ]
          ---------------------------------------
          "C:\Program Files\Intel\SUR\QUEENCREEK\x64\esrv_svc.exe" "--START" "--depend_on_key" "system\currentcontrolset\services\esrv_queencreek " "--address" "127.0.0.1" "--port" "49350" "--time_in_ms" "--pause" "5000" "--watchdog" "5" "--watchdog_cpu_usage_limit" "50" "--kernel_priority_boost" "--shutdown_priority_boost" "--end_on_error" "--library" "C:\Program Files\Intel\SUR\QUEENCREEK\x64\intel_modeler.dll" "--no_pl" "--device_options" " time=no generate_key_file=no performance=no in_cycle_performance=no output=w output_folder='C:\ProgramData\Intel\SUR\QUEENCREEK \intermediate_data\' upload_folder='c:\programdata\intel\sur\queencreek \collected_data' lock_xls=yes il='C:\Program Files\Intel\SUR\QUEENCREEK\x64\intel_acpi_battery_ input.dll' il='C:\Program Files\Intel\SUR\QUEENCREEK\x64\intel_wifi_input.dl l' il='C:\Program Files\Intel\SUR\QUEENCREEK\x64\devices_use_input.d ll','service=yes' il='C:\Program Files\Intel\SUR\QUEENCREEK\x64\intel_system_power_ state_input.dll' il='C:\Program Files\Intel\SUR\QUEENCREEK\x64\intel_os_input.dll' ,'clock=5000 threads=auto configuration_file=C:\Program Files\Intel\SUR\QUEENCREEK\x64\sur_os_counters.txt optimize=yes auto_min_tick=10 auto_tick_gap=5' il='C:\Program Files\Intel\SUR\QUEENCREEK\x64\intel_winstat_input .dll' il='C:\Program Files\Intel\SUR\QUEENCREEK\x64\intel_process_input .dll','C:\Program Files\Intel\SUR\QUEENCREEK\x64\process_input_optio ns.txt' il='C:\Program Files\Intel\SUR\QUEENCREEK\x64\intel_hw_input.dll' ,'configuration_file=C:\Program Files\Intel\SUR\QUEENCREEK\x64\sur_hw_config.txt' il='C:\Program Files\Intel\SUR\QUEENCREEK\x64\intel_sampler_input .dll' il='C:\Program Files\Intel\SUR\QUEENCREEK\x64\intel_sgx_input.dll ' ll='C:\Program Files\Intel\SUR\QUEENCREEK\x64\sql_logger.dll','db _differential_elaspsed_time=yes db_wal=yes db_wal_autocheckpoint=0 db_cache=yes db_cache_size=auto db_max_page_count=300000 db_synchronous=off db_journal_mode=off db_locking_mode=exclusive delayed_dctl=summarize dctl_process_delay=5000' "
          Könnt ihr damit etwas anfangen?

          Kommentar


          • #6
            Schau mal /xampp/apache/logs/error.log

            Kommentar


            • #7
              Zitat von Hardyy Beitrag anzeigen
              In der default_error_stack-002174-000000.txt - Datei von heute habe ich diesen Eintrag, der mir leider überhaupt nichts sagt.



              Könnt ihr damit etwas anfangen?
              Gemeint war sicher die error.log von PHP
              wieso Du die
              Sony® Energy Server Service
              hier postet verstehst Du wohlmöglich selbst; auch wenn die schon drei stunden alt war, als Du den Post schriebst.

              Kommentar


              • #8
                Hier meinte ich (Screenshot): https://stackoverflow.com/a/38347316/10537201
                Debugging: Finde DEINE Fehler selbst! | Gegen Probleme beim E-Mail-Versand | Sicheres Passwort-Hashing | Includes niemals ohne __DIR__
                PHP.de Wissenssammlung | Kein Support per PN

                Kommentar


                • #9
                  Apache error.log von heute

                  Code:
                  [Tue Aug 20 11:24:31.522997 2019] [ssl:warn] [pid 6004:tid 664] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
                  [Tue Aug 20 11:24:31.647993 2019] [core:warn] [pid 6004:tid 664] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
                  [Tue Aug 20 11:24:31.647993 2019] [ssl:warn] [pid 6004:tid 664] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
                  [Tue Aug 20 11:24:33.382308 2019] [mpm_winnt:notice] [pid 6004:tid 664] AH00455: Apache/2.4.39 (Win64) OpenSSL/1.1.1c PHP/7.3.8 configured -- resuming normal operations
                  [Tue Aug 20 11:24:33.382308 2019] [mpm_winnt:notice] [pid 6004:tid 664] AH00456: Apache Lounge VC15 Server built: May 29 2019 11:22:50
                  [Tue Aug 20 11:24:33.382308 2019] [core:notice] [pid 6004:tid 664] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
                  [Tue Aug 20 11:24:33.382308 2019] [mpm_winnt:notice] [pid 6004:tid 664] AH00418: Parent: Created child process 20636
                  [Tue Aug 20 11:24:33.929164 2019] [ssl:warn] [pid 20636:tid 632] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
                  [Tue Aug 20 11:24:33.976038 2019] [ssl:warn] [pid 20636:tid 632] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
                  [Tue Aug 20 11:24:34.038535 2019] [mpm_winnt:notice] [pid 20636:tid 632] AH00354: Child: Starting 150 worker threads.
                  [Tue Aug 20 11:27:54.394257 2019] [core:alert] [pid 20636:tid 1864] [client ::1:4782] C:/xampp/htdocs/Aktuell/.htaccess: Expected </meta> but saw </head>
                  [Tue Aug 20 11:33:50.709033 2019] [core:alert] [pid 20636:tid 1896] [client ::1:4824] C:/xampp/htdocs/Aktuell/.htaccess: Expected </meta> but saw </head>
                  [Tue Aug 20 12:08:15.921681 2019] [ssl:warn] [pid 6176:tid 616] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
                  [Tue Aug 20 12:08:16.077929 2019] [core:warn] [pid 6176:tid 616] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
                  [Tue Aug 20 12:08:16.093550 2019] [ssl:warn] [pid 6176:tid 616] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
                  [Tue Aug 20 12:08:16.343543 2019] [mpm_winnt:notice] [pid 6176:tid 616] AH00455: Apache/2.4.39 (Win64) OpenSSL/1.1.1c PHP/7.3.8 configured -- resuming normal operations
                  [Tue Aug 20 12:08:16.343543 2019] [mpm_winnt:notice] [pid 6176:tid 616] AH00456: Apache Lounge VC15 Server built: May 29 2019 11:22:50
                  [Tue Aug 20 12:08:16.343543 2019] [core:notice] [pid 6176:tid 616] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
                  [Tue Aug 20 12:08:16.343543 2019] [mpm_winnt:notice] [pid 6176:tid 616] AH00418: Parent: Created child process 2504
                  [Tue Aug 20 12:08:16.937274 2019] [ssl:warn] [pid 2504:tid 616] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
                  [Tue Aug 20 12:08:17.015397 2019] [ssl:warn] [pid 2504:tid 616] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
                  [Tue Aug 20 12:08:17.046644 2019] [mpm_winnt:notice] [pid 2504:tid 616] AH00354: Child: Starting 150 worker threads.
                  [Tue Aug 20 13:28:31.783946 2019] [core:alert] [pid 2504:tid 1896] [client ::1:2351] C:/xampp/htdocs/Aktuell/.htaccess: Expected </meta> but saw </head>
                  [Tue Aug 20 15:30:29.355513 2019] [core:alert] [pid 2504:tid 1912] [client ::1:2891] C:/xampp/htdocs/Aktuell/.htaccess: Expected </meta> but saw </head>

                  Bin erst wieder in ca. 2 Std. am PC.

                  Kommentar


                  • #10
                    Und hast du das auch gelesen, nachgeschaut, mal im www nach den Meldungen gesucht, und so weiter.

                    Code:
                     [core:alert] [pid 2504:tid 1912] [client ::1:2891] C:/xampp/htdocs/Aktuell/.htaccess: Expected </meta> but saw </head>
                    Wie sieht die .htaccess aus zB.. und so weiter..

                    Mit dem Zertifikat gibts wohl auch nochwas.
                    Debugging: Finde DEINE Fehler selbst! | Gegen Probleme beim E-Mail-Versand | Sicheres Passwort-Hashing | Includes niemals ohne __DIR__
                    PHP.de Wissenssammlung | Kein Support per PN

                    Kommentar


                    • #11
                      Zitat von hausl Beitrag anzeigen
                      Und hast du das auch gelesen, nachgeschaut, mal im www nach den Meldungen gesucht, und so weiter.
                      Tut mir leid, aber die Meldungen sagen mir nichts und nachschauen wüßte ich nicht nach was.

                      Aber den Übeltäter habe ich gefunden: ich und meine .htaccess.
                      Sobald ich sie lösche, geht alles wieder wie gewohnt.

                      Ich muß mich nochmals in die .htaccess-Thematik einlesen.

                      Vielen Dank an alle für eure Hilfe.

                      Kommentar


                      • #12
                        Zitat von Hardyy Beitrag anzeigen
                        Aber den Übeltäter habe ich gefunden: ich und meine .htaccess.
                        Sobald ich sie lösche, geht alles wieder wie gewohnt.
                        Logisch, steht ja schon in der Fehlermeldung dass da was drinsteht was da nicht hingehört - um das herauszufinden reicht es völlig sich die Meldung mal durchzulesen. Wobei deine übersetzte Fehlermeldung beim dem 500er schlecht ist: das englische Original verweist direkt in der Fehlermeldung darauf dass man ins Errorlog schauen möge.

                        Kommentar

                        Lädt...
                        X