Ankündigung

Einklappen
Keine Ankündigung bisher.

Wildcard Apache2

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Wildcard Apache2

    Hallo,
    ich versuche mir einen dynamischen Vhost einzurichten Dazu habe ich auf einem Host (Win10) eine VM als Server (Debain 9 mit Apache2) eingerichtetet.

    Dazu versuche ich mich an diesen Anleitungen langzuhangeln:

    https://httpd.apache.org/docs/2.4/vhosts/mass.html
    https://www.chris-shaw.com/blog/usin...osts-on-apache

    Der Vhost soll folgende Anfragen entsprechend mappen:
    Code:
    dev.first.module.modules.local ---> /media/sf_Modules/first_module/dev/public
    dev.second_module.modules.local ---> /media/sf_Modules/second_module/dev/public
    sf_Modules steht für die gemeinsam genutzten Ordner zwischen Host und Client der VM und zeigt auf den Ordner modules im Host:

    Code:
    |- ...
    |- modules
    |-- first_module
    |--- dev
    |---- public
    |----- index.php
    |-- second_module
    |--- dev
    |---- public
    ​​​​​​​|----- index.php
    |- ...
    meine Vhost-Datei /etc/apache2/sites-available/modules.local.conf
    Code:
    # /etc/apache2/sites-available/modules.local.conf
    <VirtualHost *:80>
        UseCanonicalName    Off
        ServerAlias *.*.modules.local
        VirtualDocumentRoot "/media/sf_Modules/%2/%1/public"
    </VirtualHost>
    Ich sehe aber nur die default Seite des Apachen, welcher von der Datei 000-default.conf gemappt wird
    Code:
    # 000-default.conf
    <VirtualHost *:80>
        ...
        DocumentRoot /var/www/html
        ....
    </VirtualHost>
    Warum greift mein Vhost nicht?

    Gruss Rammi


  • #2
    Hi,...10 Sichtungen und kein Ansatz? Bin ich tatsächlich der Einzige, der vor diesem Problem steht?

    Kommentar


    • #3
      Ich benutzte keinen Apache, aber müsste der Vhost nicht in sites-enabled sein? Ich glaube der Befehl heiß dazu a2ensite sitename.
      http://manpages.ubuntu.com/manpages/...dissite.8.html

      Kommentar


      • #4
        Zitat von Zeichen32 Beitrag anzeigen
        Ich benutzte keinen Apache, aber müsste der Vhost nicht in sites-enabled sein? Ich glaube der Befehl heiß dazu a2ensite sitename.
        http://manpages.ubuntu.com/manpages/...dissite.8.html
        nee nee, das passt schon. Mit a2ensite *** wird ja die coiónfig datei in den Ordner sites-enabled... Das habe ich alles getan. Die Datei liegt da auch vor.

        Jetzt bin ich ein Schritt weiter:
        Code:
        <VirtualHost *:80>
            UseCanonicalName Off
            ServerAlias *.*.modules.local
            VirtualDocumentRoot "/media/sf_Modules/%2/%1/public"
        
            <Directory "/media/sf_Modules/%2/%1/public">
                Options Indexes FollowSymLinks MultiViews
                #Options Indexes
                AllowOverride All
                Require all granted
            </Directory>
        </VirtualHost>
        ...mit folgenden Fehler
        Code:
        [Mon May 13 19:22:59.370489 2019] [authz_core:error] [pid 18975] [client 10.0.2.2:59826] AH01630: client denied by server configuration: /media/sf_Modules/first_module/dev/public/
        Die Fehlermeldung verwirrt, weil die Rechte vergeben sind: Es sind noch andere Seiten auf derselben VM, alle anderen Seiten funktionieren. Der Unterschied ist VirtualDocumentRoot vs DocumentRoot, ein Beispiel:
        Code:
        <VirtualHost *:80>
                ServerName dev.beispiel.local
                Redirect / https://dev.beispiel.local/
        </VirtualHost>
        
        <VirtualHost *:443>
                ServerName dev.beispiel.local
                ....
        
                <Directory "/media/sf_Beispiel/public">
                        Options Indexes FollowSymLinks MultiViews
                        #Options Indexes
                        AllowOverride All
                        Require all granted
                </Directory>
                ....
        </VirtualHost>
        Also hier, Anfrage an http://dev.beispiel.local wird sauber an 443 weitergeleitet und der Inhalt im Browser ausgegeben, kein Fehler, keinre Zugriffsbeschränkung...

        Kommentar


        • #5
          Muss dort das %s ggf. durch ein * ausgetauscht werden? "/media/sf_Modules/*/*/public" da die Rules ja vor dem Aufruf schon verarbeitet werden müssen?

          Code:
              <Directory "/media/sf_Modules/%2/%1/public">
                  Options Indexes FollowSymLinks MultiViews
                  #Options Indexes
                  AllowOverride All
                  Require all granted
              </Directory>
          http://eosrei.net/articles/2012/08/c...ttp-vhostalias

          Kommentar


          • #6
            Zitat von Zeichen32 Beitrag anzeigen
            Muss dort das %s ggf. durch ein * ausgetauscht werden? "/media/sf_Modules/*/*/public" da die Rules ja vor dem Aufruf schon verarbeitet werden müssen?...
            Das war es, Danke

            Kommentar

            Lädt...
            X