Ankündigung

Einklappen
Keine Ankündigung bisher.

Richtiges Einbinden einer "php.ini" für eine Webseite / mittels der Datei .htaccess?

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Richtiges Einbinden einer "php.ini" für eine Webseite / mittels der Datei .htaccess?

    Hallo,

    ich kenne mich mit WordPress aus, aber in Sachen PHP/Server bin ich (leider) Laie...

    1.) Ausgangslage:

    Da ich mit meiner WordPress-Seite Problem beim Speichern des dazugehörigen WordPress-Templates habe, teilte mir der Entwickler des Wordpress-Themes mit,
    dass der Server-Parameter von "max_input_vars = 1000" auf "max_input_vars = 7000" erhöht werden solle.

    Dies teile ich meinem Webspace-Provider entsprechend mit, der daraufhin die nachfolgende php.ini-Datei (mit dem Parameter max_input_vars = 7000) für mich erstellte.
    Hier ein Screenshot der ganzen php.ini-Datei


    Inhalt_der_PHP_ini.png


    2.) Zwischenergebnis:

    a) Ruft man hinter der WWW-Webseiten-Domain /phpinfo.php auf, werden einem dann folgende entsprechende Werte angezeigt (max_input_vars = 7000):

    Inhalt_der_phpinfo_zur_Domain.png


    Dennoch besteht trotz des Parameter "max_input_vars = 7000" das o.g. Ausgangsproblem weiter: Probleme beim Abspeichern eines WordPress Templates.

    b) Und wenn man INNERHALB der Wordpress-Anwendung eine entsprechende PHP-Info per Plugin aufruft,
    dann wird einem nach wie vor der Ausgangswert (mit nur) "max_input_vars = 1000" angezeigt!?:

    phpinfo_innerhalb_der_WordPress-Anwendung.png


    3.) Resümee:

    Da das o.g. Problem (weiterhin) besteht nehme ich an, dass der Screenshot vom Punkt 2.a) mit "max_input_vars = 7000" NICHT "zieht",
    sondern dass der Screenshot des Punktes 2.b) mit "max_input_vars = 1000" die WAHRE Aussage ist.

    Welchem der beiden Screenshots kann man letztlich trauen?


    4.) Fragen:

    Kann es sein, dass die Datei "php.ini" irgendwie (erst noch) richtig verknüpft werden muss (damit der Parameter "max_input_vars = 7000" tatsächlich "zieht")?

    Kann es sein, dass die Datei "php.ini" z.B. über die Datei .htaccess irgendwie verknüpft werden muss? Wenn ja, wie muss eine solche Verknüpfung/ein solcher Aufruf aussehen?
    Denn aktuell enthält die Datei .htaccess diesbezüglich noch keine etwaige Verknüpfung/keinen etwaigen Aufruf auf die Datei "php.ini" ...






  • #2
    Es gibt mehrere php.ini Dateien. Üblicherweise mindestens 2, eine für den Webdienst und eine für das CLI. Aber da phpinfo, auf die Daten kannst du dich verlassen, das korrekt anzeigt ist hier nichts weiter zu unternehmen.

    Man kann in Wordpress die Einstellungen auch über .htacess vornehmen.
    Auch da 2 mal.
    Ein mal im root von Wordpress, dazu trägt man in die .htaccess oben folgendes ein,
    Code:
     php_value max_input_vars 7000
    Es kann auch im Verzeichnis WP-Admin noch eine .htaccess liegen, dort geht man dann genauso vor.

    Kommentar


    • #3
      Zitat von protestix Beitrag anzeigen
      Es gibt mehrere php.ini Dateien. Üblicherweise mindestens 2, eine für den Webdienst und eine für das CLI. Aber da phpinfo, auf die Daten kannst du dich verlassen, das korrekt anzeigt ist hier nichts weiter zu unternehmen.

      Man kann in Wordpress die Einstellungen auch über .htacess vornehmen.
      Auch da 2 mal.
      Ein mal im root von Wordpress, dazu trägt man in die .htaccess oben folgendes ein,
      Code:
      php_value max_input_vars 7000
      Es kann auch im Verzeichnis WP-Admin noch eine .htaccess liegen, dort geht man dann genauso vor.
      Danke, für die Infos!

      Daraufhin habe ich die Datei phpinfo.php auch mal noch (zusätzlich) in dass Unterverzeichnis wp-admin hochgeladen und mal www.meinedomain.de/wp-admin/phpinfo.php aufgerufen:
      Und siehe da, dann wurde dort NUR der Wert max_input_vars = 1000 angezeigt! (Was der o.g. dritte Screenshot ja auch bestätigt).


      Dann habe ich die Datei php.ini (mit dem Paramter php_value max_input_vars 7000) auch noch in das Unterverzeichnis wp-admin hochgeladen und erneut www.meinedomain.de/wp-admin/phpinfo.php aufgerufen: Und siehe da, NUN wurde dort (auch) der Wert php_value max_input_vars 7000 angezeigt!
      Als ich dann über das Wordpress Dashboard nun erneut versucht habe ein Wordpress Template abzuspeichern, hat dies nun endlich geklappt (es gab keine Speicherproblem-Fehlermeldung mehr)!


      D.h. die Datei php.ini (mit dem Parameter php_value max_input_vars 7000), die mein Webspace-Provider für mich erstellt hatte und (nur) ins Wordpress Root-Verzeichnis hochgeladen hatte,
      war dort für mein o.g. Wordpress Template Editier-Problem nutzlos, denn um das Editier-Problem beim Speichern eines Wordpress Templates zu lösen, hätte die Datei php.ini entsprechend
      von Anfang an in das Unterverzeichnis wp-admin (das letztlich für Wordpress Editier-Funktionen zuständig ist) hochgeladen werden müssen!!


      Man lernt nie aus...

      Kommentar

      Lädt...
      X