Ankündigung

Einklappen
Keine Ankündigung bisher.

Mediawiki upload filesize erhöhen/php.ini

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Mediawiki upload filesize erhöhen/php.ini

    Hallo Community,

    ich möchte in meinem Mediawiki Modul die Maximalgröße der hochzuladenen Dateien erhöhen.

    - Habe schon auf dem Server die entsprechenden Defaul-Parameter in der php.ini aufgebohrt.
    - Habe im Mediawiki Local_settings.php die entsprechenden Parameter hinzugefügt.

    Beides hat keine Wirkung gezeigt. Wie geht das?

    Danke und Gruß.


  • #2
    Bitte beachten: Fachfragen zu bestimmten Softwareprodukten

    MOD: Verschoben von Frameworks
    Debugging: Finde DEINE Fehler selbst! | Gegen Probleme beim E-Mail-Versand | Sicheres Passwort-Hashing | Includes niemals ohne __DIR__
    PHP.de Wissenssammlung | Kein Support per PN

    Kommentar


    • #3
      was sagt phpinfo( );
      welches Server benutzst du?
      was steht in <Virtual Host>
      usw... https://www.mediawiki.org/wiki/Manua...ile_uploads/de
      Signaturrrrrrr

      Kommentar


      • #4
        Hallo,

        phpinfo(); zeigt mir die Standardwerte ein obwohl ich auf meinem WebServer die php.ini mit nano angepasst, den Server auch rebootet habe, auf 120MB. WebServer ist nginx. Soweit ich verstanden habe hat benutzt nginx nicht die .htaccess, also kann ich die Werte da auch nicht reinscripten.
        Anleitung von mediawiki bin ich schon durchgegangen, keine Auswirkung. Ich lese mir es aber nochmal durch, vielleicht hab ich was übersehen.

        Derweil verstehe grade <Virtual Host> nicht...wo ist der?

        In Mediawiki hab ich die Werte auch in der Local_settings.php eingefügt wie beschrieben.

        Kommentar


        • #5
          https://www.google.de/search?client=...UTF-8&oe=UTF-8

          <Virtual Host> die Datei mit virtuelle Hosts beschreibung, aber wenn du weißt es nicht, was es ist, dann soll es da nix nutzliches geben.... Guck dir bloß das Link, veilleicht findest du da was. Ich kenne mich mit ngnix nicht aus, aber hab gehört, da gibt es auch genug Einstellungen zum Spielen.
          Signaturrrrrrr

          Kommentar


          • #6
            Code:
            client_max_body_size 2048M;

            Kommentar


            • #7
              Hallo, so Virtual Host klar hab ich auf nginx/nginx.conf, ergänzt und folgende Schritte durchgeführt:

              - das von Meister1900 : client_max_body_size 2048M; in der nginx.conf unter http hinzugefügt
              - in der php.ini unter cli die Werte post_max_size 2048M und upload_max_filesize 2048M ergänzt (war erst in der fpm php.ini also von daher korrigiert)
              - in den local_settings.php unter mediawiki die Attribute: $wgUploadSizeWarning = 2147483647; $wgMaxUploadSize = 2147483647


              -> keine Auswirkung. Weder in der php.info noch in MediaWiki direkt. Max Upload 2M ... .

              Kommentar


              • #8
                Habe jetzt grade noch unter /etc/nginx/sites-enabled/ die entsprechenden Parameter gesetzt also client_max_body_size 2048M; -> keine Auswirkung. Wo drehe ich an der richtigen Schraube?

                - php.ini angepasst
                - local_settings.php angepasst
                - nginx angepasst.

                Update: So ich hab openmediavault am laufen und: Ja, Layer 8 Problem: hab ein Interface wo ich das hochtakten kann...... Jetzt gehts, kann aber sein das die vorher gemachten Einstellungen auch wichtig sind.

                Kommentar

                Lädt...
                X