Ankündigung

Einklappen
Keine Ankündigung bisher.

2 Domains - 1 Server // Index of/ wird angezeigt statt index.php

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • 2 Domains - 1 Server // Index of/ wird angezeigt statt index.php

    Hallo,

    ich habe ein mysteriöses Problem.
    Ich lasse 2 Domains über einen Server laufen, das Problem ist, dass eine der Domain einfach nicht die index.php Datei öffnen will bzw. den Inhalt liest, aber nichts passiert.
    Wenn ich über die 2. Domain in das Verzeichnis gehe um die Index.php Datei zu öffnen, funktioniert es.
    Anbei der Eintrag in Apache2

    PHP-Code:
    <VirtualHost *:80>
        
    ServerAdmin webmaster@localhost

        DocumentRoot 
    /var/www
        
    <Directory />
            
    Options FollowSymLinks
            AllowOverride None
        
    </Directory>
        <
    Directory /var/www/>
            
    Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow
    ,deny
            allow from all
        
    </Directory>

        
    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <
    Directory "/usr/lib/cgi-bin">
            
    AllowOverride None
            Options 
    +ExecCGI -MultiViews +SymLinksIfOwnerMatch
            Order allow
    ,deny
            Allow from all
        
    </Directory>

        
    ErrorLog ${APACHE_LOG_DIR}/error.log

        
    # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        
    LogLevel warn

        CustomLog 
    ${APACHE_LOG_DIR}/access.log combined
    RewriteEngine on
    RewriteCond 
    %{SERVER_NAME} =www.XXXXX [OR]
    RewriteCond %{SERVER_NAME} =XXXXX
    RewriteRule 
    https://%{SERVER_NAME}%{REQUEST_URI} [L,NE,R=permanent]
    </VirtualHost>

    <
    VirtualHost *:80>

        
    ServerName XXXXX
        DocumentRoot 
    /var/www/panel/
        <
    Directory /var/www/panel/>
            
    Options Indexes FollowSymLinks
            AllowOverride All
       
    </Directory>
    </
    VirtualHost>
    <
    VirtualHost *:80>
        
    ServerName www.XXXXXX
        DocumentRoot 
    /var/www/panel/
        <
    Directory /var/www/panel/>
            
    Options Indexes FollowSymLinks
            AllowOverride All
       
    </Directory>
    </
    VirtualHost
    Und noch Bilder, welche dies nochmal verdeutlichen:

    Hier, wenn ich direkt auf die 1. Domain connecte
    Bild direct.PNG

    Hier, wenn ich versuche die index.php Datei zu öffnen - die weiterleitung funktioniert soweit, aber es wird nichts angezeigt.

    Bild direct (2).PNG
    Und hier eben, wenn ich über die andere Domain in das Verzeichnis gehe und die index.php Datei öffne.

    Bild second.PNG

    Danke für eine Hilfe!


  • #2
    Mit der Option DirectoryIndex kannst du festlegen, welches die Standard Datei ist, die angesprochen werden soll.
    Vermutlich ist bei dir eine derartige Directive nicht gesetzt oder enthält nicht die index.php

    Beispiel:
    Code:
    DirectoryIndex index.php index.html index.htm index.txt
    @see https://httpd.apache.org/docs/2.4/mo...DirectoryIndex

    Es empfiehlt sich weiterhin das Directory Listing generell zu deaktivieren, außer es ist explizit gewünscht.
    Dazu dann in den Options einfach ein Minus vor den Wert Indexes setzen

    Code:
    Options -Indexes +FollowSymLinks
    @see https://httpd.apache.org/docs/2.4/de...e.html#Options

    Wenn Indexes deaktiviert ist, dann gibt es statt dessen eine Forbidden Meldung vom Server, sofern dann keine Index Datei vorhanden sein sollte, die ausgespielt wird.

    Kommentar

    Lädt...
    X