Ankündigung

Einklappen
Keine Ankündigung bisher.

xml - Probs auf Server. Woran kann das liegen?

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • xml - Probs auf Server. Woran kann das liegen?

    Hallo,
    bei einem Kunden, der seinen Server selber einstellen kann, wie er will, kann ich Inhalte von extrernen XML nicht erfassen.
    Hier einmal die Daten:

    XML
    Code:
    <DistanceMatrixResponse>
    <status>OK</status>
    <origin_address>Wilhelmstraße 56, 47229 Duisburg, Deutschland</origin_address>
    <destination_address>Meerwiesenstraße 7, 68163 Mannheim, Deutschland</destination_address>
    <row>
    <element>
    <status>OK</status>
    <duration>
    <value>11543</value>
    <text>3 Stunden, 12 Minuten</text>
    </duration>
    <distance>
    <value>310605</value>
    <text>311 km</text>
    </distance>
    </element>
    </row>
    </DistanceMatrixResponse>
    PHP-Code:
    if($xml=simplexml_load_file("https://maps.googleapis.com/maps/api/distancematrix/xml?origins=".$start_adresse."+DE&destinations=".$end_adresse."+DE&mode=driving&language=de-DE&sensor=false&key=XXXXX"))
        {
            if(
    $xml->status=="OK")
            {
              
    $distance $xml->row->element->distance->value;
              
    $distance round$distance 1000);
              
    $distance ceil($distance);
            }
        }
    echo 
    "Distanz: $distance<br><br>"
    Distanz: 0
    $start_adresse & $end_adresse sind richtig befüllt. Habe ich mir schon zwischendrin ausgeben lassen und habe auch den Google-Link mir angeschaut (daher habe ich die XML-Daten)
    Woran kann das liegen?
    Wenn ihr weitere Daten braucht, sagt mir bitte bescheid.


  • #2
    Und wie lautet die Fehlermeldung?

    Kommentar


    • #3
      Leider könnte ich nur an die PHP Fehlermeldungen kommen (error_reporting(E_ALL) ) kommen und der zeigt mir nichts an

      Kommentar


      • #4
        Und du hast ganz sicher ins richtige Error-Log geschaut?

        Kommentar


        • #5
          Zitat von Crazynet Beitrag anzeigen
          Leider könnte ich nur an die PHP Fehlermeldungen kommen (error_reporting(E_ALL) ) kommen und der zeigt mir nichts an
          und ini_set('display_errors', 1) gemacht? https://php-de.github.io/jumpto/faq/#debugging

          Und siehe auch erstes Beispiel - Fehlerbehandlung XML: http://php.net/manual/de/simplexml.examples-errors.php
          Debugging: Finde DEINE Fehler selbst! | Gegen Probleme beim E-Mail-Versand | Sicheres Passwort-Hashing | Includes niemals ohne __DIR__
          PHP.de Wissenssammlung | Kein Support per PN

          Kommentar

          Lädt...
          X