Ankündigung

Einklappen
Keine Ankündigung bisher.

Ich stelle mich selten dämlich mit Vagrant und puphpet.com Tool Vagrant konfigurieren

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Ich stelle mich selten dämlich mit Vagrant und puphpet.com Tool Vagrant konfigurieren

    Aloha Leute,

    ich dachte puphpet.com sollte Entwicklungsumgebungen konfigurieren leicht machen aber ich bin schon mittlerweile 1 1/2 Wochen an basteln ich dachte es ist selbst erklärend neee. Grrr

    also ich habe ein Projekt was unter Windows im pfad C: Dev/Fast-Fun/ liegt puphpet Ordner(Vagrantfile und puphpet ordner) dort abgelegt es ist ein Laravel Projekt . Vagrant up im ordner Fast-Fun ausgefürt funkt nicht erstellt ein html Ordner.


    ich weiß nicht mehr weiter.

    notfalls poste ich auch die config.ymi Datei.

    Danke im vorraus


  • #2
    "funkt nicht" ist keine Fehlerbeschreibung.

    Was passiert genau? Was für Fehlermeldungen werden dir angezeigt? Wie führst du "vagrant up" aus?

    Kommentar


    • #3
      Zitat von ChromOxid Beitrag anzeigen
      "funkt nicht" ist keine Fehlerbeschreibung.

      Was passiert genau? Was für Fehlermeldungen werden dir angezeigt? Wie führst du "vagrant up" aus?
      sooo ich kriege keine Fehlermeldungen ich vermute es stimmt was nicht mit der Konfiguration auf puphpet.com oder config.yaml ehr config.yaml.


      es wird auch kein php richtig angewandt auf dem ziel Ordner html was als Default ist.

      mein ziel ist es C: Dev/Fast-Fun/public auszuführen als vhost da das ein laravel Project ist.


      die ordner Vagrantfile und puphpet sind im C: Dev/Fast-Fun ist das richtig oder in C: Dev/ ehr C: Dev/Fast-Fun????

      Mein Vagrantfile
      Code:
      # -*- mode: ruby -*-
      
      dir = File.dirname(File.expand_path(__FILE__))
      
      require 'yaml'
      require "#{dir}/puphpet/ruby/deep_merge.rb"
      require "#{dir}/puphpet/ruby/to_bool.rb"
      
      configValues = YAML.load_file("#{dir}/puphpet/config.yaml")
      
      provider = ENV['VAGRANT_DEFAULT_PROVIDER'] ? ENV['VAGRANT_DEFAULT_PROVIDER'] : 'local'
      if File.file?("#{dir}/puphpet/config-#{provider}.yaml")
        custom = YAML.load_file("#{dir}/puphpet/config-#{provider}.yaml")
        configValues.deep_merge!(custom)
      end
      
      if File.file?("#{dir}/puphpet/config-custom.yaml")
        custom = YAML.load_file("#{dir}/puphpet/config-custom.yaml")
        configValues.deep_merge!(custom)
      end
      
      data = configValues['vagrantfile']
      
      Vagrant.require_version '>= 1.8.1'
      
      Vagrant.configure('2') do |config|
        eval File.read("#{dir}/puphpet/vagrant/Vagrantfile-#{data['target']}")
      end

      und die config.yaml
      Code:
      vagrantfile:
          target: local
          vm:
              provider:
                  local:
                      box: bento/ubuntu-14.04
                      box_url: 'false'
                      box_version: '0'
                      chosen_virtualizer: virtualbox
                      virtualizers:
                          virtualbox:
                              modifyvm:
                                  natdnshostresolver1: false
                              showgui: 0
                          vmware:
                              numvcpus: 1
                          parallels:
                              linked_clone: 0
                              check_guest_tools: 0
                              update_guest_tools: 0
                      machines:
                          machine1:
                              id: Fast-Fun
                              hostname: Fast-Fun.puphpet
                              network:
                                  private_network: 192.168.56.101
                                  forwarded_port:
                                      port1:
                                          host: '7539'
                                          guest: '22'
                              memory: '1024'
                              cpus: '1'
              provision:
                  puppet:
                      manifests_path: puphpet/puppet/manifests
                      module_path:
                          - puphpet/puppet/modules
                          - puphpet/puppet/manifests
                      options:
                          - '--verbose'
                          - '--hiera_config /opt/puphpet/puppet/hiera.yaml'
              synced_folder:
                  folder1:
                      owner: vagrant
                      group: vagrant
                      source: 'C:\Dev\Fast-Fun\public'
                      target: /var/www
                      sync_type: default
                      smb:
                          smb_host: ''
                          smb_username: ''
                          smb_password: ''
                          mount_options:
                              dir_mode: '0775'
                              file_mode: '0664'
                      rsync:
                          args:
                              - '--verbose'
                              - '--archive'
                              - '-z'
                          exclude:
                              - .vagrant/
                              - .git/
                          auto: 'true'
              usable_port_range:
                  start: 10200
                  stop: 10500
              post_up_message: ''
          ssh:
              host: 'false'
              port: 'false'
              private_key_path: 'false'
              username: vagrant
              guest_port: 'false'
              keep_alive: '1'
              forward_agent: 'false'
              forward_x11: 'false'
              shell: 'bash -l'
              insert_key: 'false'
          vagrant:
              host: detect
          proxy:
              http: ''
              https: ''
              ftp: ''
              no_proxy: ''
      server:
          install: '1'
          packages:
              - bash-completion
              - htop
              - vim
      users_groups:
          install: '1'
          groups: {  }
          users: {  }
      locale:
          install: '1'
          settings:
              default_locale: de_DE.UTF-8
              locales:
                  - en_GB.UTF-8
                  - en_US.UTF-8
                  - de_DE.UTF-8
              timezone: UTC
      firewall:
          install: '1'
          rules: {  }
      resolv:
          install: '1'
          nameservers:
              - 8.8.8.8
              - 8.8.4.4
          domainname: ''
          searchpath: {  }
      cron:
          install: '1'
          jobs: {  }
      nginx:
          install: '0'
          settings:
              version: present
              default_vhost: 1
              proxy_buffers: '4 256k'
              proxy_buffer_size: 128k
              proxy_connect_timeout: 600s
              proxy_send_timeout: 600s
              proxy_read_timeout: 600s
              names_hash_bucket_size: 128
          upstreams: {  }
          vhosts:
              vhost1:
                  server_name: awesome.test
                  server_aliases:
                      - www.awesome.test
                  www_root: /var/www/awesome
                  listen_port: '80'
                  client_max_body_size: 1m
                  ssl: '0'
                  locations:
                      php_html:
                          www_root: /var/www/awesome
                          location: /
                          autoindex: 'off'
                          internal: 'false'
                          index_files:
                              - index.html
                              - index.php
                          try_files:
                              - $uri
                              - $uri/
                              - /index.php$is_args$args
                      php_php:
                          www_root: /var/www/awesome
                          location: '~ \.php$'
                          autoindex: 'off'
                          internal: 'false'
                          index_files:
                              - index.php
                          try_files:
                              - $uri
                              - $uri/
                          set:
                              - '$path_info $fastcgi_path_info'
                          fastcgi: '127.0.0.1:9000'
                          fastcgi_index: index.php
                          fastcgi_split_path: '^(.+?\.php)(/.*)$'
                          fast_cgi_params_extra:
                              - 'SCRIPT_FILENAME $document_root$fastcgi_script_name'
          proxies: {  }
      apache:
          install: '1'
          settings:
              version: 2.4
              user: www-data
              group: www-data
              default_vhost: true
              manage_user: false
              manage_group: false
              sendfile: 0
          modules:
              - proxy_fcgi
              - rewrite
          vhosts:
              vhost1:
                  servername: Fast-Fun.dev
                  serveraliases:
                      - Fast-Fun.dev
                  docroot: /dev/Fast-Fun/public
                  port: '80'
                  setenvif:
                      - 'Authorization "(.*)" HTTP_AUTHORIZATION=$1'
                  ssl: '0'
                  ssl_cert: LETSENCRYPT
                  ssl_key: LETSENCRYPT
                  ssl_chain: LETSENCRYPT
                  ssl_certs_dir: LETSENCRYPT
                  ssl_protocol: ''
                  ssl_cipher: ''
                  directories:
                      php_html:
                          provider: directory
                          path: /dev/Fast-Fun/public
                          directoryindex: 'index.php index.html'
                          options:
                              - Indexes
                              - FollowSymlinks
                              - MultiViews
                          allow_override:
                              - All
                          require:
                              - 'all granted'
                      php_php:
                          provider: filesmatch
                          path: \.php$
                          sethandler: 'proxy:fcgi://127.0.0.1:9000'
      letsencrypt:
          install: '1'
          settings:
              email: ''
              webserver_service: ''
          domains: {  }
      php:
          install: '1'
          settings:
              version: '7.2'
          modules:
              php:
                  - cli
                  - intl
                  - xml
              pear: {  }
              pecl: {  }
          ini:
              display_errors: 'On'
              error_reporting: '-1'
              session.save_path: /var/lib/php/session
              date.timezone: UTC
          fpm_ini:
              error_log: /var/log/php-fpm.log
          fpm_pools:
              pool1:
                  ini:
                      prefix: www
                      listen: '127.0.0.1:9000'
                      security.limit_extensions: .php
                      user: www-user
                      group: www-data
          composer: '1'
          composer_home: ''
      xdebug:
          install: '0'
          settings:
              xdebug.default_enable: '1'
              xdebug.remote_autostart: '0'
              xdebug.remote_connect_back: '1'
              xdebug.remote_enable: '1'
              xdebug.remote_handler: dbgp
              xdebug.remote_port: '9000'
      blackfire:
          install: '0'
          settings:
              server_id: ''
              server_token: ''
              agent:
                  http_proxy: ''
                  https_proxy: ''
                  log_file: stderr
                  log_level: '1'
              php:
                  agent_timeout: '0.25'
                  log_file: ''
                  log_level: '1'
      wpcli:
          install: '0'
      drush:
          install: '0'
          version: 8.0.5
      ruby:
          install: '1'
          versions:
              ruby1:
                  default: '1'
                  bundler: '1'
                  version: '2.4'
                  gems:
                      - deep_merge@1.2.1
                      - activesupport@5.1.4
                      - vine@0.4
      python:
          install: '1'
          packages: {  }
          versions: {  }
      nodejs:
          install: '1'
          settings:
              version: '8'
          npm_packages: {  }
      mariadb:
          install: '0'
          settings:
              version: '10.1'
              root_password: '123'
              override_options: {  }
          users:
              user1:
                  name: dbuser
                  password: '123'
          databases:
              database1:
                  name: dbname
                  collate: utf8_general_ci
                  sql: ''
          grants:
              grant1:
                  user: dbuser
                  table: '*.*'
                  privileges:
                      - ALL
      mysql:
          install: '1'
          settings:
              version: '5.7'
              root_password: Fast-Fan
              override_options: {  }
          users:
              user1:
                  name: Fast-Fan
                  password: Fast-Fan
          databases:
              database1:
                  name: Fast-Fan
                  collate: utf8_general_ci
                  sql: ''
          grants:
              grant1:
                  user: Fast-Fan
                  table: '*.*'
                  privileges:
                      - ALL
      postgresql:
          install: '0'
          settings:
              global:
                  encoding: UTF8
                  version: '9.6'
              server:
                  postgres_password: '123'
          databases:
              database1:
                  dbname: dbname
                  owner: dbuser
          users:
              user1:
                  username: dbuser
                  password: '123'
                  superuser: '1'
          grants:
              grant1:
                  role: dbuser
                  db: dbname
                  privilege:
                      - ALL
      mongodb:
          install: '0'
          settings:
              bind_ip: 127.0.0.1
              port: '27017'
          globals:
              version: 3.6.2
          databases:
              database1:
                  name: dbname
                  user: dbuser
                  password: '123'
      redis:
          install: '0'
          settings:
              port: '6379'
      sqlite:
          install: '0'
          databases:
              database1:
                  name: dbname
                  owner: www-data
                  group: www-data
                  sql_file: ''
      mailhog:
          install: '1'
          settings:
              smtp_ip: 0.0.0.0
              smtp_port: 1025
              http_ip: 0.0.0.0
              http_port: '8025'
              path: /usr/local/bin/mailhog
      beanstalkd:
          install: '0'
          settings:
              listenaddress: 0.0.0.0
              listenport: '11300'
              maxjobsize: '65535'
              maxconnections: '1024'
              binlogdir: /var/lib/beanstalkd/binlog
              binlogfsync: null
              binlogsize: '10485760'
          beanstalk_console: 0
      rabbitmq:
          install: '0'
          settings:
              port: '5672'
          users:
              user1:
                  admin: '1'
                  name: admin
                  password: '123'
                  tags:
                      - admin
          vhosts: {  }
          plugins: {  }
      elastic_search:
          install: '0'
          settings:
              version: 6.1.2
              java_install: true
          instances:
              instance1:
                  name: es-01
                  jvm_options:
                      - '-Xms2G'
                      - '-Xmx2G'

      Kommentar


      • #4
        es wird auch kein php richtig angewandt auf dem ziel Ordner html was als Default ist.
        und jetzt nochmal auf deutsch? HTML und PHP haben noch nix mit dem Aufsetzen eines Servers mit Vagrant (und puphpet) zu tun.

        sooo ich kriege keine Fehlermeldungen ich vermute es stimmt was nicht mit der Konfiguration auf puphpet.com oder config.yaml ehr config.yaml.
        Schade das du meine Frage nicht vollständig beantwortet hast. Was passiert?! Du gibst in deine Konsole "vagrant up" ein, irgendeine Rückmeldung dazu wird es geben.

        die ordner Vagrantfile und puphpet
        Das Vagrantfile ist kein Ordner sondern eine einzelne Datei, wenn du sie in einen extra Ordner gepackt hast hackt es vermutlich da.

        Kommentar


        • #5
          Ich habe das Gefühl du machst dir das Leben komplizierter als es sein müsste.

          Ich habe früher mit Vagrant gearbeitet (siehe Signatur) und dazu Maschinen erstellt, die eine Entwicklungsumgebung bereitstellen. Inzwischen bin ich zu Docker umgezogen, da schneller und leichtgewichtiger. Zudem würde ich für deine Entwicklungsumgebung auf SSL verzichten, das ist unnötiger Ballast.

          Wieso nicht eine der vielen existierenden Vagrant-Boxen nehmen und diese (minimalistisch) anpassen?
          GitHub.com - ChrisAndChris - RowMapper und QueryBuilder für MySQL-Datenbanken

          Kommentar


          • #6
            Zitat von ChristianK Beitrag anzeigen
            Ich habe das Gefühl du machst dir das Leben komplizierter als es sein müsste.

            Ich habe früher mit Vagrant gearbeitet (siehe Signatur) und dazu Maschinen erstellt, die eine Entwicklungsumgebung bereitstellen. Inzwischen bin ich zu Docker umgezogen, da schneller und leichtgewichtiger. Zudem würde ich für deine Entwicklungsumgebung auf SSL verzichten, das ist unnötiger Ballast.

            Wieso nicht eine der vielen existierenden Vagrant-Boxen nehmen und diese (minimalistisch) anpassen?
            ja eigentlich habe ich gedacht, dass das Tool mir leicht macht aber irgend wie habe ich das Gefühl es ist doch nicht so trivial ist und selbst erklärend das Tool(puphpet.com)

            ich habe mir eigentlich auch gedacht das ich nur einmal es anpassen muss und dann habe ich ne Rohform für kommende Projekte so das ich die Directoryroot für das Benötigte Projekt anpassen muss was in c:​ Dev/Fast-Fan/public liegt nee ist nicht.

            es war auch einleuchtend das ich da Datenbanken (mysql), Apache, node.js und so konfigurieren konnte.

            Das SSL ist vom Tool Konfiguriert.

            Vielleicht könntest du dir mal das Tool anschauen puphpet.com und auf den Projekt pfad c: Dev/Fast-Fan/public für laravel konfigurieren bitte ??

            Vielleicht kann ich dann nachvollziehen was falsch ist ?

            Kommentar


            • #7
              Zitat von Harry05 Beitrag anzeigen
              [...]
              Vielleicht könntest du dir mal das Tool anschauen puphpet.com und auf den Projekt pfad c: Dev/Fast-Fan/public für laravel konfigurieren bitte ??
              [...]
              So leid es mir tut, dafür habe ich keine Zeit (und auch nicht wirklich Lust).

              Es gibt übrigens hunderte Beispiele zu Apache2 und Vagrant. Z.B. dieses Gist: https://gist.github.com/ricardocanel...7cc9e39eb0effe Ausserdem sollte es kein "für Laravel konfigurieren" geben. Du benötigst einen Apache-Webserver, für was du den verwendest sollte deiner Entwicklungsumgebung egal sein.

              GitHub.com - ChrisAndChris - RowMapper und QueryBuilder für MySQL-Datenbanken

              Kommentar

              Lädt...
              X