Ankündigung

Einklappen
Keine Ankündigung bisher.

Apache: Zertifikat geht nur mit www

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Apache: Zertifikat geht nur mit www

    Ich habe heute ein normales Zertifikat gekauft, dort stand geschützt für
    www.example.de
    example.de

    Als ich es auf mein Apache eingerichtet habe geht es nur für https://www.example.com
    bei https://example.com tut mein Browser so als hätte ich kein Zertifikat.
    Musst man unter Apache noch was einstellen damit beide Varianten geschützt werden?
    Oder deckt ein normales SSL immer nur eine Variante ab?

    Es war ein normales Zertifikat für eine Domain, kein Multi oder was es sonst noch gibt wie Wildcard
    Server: Suse 13.1


  • #2
    Bitte example.com als Beispieldomain verwenden, dafür gibt es sie.
    Competence-Center -> Enjoy the Informatrix
    PHProcks!Einsteiger freundliche Tutorials

    Kommentar


    • #3

      Warum fragst du nicht deinen Hoster, der weiss doch was er verkauft, danach bist du schlauer und kannst hier mit mehr Informationen glänzen.

      Kommentar


      • #4
        Sind der ServerName/ServerAlias entsprechend gesetzt? Es sollten beiden Domains mit aufgeführt sein, oder eine entsprechende Wildcard Domain.

        Kommentar


        • #5
          Ich würde Non-WWW immer mit 301 auf WWW umleiten, feddich...
          Competence-Center -> Enjoy the Informatrix
          PHProcks!Einsteiger freundliche Tutorials

          Kommentar


          • #6
            Hallo erc
            (Gebe aber selbst zu , das ist eher im Serverforum angebracht, weniger im php Forum aber viellecht weiß das ja jemand)

            "Sind der ServerName/ServerAlias entsprechend gesetzt? Es sollten beiden Domains mit aufgeführt sein, oder eine entsprechende Wildcard Domain."
            Code:
            <IfDefine SSL>
            <IfDefine !NOSSL>
            
            <VirtualHost _default_:443>
            
            # General setup for the virtual host
            DocumentRoot "//webserver/http/htdocs/example"
            ServerName www.example.at:443 # mit * und ohne www schon getestet
            ServerAlias example.at:443 # auch mit * getestet
            #ServerAdmin webmaster@example.com
            ErrorLog /var/log/apache2/example/error_log
            CustomLog /var/log/apache2/example/access_log combined
            
            #TransferLog /var/log/apache2/access_log
            
            # SSL Engine Switch:
            # Enable/Disable SSL for this virtual host.
            SSLEngine on
            
            # SSL protocols
            # Supporting TLS only is adequate nowadays -SSLv2 entfert dafuer -SSLv3 gesetzt
            SSLProtocol all -SSLv2 -SSLv3
            
            # SSL Cipher Suite:
            # List the ciphers that the client is permitted to negotiate.
            # See the mod_ssl documentation for a complete list.
            SSLCipherSuite HIGH:MEDIUM:!aNULL:!MD5
            
            # Speed-optimized SSL Cipher configuration:
            # If speed is your main concern (on busy HTTPS servers e.g.),
            # you might want to force clients to specific, performance
            # optimized ciphers. In this case, prepend those ciphers
            # to the SSLCipherSuite list, and enable SSLHonorCipherOrder.
            # Caveat: by giving precedence to RC4-SHA and AES128-SHA
            # (as in the example below), most connections will no longer
            # have perfect forward secrecy - if the server's key is
            # compromised, captures of past or future traffic must be
            # considered compromised, too.
            #SSLCipherSuite RC4-SHA:AES128-SHA:HIGH:MEDIUM:!aNULL:!MD5
            #SSLHonorCipherOrder on
            
            SSLCertificateFile /etc/apache2/ssl.crt/example17-at.crt
            SSLCertificateKeyFile /etc/apache2/ssl.key/www.example17-at.key
            SSLCACertificateFile /etc/apache2/ssl.ca/example17-at.ca
            
            <FilesMatch "\.(cgi|shtml|phtml|php)$">
            SSLOptions +StdEnvVars
            </FilesMatch>
            <Directory "/srv/www/cgi-bin">
            SSLOptions +StdEnvVars
            </Directory>
            
            BrowserMatch "MSIE [2-5]" \
            nokeepalive ssl-unclean-shutdown \
            downgrade-1.0 force-response-1.0
            
            # Per-Server Logging:
            # The home of a custom SSL log file. Use this when you want a
            # compact non-error SSL logfile on a virtual host basis.
            CustomLog /var/log/apache2/ssl_request_log ssl_combined
            
            </VirtualHost>
            
            </IfDefine>
            </IfDefine>

            Kommentar


            • #7
              Hat nichts mit PHP zu tun.

              MOD: Verschoben von PHP-Fortgeschritten
              PHP.de Wissenssammlung | Debugging: Finde DEINE Fehler selbst! | mysql_* ist veraltet! | Gegen Probleme beim E-Mail-Versand | Sicheres Passwort-Hashing | Includes niemals ohne __DIR__ | Kein Support per PN

              Kommentar


              • #8
                Nehm den Port aus dem Namen und Alias, der hat da nix zu suchen.

                Kommentar


                • #9
                  Hallo erc,

                  ich habe den Port nun rausgenommen, aber keine besserung:
                  das waren halt die originalen Sample Datei von Suse siehe:


                  # General setup for the virtual host
                  DocumentRoot "/srv/www/htdocs"
                  #ServerName www.example.com:443
                  #ServerAdmin webmaster@example.com
                  ErrorLog /var/log/apache2/error_log
                  TransferLog /var/log/apache2/access_log #wobei das hier auch nicht stimmt, dafür habe ich CustomLog

                  Kommentar


                  • #10
                    wenn ich dein Problem richtig verstanden habe: du musst mit .htaccess eine Umleitung machen.

                    wie z.B.
                    Code:
                    RewriteEngine on
                    RewriteCond %{SERVER_PORT} !^443
                    RewriteRule ^(.*)$ https://www.example.com/$1 [r=301,L]
                    so müsste es gehen.

                    Kommentar


                    • #11
                      Hallo tufanum,
                      das habe ich auch schon überlegt und mache es mit.

                      #alles auf https umleiten
                      RewriteCond %{HTTPS} !=on
                      RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

                      aber ich finde, das ist nur eine Notlösung, es musst auch über Apache direkt gehen.
                      sonst würde der Provider nicht schreiben:

                      Abgedeckte Domains:

                      - www.examble.at
                      - examble.at

                      aber vielen Dank, hilft auf jedenfalls denen, die nur ein www.examble.at SSL gekauft haben.

                      PS:
                      Bei der htacces Umleitung ist das Problem auch, das dann alle Domain im Verzeichnis geschützt werden müssen.
                      Bei uns laufen 6 Domains, 3 davon sind erst über ssl geschützt.
                      Oder man musst angeben können, nur Domin a und b auf https umleiten.

                      Kommentar


                      • #12
                        Für alle die irgendwann durch Google hier landen die

                        Auflösung:

                        ServerName example.de
                        ServerAlias www.example.de *.example.de

                        Aber es gibt auch Zertifikate, die decken nur eine Variante ab, mit www oder ohne www
                        da hilft nur umleiten.

                        Kommentar

                        Lädt...
                        X