Ankündigung

Einklappen
Keine Ankündigung bisher.

Servernamen für Built-In Server ändern in PHPStorm

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Servernamen für Built-In Server ändern in PHPStorm

    Hallo,

    Ich habe seit sehr kurzer Zeit PHPStorm in Verwendung und beschäftige mich auch erst seit kurzem mit PHP.
    Ich nutze den Built-In-Server von PHPStorm in Verbindung mit dem Debugger/Debug-Listener.

    Im Browser gebe ich zum Debuggen immer localhost:63342 ein um debuggen zu können.
    In meiner PHP-Anwendung frage ich jedoch $_SERVER["SERVER_NAME"] ab welcher nicht "localhost" zurückgibt sondern "PhpStorm 2017.1.4", was zu Problemen führt wenn ich "header(...)" aufrufe.
    Wie kann ich es bewerkstelligen dass dieses "localhost" auch der Wert von $_SERVER["SERVER_NAME"] ist?
    Bzw. gibt es eine Möglichkeit meine Anwendung im Browser sofort mit "PhpStorm 2017.1.4:63342" aufzurufen?
    Die Hauptsache ist dass es einheitlich ist.

    Ich habe versucht den Server in Settings->Lang.&FW->PHP->Servers abzuändern. Aber sobald ich das mache will PHPStorm beim Start des Debuggens wieder einen Server kreieren der genauso aussieht wie der Server zuvor. Was kann ich da machen? Wie erstelle ich meinen eigenen eigenen Server für meinen Debug-Listener? PHPStorm lässt nicht locker und will immer den gleichen Server dafür nutzen.


  • #2
    Du vermischst zwei Sachen, das eine ist der Hostname und das andere ist der Servername.

    Der Hostname, localhost, ist ein Alias für die IP 127.0.0.1 und der Servername, PhpStorm..., ist ein "ausgedachter" Name für den Server, wie das Apache 2.4 oder Irgendwas-Server v9 wäre.

    GitHub.com - ChrisAndChris - RowMapper und QueryBuilder für MySQL-Datenbanken

    Kommentar


    • #3
      Wieso nutzt du den Built-In-Server von PHPStorm?

      Du hast ja jetzt PHP Lokal, dann konfiguriere deinen Eigenen Server.

      Einfach oben Rechts Edit Configuration.. http://i.imgur.com/es7E9pY.png

      Danach kommt ein neues Poup, dort klickst du oben auf "+" und Wählst built-in Webserver http://i.imgur.com/mWPGEoa.png

      Dann stellst du einen Namen der Configuration ein http://i.imgur.com/bv9CInc.png sowie pfad zu deinem Webserver, wenn du PHP nicht konfiguriert hast, kriegst du unten einen "Fix" button, da musst du vorher drauf klicken und alles fixen. Nach dem Speichern hast du dann oben Rechts ein Grünen "Play" Button. Wenn du drauf klickst, startest du deinen Lokalen Built-in webserver.


      PHP-Code:
      Im Browser gebe ich zum Debuggen immer localhost:63342 ein um debuggen zu können
      Ist das jetzt nur zum Debuggen? Oder hast du generell dein Apache auf Port 63342 laufen?
      apt-get install npm -> npm install -g bower -> bower install <package> YOLO https://www.paypal.me/BlackScorp

      Kommentar


      • #4
        Zitat von BlackScorp Beitrag anzeigen
        Wieso nutzt du den Built-In-Server von PHPStorm?

        Du hast ja jetzt PHP Lokal, dann konfiguriere deinen Eigenen Server.

        Einfach oben Rechts Edit Configuration.. http://i.imgur.com/es7E9pY.png

        Danach kommt ein neues Poup, dort klickst du oben auf "+" und Wählst built-in Webserver http://i.imgur.com/mWPGEoa.png

        Dann stellst du einen Namen der Configuration ein http://i.imgur.com/bv9CInc.png sowie pfad zu deinem Webserver, wenn du PHP nicht konfiguriert hast, kriegst du unten einen "Fix" button, da musst du vorher drauf klicken und alles fixen. Nach dem Speichern hast du dann oben Rechts ein Grünen "Play" Button. Wenn du drauf klickst, startest du deinen Lokalen Built-in webserver.


        PHP-Code:
        Im Browser gebe ich zum Debuggen immer localhost:63342 ein um debuggen zu können
        Ist das jetzt nur zum Debuggen? Oder hast du generell dein Apache auf Port 63342 laufen?
        Den Built-In-Server von PHPStorm zu verwenden war ja jetzt nicht direkt falsch oder?

        Und den localhost:63342 nehme ich nur zum Debuggen.

        Kommentar


        • #5
          Zitat von StefEAG Beitrag anzeigen

          Den Built-In-Server von PHPStorm zu verwenden war ja jetzt nicht direkt falsch oder?

          Und den localhost:63342 nehme ich nur zum Debuggen.
          doch, dieser nutzt dann seine eigene Einstellungen, eigentlich sollte debuggen auf den Gleichen Server passieren wo dein Code auch läuft, denn es gibt auch bugs die vom Server abhängig ist.

          Eigenlich sollltest du im Browser das Plugin Aktivieren, den Listener in PHp Storm aktivieren und breakpoints setzten und über die gleiche URL Debuggen wie der Code.

          apt-get install npm -> npm install -g bower -> bower install <package> YOLO https://www.paypal.me/BlackScorp

          Kommentar


          • #6
            Zitat von BlackScorp Beitrag anzeigen

            doch, dieser nutzt dann seine eigene Einstellungen, eigentlich sollte debuggen auf den Gleichen Server passieren wo dein Code auch läuft, denn es gibt auch bugs die vom Server abhängig ist.

            Eigenlich sollltest du im Browser das Plugin Aktivieren, den Listener in PHp Storm aktivieren und breakpoints setzten und über die gleiche URL Debuggen wie der Code.
            Ich bin schön langsam der Meinung dass ich das ganze mit einem lokalen Built-In-Server gar nicht zum laufen bekommen kann.
            Denn ich habe nun auch einen Zertifikat-Fehler.
            In dem Code den ich bekommen habe werden Variablen wie $_SERVER['SSL_CLIENT_VERIFY'] abgefragt, welche meines Wissens Apache-spezifisch sind. Das heißt ich müsste auch noch einen Apache-Server lokal installieren, oder?

            Kommentar


            • #7
              Zitat von StefEAG Beitrag anzeigen

              Ich bin schön langsam der Meinung dass ich das ganze mit einem lokalen Built-In-Server gar nicht zum laufen bekommen kann.
              Denn ich habe nun auch einen Zertifikat-Fehler.
              In dem Code den ich bekommen habe werden Variablen wie $_SERVER['SSL_CLIENT_VERIFY'] abgefragt, welche meines Wissens Apache-spezifisch sind. Das heißt ich müsste auch noch einen Apache-Server lokal installieren, oder?
              oder https://localhost aufrufen? Was hast du für ein Script? Weiso ist dein Server auf Windows? da sind so viele Fragen die Offen sind
              apt-get install npm -> npm install -g bower -> bower install <package> YOLO https://www.paypal.me/BlackScorp

              Kommentar


              • #8
                Zitat von BlackScorp Beitrag anzeigen

                oder https://localhost aufrufen? Was hast du für ein Script? Weiso ist dein Server auf Windows? da sind so viele Fragen die Offen sind

                Zwei Geräte:

                1. Der Server:
                Das Betriebssystem ist Windwos Server 2012R2.
                Dort liegen alle Source-Files meiner Anwendung.
                Dort ist mein Apache-Server installiert.
                Laut php.ini wird openssl verwendet.
                In php.ini ist xdebug aktiviert.

                2. Der Arbeitsrechner:
                Das Betriebssystem ist Windows 7.
                Dort ist ein Netzwerklaufwerk eingerichtet mit dem ich Zugriff auf alle Source-Files meiner Anwendung vom Server habe.
                PHPStorm ist dort installiert.
                PHP ist installiert und xDebug aktiviert im php.ini (neuere PHP-/xDebug-Version als auf Server, falls relevant).
                Vom Browser aus kann ich die Anwendung aus starten.


                Ich kann dir so ziemlich jede Frage beantworten, außer Wieso-Fragen. Ich kann dir leider nicht sagen aus welchem Grund gewisse Dinge entschieden worden sind.
                Mein Vorgänger ist leider verschwunden und macht nun eine Weltreise. Der kommt nie wieder zurück.
                Hinterlassen hat er mir nur fragwürdigen Code ohne Kommentare. Dokumentation gibt es auch keine.
                Und soetwas wie eine professionelle Entwicklungsumgebung wurde mir auch nicht hinterlassen (Nur Notepad++).
                Deswegen versuche ich auch nun PHPStorm ordentlich mit Debugger einzurichten um menschenwürdige Umstände zu schaffen ^^"

                Es muss doch irgendwie möglich sein einfach über den bestehenden Server zu debuggen, oder?
                Wenn ich es durch deine Hilfe irgendwie hinbekomme dann werde ich dir jedes Jahr ein Dankschreiben schicken. Ganz im ernst. Das werde ich mir in den Kalender eintragen xD
                Also bitte, frag mich was du willst.

                Kommentar


                • #9
                  MOD: Verschoben von PHP-Einsteiger
                  Debugging: Finde DEINE Fehler selbst! | Gegen Probleme beim E-Mail-Versand | Sicheres Passwort-Hashing | Includes niemals ohne __DIR__
                  PHP.de Wissenssammlung | Kein Support per PN

                  Kommentar


                  • #10
                    Zitat von StefEAG Beitrag anzeigen
                    Es muss doch irgendwie möglich sein einfach über den bestehenden Server zu debuggen, oder?
                    Ja aber nicht über externen Port, einfach in PHPStorm den Listener aktivieren, Break point setzen, dann deine Seite im Browser öffnen im Normalen Port und dann Browserplugin aktivieren und Refresh, schon sollte sich PHPStorm bei dir Melden
                    apt-get install npm -> npm install -g bower -> bower install <package> YOLO https://www.paypal.me/BlackScorp

                    Kommentar


                    • #11
                      Zitat von BlackScorp Beitrag anzeigen

                      Ja aber nicht über externen Port, einfach in PHPStorm den Listener aktivieren, Break point setzen, dann deine Seite im Browser öffnen im Normalen Port und dann Browserplugin aktivieren und Refresh, schon sollte sich PHPStorm bei dir Melden
                      Wenn du "normaler Port" schreibst dann meinst du dass ich einfach meine Webanwendung ganz normal, als würde ich sie einfach im Browser verwenden wollen, öffne.
                      Nur eben dass ich zusätzlich das Browser-Plugin aktiviert habe
                      und in PHPStorm den Listener.

                      Also nicht länger über irgendeinen lokalen Built-In-Server.

                      Kommentar


                      • #12
                        Zitat von StefEAG Beitrag anzeigen

                        Wenn du "normaler Port" schreibst dann meinst du dass ich einfach meine Webanwendung ganz normal, als würde ich sie einfach im Browser verwenden wollen, öffne.
                        Nur eben dass ich zusätzlich das Browser-Plugin aktiviert habe
                        und in PHPStorm den Listener.

                        Also nicht länger über irgendeinen lokalen Built-In-Server.
                        Ich weiß echt nicht was ich drauf antworten soll, hier ist keine Frage, auch keine Antwort ob das Problem glöst ist oder nicht, irgendwas?

                        So schwer kann es doch garnicht sein.

                        Du brauchst, Listener, Browser plugin, Code und in der ini einstellen xdebug.remote_enable= 1
                        apt-get install npm -> npm install -g bower -> bower install <package> YOLO https://www.paypal.me/BlackScorp

                        Kommentar


                        • #13
                          Zitat von BlackScorp Beitrag anzeigen

                          Ich weiß echt nicht was ich drauf antworten soll, hier ist keine Frage, auch keine Antwort ob das Problem glöst ist oder nicht, irgendwas?

                          So schwer kann es doch garnicht sein.

                          Du brauchst, Listener, Browser plugin, Code und in der ini einstellen xdebug.remote_enable= 1
                          In PHPStorm ist der Listener aktiviert.
                          Im Chrome ist das xDebug-Plugin für PHPStorm mit dem IDE-Key "PHPStorm" aktiviert.
                          Sowohl im php.ini meines Servers als auch im php.ini meines Arbeitsrechners ist xDebug enabled (wobei es wahrscheinlich nur am Server notwendig ist).
                          Rufe ich meine Webanwendung die auf meinem Server ausgeführt wird in Google-Chrome auf, so funktioniert diese Anwendung ganz normal.
                          Aber es wird in PHPStorm nichts getriggert.

                          (also keine lokalen Built-In Webserver mehr)

                          Kommentar


                          • #14
                            Zitat von StefEAG Beitrag anzeigen

                            In PHPStorm ist der Listener aktiviert.
                            Im Chrome ist das xDebug-Plugin für PHPStorm mit dem IDE-Key "PHPStorm" aktiviert.
                            Sowohl im php.ini meines Servers als auch im php.ini meines Arbeitsrechners ist xDebug enabled (wobei es wahrscheinlich nur am Server notwendig ist).
                            Rufe ich meine Webanwendung die auf meinem Server ausgeführt wird in Google-Chrome auf, so funktioniert diese Anwendung ganz normal.
                            Aber es wird in PHPStorm nichts getriggert.

                            (also keine lokalen Built-In Webserver mehr)
                            Naja du musst auch ein Breakpoint setzen oder unter Settings > L&FW > PHP > Debug > "Break at first line in PHP Scripts" da ein Häckchen setzen
                            apt-get install npm -> npm install -g bower -> bower install <package> YOLO https://www.paypal.me/BlackScorp

                            Kommentar


                            • #15
                              Zitat von BlackScorp Beitrag anzeigen

                              Naja du musst auch ein Breakpoint setzen oder unter Settings > L&FW > PHP > Debug > "Break at first line in PHP Scripts" da ein Häckchen setzen
                              Das habe ich natürlich.

                              Die Frage ist eben an welchen Stellen ich was wie Konfigurieren muss, ausgehend von "ich habe noch nichts gemacht".
                              Am Arbeitsrechner ist PHPStorm.
                              Der Listener ist aktiviert.
                              Das Chrome-xDebug-Plugin ist für PHPStorm aktiviert.
                              Meine Anwendung die am Server ausgeführt wird ist in Chrome aufrufbar.
                              Die Source-Files sind über ein Netzwerklaufwerk lokal verfügbar.

                              Das richtige xDebug-DLL habe ich laut phpinfo() des Servers in den ext-Ordner am Server.
                              Im php.ini ist der Pfad zum DLL angegeben und xbebug ist enabled.
                              Als remote-host habe ich die IP meines Arbeitsrechners angegeben.
                              Die Firewall des Servers lässt ausgehende Verbindungen zu.

                              Was fehlt noch?

                              Kommentar

                              Lädt...
                              X