Ankündigung

Einklappen
Keine Ankündigung bisher.

Seitenausgabe immer öfter nicht möglich

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Seitenausgabe immer öfter nicht möglich

    Guten Morgen liebe Leute,

    vielleicht kann mir Jemand von euch einen Tipp geben. Ich habe ein kleines Webprojekt bei t-online seit mehr als 10 Jahren. Nun wird es naturgemäß immer größer einschl. der DB. Seit einiger Zeit erhalte ich öfter Seiten-Ladefehler angezeigt und am Anfang des Seitenaufbaus erfolgt eine Ausgabe des HTML Codes. Nun die Frage, ist es wahrscheinlich ein Scriptfehler von mir, oder sollte ich mich nach einem anderen Server umschauen? Die Seite ist www.molcup.de
    Vielen Dank für die Tipps im Voraus, eins noch ich habe das nicht studiert sondern mir nur angenommen. Daher bitte ich um ein bisschen Verständnis.


  • #2
    wie reproduzierst du denn den Fehler? Guck mal ob du bei deinem Hoster auf das Logfile zugreifen kannst.
    You know, my wife sometimes looks at me strangely. „Duncan“, she says, „there's more to life than Solaris“. Frankly, it's like she speaks another language. I mean, the words make sense individually, but put them together and it's complete nonsense.

    Kommentar


    • #3
      Würde auch beim Hoster selbst mal beim Support anfragen.


      [MOD: Verschoben von PHP-Einsteiger]
      Debugging: Finde DEINE Fehler selbst! | Gegen Probleme beim E-Mail-Versand | Sicheres Passwort-Hashing | Includes niemals ohne __DIR__
      PHP.de Wissenssammlung | Kein Support per PN

      Kommentar


      • #4
        Hallo!

        T-Online ist schon seit Jahren kein verlässlicher Hoster mehr. Noch nicht einmal htaccess möglich (angeblich zu unsicher). Und regelmäßig werden die LOG-Files nicht geführt, da fehlen dann schon mal für Tage oder Wochen die LOGs. Und die PHP-Version ist regelmäßig veraltet, da kann es Jahre dauern bis es eine neue PHP-Version gibt. Das war für mich ein Grund zu wechseln.

        Auf Fehlersuche solltest Du dennoch gehen.

        BTW:
        Nach 10 Jahren sollte man mal darüber nachdenken alte Inhalte zu löschen. Nicht alles was vor 10 Jahren mal nützlich war muss heute noch nützlich sein.

        Gruß, René

        Kommentar


        • #5
          Hallo Mumpel,

          ja das ist auch mein Eindruck. Ich habe nun ein weiteres Problem. Ein Script wird anscheinend nicht ausgeführt. auf xampp läuft es nach wie vor hervorragend. Ich habe die error_log ausgelesen und auch versucht Fehler mit
          PHP-Code:
           error_reporting (E_ALL E_STRICT);
          ini_set ('display_errors' 1
          ; auszulesen und auch
          PHP-Code:
          $xxxx$_POST['xxxx'];
              
                    

                if(
          $xxxxx==$_SESSION['xxxxx']){



              require_once(
          "anmeldung/formkont.php");

                }else {echo 
          '<div class ="error"> Anmeldung nicht möglich derzeit"<div>';} 
          bringt kein Ergebnis. Kann mir jemand helfen und sagen wie ich den Fehler finden kann? Lt t-online läuft bei Ihnen alles.
          Es wird nur eine leere Seite angezeigt. Auch der Versuch den Quellcode auszulesen scheitert. Alles leer

          Kommentar


          • #6
            Schau ins Error-Log.

            Kommentar


            • #7
              Zitat von hellbringer Beitrag anzeigen
              Schau ins Error-Log.
              wie schon gesagt, kein Eintrag

              Kommentar


              • #8
                Dann überprüfe, ob Error-Reporting und Error-Logging am Server richtig konfiguriert ist.

                Kommentar


                • #9
                  ich habe jetzt die Konsequenz gezogen und ziehe um zu einem anderen Provider. Da sich heraus gestellt hat das die Probleme nur temporär sind. Heute funktioniert alles wieder normal. Daher gehe ich davon aus, das der Fehler wohl doch nicht bei mir liegt. Ich denke zwar der Code ist alles Andere als perfekt, doch er funktioniert schon lange und auf xampp auch. nur bei t-online treten zeitweise diese Fehler auf. Danke für eure Hilfe. Jetzt haben wir auch Cronjobs, somit ist alles gut.

                  Kommentar


                  • #10
                    Ja, T-Online kann man echt vergessen.

                    Nur aus Neugierde: Wo bist du hingezogen?

                    Kommentar


                    • #11
                      zu alfahosting

                      Kommentar


                      • #12
                        T-Online leidet zeitweise recht stark unter Angriffen ... bzw wird selbst für Angriffe genutzt - schätzungsweise 30% der Accounts dort sind mittlerlweile gehackt ...

                        das würde zeitweise Aussetzer bei dir erklären - wenn andere T-Online Accounts gerade Spamwellen lostreten, landen die Server schon mal in irgendwelchen Blacklists und dann geht kaum noch was - außerdem sind dann die Server regelmäßig ausgelastet ....

                        viel Spass beim neuen Hoster
                        "Irren ist männlich", sprach der Igel und stieg von der Drahtbürste

                        Kommentar

                        Lädt...
                        X