Ankündigung

Einklappen
Keine Ankündigung bisher.

.htaccess unter Xampp Localhost mod_rewrite [erledigt]

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Quellcode
    hat ein Thema erstellt .htaccess unter Xampp Localhost mod_rewrite [erledigt].

    .htaccess unter Xampp Localhost mod_rewrite [erledigt]

    Guten Tag,

    ich habe nun eine Weile im WWW gesucht und komme nur bis zu einem bestimmten Punkt, wo ich nun länger hänge.

    Vorab mein Ziel:

    Die Domain "http://localhost/xampp/Projekt/index.php" existiert, alle weiteren "Ordner" sollen als Wert übergeben werden.
    Also aus "http://localhost/xampp/Projekt/Beispiel" soll "http://localhost/xampp/Projekt/index.php?category=Beispiel" werden.

    Hier meine .htaccess
    Code:
    <IfModule mod_rewrite.c>
    Options +FollowSymlinks
    RewriteEngine On
    RewriteBase xampp/Projekt/
    RewriteRule ^(.*)/$ index.php?category=$1 [NC,L]
    </IfModule>
    Folgendes habe ich in der httpd.conf hinzu gefügt
    Code:
    <Directory "/xampp/htdocs/xampp/Projekt">
        Options Indexes FollowSymLinks Includes ExecCGI
        AllowOverride All
        Require all granted
    </Directory>
    Der Ordner befindet sicht tatsächlich unter:
    C:\xampp\htdocs\xampp\Projekt

    Das doppelte "xampp" ist also kein Fehler.


    Ich erhalte einen 500 Server Error.
    Was mache ich falsch?

    Vielen Dank im Voraus für alle Tipps von euch!!

  • hellbringer
    antwortet
    Zitat von Quellcode Beitrag anzeigen
    Dies ist eine gute allgemeine Möglichkeit.
    Aber für meinen Fall benötige ich die Parameter, da ich auf dieser Basis meine Skripte aufrufe.
    Die Parameter stehn ja in der URL. Wo ist das Problem?

    Einen Kommentar schreiben:


  • Quellcode
    antwortet
    Dies ist eine gute allgemeine Möglichkeit.
    Aber für meinen Fall benötige ich die Parameter, da ich auf dieser Basis meine Skripte aufrufe.

    Einen Kommentar schreiben:


  • hellbringer
    antwortet
    Einfacher ist es pauschal alle Anfragen an index.php zu leiten, anstatt irgendwelche GET-Parameter dazu zu basteln:

    Code:
    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} -s [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]

    Einen Kommentar schreiben:


  • Quellcode
    antwortet
    Log hatte ich bereits eingesehen. Danach war es "nur noch" ein 404 Error.
    Den habe ich nun auch raus.

    Für weitere Nutzer mit ähnlichem Fehlerbild:
    http://stackoverflow.com/questions/7...-get-variables

    LG

    Einen Kommentar schreiben:


  • hellbringer
    antwortet
    Zitat von Quellcode Beitrag anzeigen
    Ich erhalte einen 500 Server Error.
    Was mache ich falsch?
    Du fragst andere Leute, was bei dir am Server passiert, anstatt selber ins Error-Log zu schauen.

    Einen Kommentar schreiben:

Lädt...
X