Ankündigung

Einklappen
Keine Ankündigung bisher.

PHP 5.4.X Probleme bei der Installation !

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • PHP 5.4.X Probleme bei der Installation !

    Um einmal meinen Weg vorzulegen wie ich ihn gegangen bin !

    Hier meine UNSORTIERTE Vorbereitung

    apt-get install libxml2-dev libbz2-dev libcurl4-openssl-dev libjpeg-dev libpng-dev libfreetype6-dev libc-client-dev libicu-dev libsasl2-dev unixodbc-dev libpspell-dev libsnmp-dev libxslt-dev re2c libgmp-dev libgmp3-dev



    apt-get install libapache2-mod-fcgid apache2-suexec libpcre3-dev libpcre++-dev libpng12-dev libbz2-dev libcurl4-openssl-dev libc-client2007e-dev libjpeg-dev libgif-dev libgif4 libpthread-stubs0-dev libx11-dev libxau-dev libxcb1-dev libxdmcp-dev libxpm-dev x11proto-core-dev x11proto-input-dev x11proto-kb-dev xtrans-dev libxml2-dev libmysqlclient-dev libfreetype6-dev
    Vielleicht einiges Doppelt aber gut, soweit so gut !

    Dann einmal alles verlinkt und Links gesetzt !

    ln -s /usr/lib/x86_64-linux-gnu/libXpm.a /usr/lib/libXpm.a
    ln -s /usr/lib/x86_64-linux-gnu/libXpm.so /usr/lib/libXpm.so
    ln -s /usr/lib/x86_64-linux-gnu/liblber.a /usr/lib/liblber.a
    ln -s /usr/lib/x86_64-linux-gnu/libldap_r.a /usr/lib/libldap_r.a
    Entsprechend meine Configuration angepasst !

    ./configure '--with-libdir=lib --with-xpm-dir=/usr --with-ldap=/usr' '--cache-file=../config.cache' '--prefix=/usr/local/php543-cgi' '--with-config-file-path=/usr/local/php543-cgi/etc' '--disable-debug' '--with-pic' '--disable-rpath' '--with-bz2' '--with-curl' '--with-freetype-dir=/usr/local/php543-cgi' '--with-png-dir=/usr/local/php543-cgi' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext=shared' '--with-gmp=/usr/include/x86_64-linux-gnu' '--with-iconv' '--with-jpeg-dir=/usr/local/php543-cgi' '--with-openssl' '--with-pspell' '--with-pcre-regex' '--with-zlib' '--enable-exif' '--enable-ftp' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-wddx' '--with-kerberos' '--with-unixODBC=/usr' '--enable-shmop' '--enable-calendar' '--without-sqlite3' '--with-libxml-dir=/usr/local/php543-cgi' '--enable-pcntl' '--with-imap' '--with-imap-ssl' '--enable-mbstring' '--enable-mbregex' '--with-gd' '--enable-bcmath' '--with-xmlrpc' '--with-ldap' '--with-ldap-sasl' '--with-mysql=/usr' '--with-mysqli' '--with-snmp' '--enable-soap' '--with-xsl' '--enable-xmlreader' '--enable-xmlwriter' '--enable-pdo' '--with-pdo-mysql' '--with-pdo-pgsql' '--with-pear=/usr/local/php543-cgi/pear' '--enable-intl' '--without-pdo-sqlite' '--with-config-file-scan-dir=/usr/local/php543-cgi/php.d' '--enable-fastcgi'
    Einiges fehlt noch in meinen Zitaten, aber ich möchte nicht alles wieder rauskramen. Die meisten Fehler habe ich so schon durch Google beheben können !

    Jetzt folgendes :

    root@rv2528:/usr/local/src/php543# configure: error: Unable to find required gettext library

    Auf folgender Seite habe ich eine Lödsung gefunden ! https://bugs.php.net/bug.php?id=20429

    Funktioniert aber nicht. Was genau ist nun eine gute Lösung. Die User raten mir zu einem Downgrade, nun will ich dies machen und es geht nicht. Nur Stress, deswegen bitte ich die Antworten so klar wie möglich zu formulieren ! Unnötige Kommentare wie (Lass es sein wenn du es nicht kannst) möchte ich nicht Lesen, ich gebe mir Mühe und habe ein Ziel vor den Augen !


  • #2
    gettext haste uaf deiner dose?
    die ganzen automake/binutils sachen fehlen mir bei deinem apt-get.

    Kommentar


    • #3
      Ja gettext ist bereits schon installiet Aber was genu fehlt ? Eventuell einen Verweis auf eine Liste ? Vielen Dank !

      Kommentar


      • #4
        jo dann gibt deine gettext lib halt an.
        dein configure sermon kann so sowieso niemand lesen.

        Kommentar


        • #5
          http://pastebin.com/kb3x7v2f

          Hilft dir das weiter ?

          Kommentar


          • #6
            http://askubuntu.com/questions/49817...lled-with-lamp

            Warum willst du selbst kompilen ?
            [URL="https://gitter.im/php-de/chat?utm_source=share-link&utm_medium=link&utm_campaign=share-link"]PHP.de Gitter.im Chat[/URL] - [URL="https://raindrop.io/user/32178"]Meine öffentlichen Bookmarks[/URL] ← Ich habe dir geholfen ? [B][URL="https://www.amazon.de/gp/wishlist/348FHGUZWTNL0"]Beschenk mich[/URL][/B].

            Kommentar


            • #7
              mir fehlt in deiner liste noch wesentlich mehr.
              dafür hab ich deine ursprüngliche fehlermeldung nicht gefunden.

              nimm lieber was fertiges, und veröffentliche in zukunft keine peröhnlichen daten wie hostnamen.

              Kommentar

              Lädt...
              X