Ankündigung

Einklappen
Keine Ankündigung bisher.

PHP Installations Error

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • PHP Installations Error

    Hallo zusammen,

    ich bin absoluter Linux/php Neuling. ich habe versucht Auf meinem Linuxserver Php5.6.4 zu installieren. Dies habe ich mit der folgenden Anleitung durchgeführt

    http://adminforge.de/control-panel/p...ubuntu-centos/

    Gestern hatte das ganze bereits einmal funktioniert. Ich war jedoch dazu gezwungen das ganze erneut zu machen da der Server nicht richtig konfiguriert war und ich ihn neu aufsetzen lassen musste. Heute habe ich das ganze wiederholen wollen. Jedoch bricht die compilation mit der folgenden Fehlermeldung ab:

    /usr/local/src/php-5.6.4/ext/pdo_pgsql/pgsql_driver.c:33:31: fatal error: pdo/php_pdo_error.h: Datei oder Verzeichnis nicht gefunden
    #include "pdo/php_pdo_error.h"
    ^
    compilation terminated.
    make: *** [ext/pdo_pgsql/pgsql_driver.lo] Fehler 1


    Ich hoffe ich bin in diesem Forum überhaupt richtig und bedanke mich schon im Voraus für die Hilfe.

    Lieben Gruß


  • #2
    Willkommen im Forum.

    Hast du einen bestimmten Grund, PHP 5.6.4 selbst zu kompilieren und nicht die Version zu wählen, die die genutzte Distribution mitliefert?

    Das wäre nämlich unkomplizierter.

    Kommentar


    • #3
      Ich möchte gerne Typo3 neos installieren und dort wird empfohlen 5.6.x zu installieren. In der Distribution wurde leider nur Php 5.5.15 installiert. Ich kann leider nicht beurteilen in wieweit sich dies auswirkt, jedoch wollte ich da kein Risiko eingehen.

      Ist meine Sorge hier unbegründet?

      Kommentar


      • #4
        Ich denke ja.

        Dort heißt es:

        Make sure you have PHP 5.3.2 or later available on your web server. Make sure your PHP CLI binary is the same version! If available, you should use PHP 5.6 as it improves performance compared to earlier versions. Generally, a newer PHP version is better.
        - http://neos.typo3.org/develop/download.html

        Das sollte also auch mit 5.5.* laufen.

        Es ist generell immer eine gute Idee, die offiziell paketierte Software zu nutzen. Hier sehe ich keinen Grund, davon abzuweichen.

        Kommentar


        • #5
          Da hab ich wohl was inoffizielles gelesen bezüglich 5.6.4 . Ich werde das mal so versuchen. Vielen dank für die schnelle Hilfe

          Kommentar

          Lädt...
          X