Ankündigung

Einklappen
Keine Ankündigung bisher.

Serverwechsel und nun Probleme...

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Serverwechsel und nun Probleme...

    Hallo Leute...

    Ich habe vor ein paar Tagen einen neuen Server bei meinem Provider gemietet, ein paar Webseiten dort rüber geschoben, die entsprechenden Datenbanken ebenfalls transferiert & nun steh ich vor nem riesen Problem...

    Vorne weg: die Domains sind noch auf dem alten Server, auf dem neuen ist lediglich der Inhalt der Domains für den Umzug der Domains vorbereitet... (Vorschau-Modus)

    Also zum Problem:
    In keiner der Webseiten (alle mit php, mysql & Sessions) kann ich mich einloggen...
    Der Abgleich des Passwortes mit der Datenbank funktioniert (Meldung "Login erfolgreich") aber nach dem klick auf "Weiter" komm ich nicht wie gewünscht in die entsprechende ebene der Webseite...

    Da ich das Script nicht verändert habe, gehe ich davon aus das beim neuen Server was nicht richtig eingestellt ist...

    Aber was????

    Ich hoffe ihr könnt mir helfen...?!

    LG Tiieto


  • #2
    Logfiles schon angesehen um auf ev. Fehlermeldungen zu kommen? Ansonsten musst du wohl debuggen um der abweichenden Config auf den Grund zu gehen.. http://php-de.github.io/jumpto/leitfaden/
    Ist PHP Version ident?
    Debugging: Finde DEINE Fehler selbst! | Gegen Probleme beim E-Mail-Versand | Sicheres Passwort-Hashing | Includes niemals ohne __DIR__
    PHP.de Wissenssammlung | Kein Support per PN

    Kommentar


    • #3
      Also PHP version, Betriebssystem sind identisch...
      Lediglich die installierte Plesk Version unterscheiden sich...

      Logs: welche? Wo?

      LG Tiieto

      Kommentar


      • #4
        Vergleich mal die Bereiche mcrypt und hash. Ich weiß jetzt nicht wo da der Fehler genau liegt bzw. liegen könnte, aber womöglich hast du unterschiedliche default Verschlüsselungs- bzw. Hashalgorithmen. Lass dir doch mal ausgeben welcher Hash bei richtiger Passworteingabe rauskommt und vergleiche den Wert mit dem in der Datenbank.

        Kommentar


        • #5
          Da vieles über die Sessions läuft, habe ich mir nach jedem klick mal den Inhalt des Session Ordners (/var/lib/php/session/ ) angesehen...

          Es scheint so, als würde der Server mit jedem klick eine neue Session aufmachen...
          Nach 3 Klicks
          (1. betreten der Seite & eingeben der Userdaten + klick auf login
          2. meldung "Login erfolgreich --> Ebenenauswahl --> klick auf die gewünschte ebene)
          3. Die Seite nur mit dem Grundkostruckt, ohne den Content)
          sind dann 3 session Dateien im Ordner... (sess_blablubb123abcetc)

          Das sollte laut meines Wissens nicht passieren...

          Ideen für die Abhilfe????

          MfG

          Kommentar


          • #6
            Zitat von Tropi Beitrag anzeigen
            Lass dir doch mal ausgeben welcher Hash bei richtiger Passworteingabe rauskommt und vergleiche den Wert mit dem in der Datenbank.
            Ich denke das können wir überspringen... Grund: Ich bekomme ja bereits eine "Login erfolgreich" Meldung, & auch die Auswahl der Bereiche stimmt mit meiner Berechtigungsstufe überein... Somit kann das denk ich mal ausgeschlossen werden...

            LG Tiieto

            Kommentar


            • #7
              sieht nach einem Problem der Sessions aus. Hast du überhaupt eine Domain auf dem Server? Beim Zugriff nur mit IP funktionert mit Cookies manches nicht, und damit der Login nicht richtig.
              Fatal Error: Windows wird gestartet

              Wie administriert man ein Netzwerk: Beispiel

              Kommentar


              • #8
                Zitat von Unlikus Beitrag anzeigen
                Hast du überhaupt eine Domain auf dem Server? Beim Zugriff nur mit IP funktionert mit Cookies manches nicht, und damit der Login nicht richtig.
                Nein... Neuer Server... Daher wollte ich alles entsprechend einrichten BEVOR ich die eine oder andere Domain dorthin umziehen lasse...

                Könnte aber tatsächlich ein Lösungsansatz sein...
                Ich schieb mal ne Domain rüber & schau dann nach was passiert...

                LG Tiieto

                Kommentar


                • #9
                  Es reicht im übrigen auch ein Eintrag in der hosts Datei
                  Fatal Error: Windows wird gestartet

                  Wie administriert man ein Netzwerk: Beispiel

                  Kommentar

                  Lädt...
                  X