Ankündigung

Einklappen
Keine Ankündigung bisher.

PHP Mailversand und swiftmailer, bekomme es nicht hin. :/

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • PHP Mailversand und swiftmailer, bekomme es nicht hin. :/

    Guten Tag,
    ich bleibe irgendwie total bei dem E-Mailversand meines Servers hängen. Aufgesetzt wurde ein Debian Wheezy Server.

    Alles funktioniert bis auf der E-Mailversand.

    Nun wollte ich mich in swiftmailer einlesen, komme vom Verständnis aber überhaupt nicht damit klar. Ich bleibe schon bei diesem "composer" hängen.

    Der jetzige Code sieht wie folgt aus:

    PHP-Code:
    <section id="kontakt">
        <div class="container">
            <div class="heading">
                <h1>Kontakt</h1>
                <h2>Hier können Sie mich kontaktieren</h2>
            </div>
        </div>
        <div class="container">
            <div class="row">
                <div class="col-sm-8">
                    <img src="http://www.php.de/img/kontakt.jpg"/> <!-- kontakt.jpg -->
                    <p></p>
                </div>
                <div class="col-sm-4">
                    <div class=text>
                        <form action="#" method="POST">
                        <input type="text" name="name" size="42" class=input placeholder="Ihr Name" required><br>
                        <input type="text" name="email" size="42" class=input placeholder="Ihre E-Mailadresse"><br>
                        <textarea name="nachricht" class=input placeholder="Ihre Nachricht"  cols="40" rows="6" required></textarea><br>
                        <input type="submit" value="Nachricht senden!" class=input></form>
        <?php
            $name 
    $_POST[name];
            
    $email $_POST[email];
            
    $nachricht $_POST[nachricht];
            
    $emfaenger 'EMAIL ADRESSE';
            
    $betreff =  "Homepagenachricht von $name";
            
    $inhalt "$name hat dir folgene Nachricht geschrieben: $nachricht";
            
    mail ($emfaenger $betreff $inhalt"From: $name <$email>");
        
    ?>
                    </div>
                </div>
            </div>
        </div>
    </section>
    Wie und vorallem was muss ich ändern damit die E-Mail über einen Dienst wie Google o.Ä. versandt wird?

    Danke für eure Hilfe!


  • #2
    Was hast du bislang denn Richtung Composer versucht und was hat nicht funktioniert?
    Standards - Best Practices - AwesomePHP - Guideline für WebApps

    Kommentar


    • #3
      Eigentlich bleibe ich schon bei der Installation kleben...
      Ich wollte den Composer wie auf dieser Seite genannt installieren:
      https://getcomposer.org/download/

      Zusätzlich habe ich mir das hier durchgelesen:
      http://www.php.de/php-einsteiger/989...art-guide.html

      Kommentar


      • #4
        zum Swiftmailer: http://php-de.github.io/jumpto/mail-class/
        Debugging: Finde DEINE Fehler selbst! | Gegen Probleme beim E-Mail-Versand | Sicheres Passwort-Hashing | Includes niemals ohne __DIR__
        PHP.de Wissenssammlung | Kein Support per PN

        Kommentar


        • #5
          haste du nen falschen mirror ?
          Zitat von console
          # apt-get download curl
          Holen: 1 Herunterladen von curl 7.26.0-1+wheezy11 [270 kB]
          Es wurden 270 kB in 0 s geholt (329 kB/s).
          liegst am "debian/debian" ?
          kann man curl nicht als packet runterladen/ webbasiert/ und danach installieren?
          was machen denn deine updates so?
          gibst du immer so schnell auf?

          bei apt-get 404 und gut, ich glaubs nicht.

          Kommentar


          • #6
            Vielen Dank für eure Antworten. Besonders auch an moma, denn du hast recht. Bin zur Zeit nur ein wenig genervt von dieser ganzen composer Sache, weil man es einfach nicht versteht oder verstehen möchte.
            Wie dem auch sei sieht es nun so aus:



            Ich versuche mal mein weiteres Glück und hoffe mich nicht mehr melden zu müssen. :P

            Kommentar


            • #7
              scheint ja zu gehen.
              sei getrost, hab gerade mein backup überschreiebn bei dem zigsten versuch ein win-7 bootstick zu bauen, genervt - kann ich nachvollziehen.

              //OT:
              zum testen für andere ist einfach besser sowas in codeblocks zu posten.

              Kommentar

              Lädt...
              X