Ankündigung

Einklappen
Keine Ankündigung bisher.

[Erledigt] Datenbanktreiber für PHP zur Nutzung wikimedia (win7)

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Erledigt] Datenbanktreiber für PHP zur Nutzung wikimedia (win7)

    Moin !

    ich mächte mediawiki betreiben unter Win7 64bit und habe Apache 2.4, PHP 5.6.0 und Mysql 5.6 installiert.

    Nun habe ich den Installer für Mediawiki gestartet und bekomme die Meldung:

    Es konnte kein adäquater Datenbanktreiber gefunden werden. Es muss daher ein Datenbanktreiber für PHP installiert werden. Die folgenden Datenbanksysteme werden unterstützt: MySQL, PostgreSQL, Oracle, Microsoft SQL Server, SQLite
    Sofern ein gemeinschaftlich genutzter Server für das Hosting verwendet wird, muss der Hoster gefragt werden einen adäquaten Datenbanktreiber zu installieren. Sofern PHP selbst kompiliert wurde, muss es mit es neu konfiguriert werden, wobei der Datenbankclient zu aktivierten ist. Hierzu kann beispielsweise ./configure --with-mysql ausgeführt werden. Sofern PHP über die Paketverwaltung einer Debian- oder Ubuntu-Installation installiert wurde, muss das „php5-mysql“-Paket nachinstalliert werden.
    Ich verstehe leider nicht, was der von mir will. Kann mir einer weiterhelfen?

    Die aktuelle phpinfo liefert:

    PHP Version 5.6.0
    System Windows NT MA22-WIKI-001 6.1 build 7601 (Windows 7 Business Edition Service Pack 1) i586
    Build Date Aug 27 2014 11:49:46
    Compiler MSVC11 (Visual C++ 2012)
    Architecture x86
    Configure Command cscript /nologo configure.js "--enable-snapshot-build" "--enable-debug-pack" "--disable-zts" "--disable-isapi" "--disable-nsapi" "--without-mssql" "--without-pdo-mssql" "--without-pi3web" "--with-pdo-oci=c:\php-sdk\oracle\x86\instantclient_12_1\sdk,shared" "--with-oci8-12c=c:\php-sdk\oracle\x86\instantclient_12_1\sdk,shared" "--with-enchant=shared" "--enable-object-out-dir=../obj/" "--enable-com-dotnet=shared" "--with-mcrypt=static" "--without-analyzer" "--with-pgo"
    Server API CGI/FastCGI
    Virtual Directory Support disabled
    Configuration File (php.ini) Path C:\Windows
    Loaded Configuration File C:\PHP-5.6.0\php.ini
    Scan this dir for additional .ini files (none)
    Additional .ini files parsed (none)
    PHP API 20131106
    PHP Extension 20131226
    Zend Extension 220131226
    Zend Extension Build API220131226,NTS,VC11
    PHP Extension Build API20131226,NTS,VC11
    Debug Build no
    Thread Safety disabled
    Zend Signal Handling disabled
    Zend Memory Manager enabled
    Zend Multibyte Support disabled
    IPv6 Support enabled
    DTrace Support disabled
    Registered PHP Streams php, file, glob, data, http, ftp, zip, compress.zlib, phar
    Registered Stream Socket Transports tcp, udp
    Registered Stream Filters convert.iconv.*, mcrypt.*, mdecrypt.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, zlib.*
    Gruß Jan


  • #2
    immer noch nicht weitergekommen?
    ich dachte dein apache/php/mysql läuft?

    die von dir zitierte fehlermeldung ist schon irgendwie eindeutig, falls du damit nicht zurecht kommst, gibts bei dem programm keine faq/forum ode sonstwas?

    Kommentar


    • #3
      Moin !

      ich dachte dein apache/php/mysql läuft?
      #

      davon war ich auch ausgegangen !

      gibts bei dem programm keine faq/forum ode sonstwas?
      Dann muss ich wohl nochmal in einem wikimedia forum nachfragen.

      Danke erst einmal.

      Gruß Jan

      Kommentar


      • #4
        Scheinbar fehlt da ein PHP-Modul. Lass dir doch mit
        Code:
        php -m
        einmal alle geladenen Module ausgeben und sieh nach, ob ein MySQL-Modul (oder PDO) dabei ist.
        GitHub.com - ChrisAndChris - RowMapper und QueryBuilder für MySQL-Datenbanken

        Kommentar


        • #5
          Moin!

          das Ergebnis der Abfrage ist

          C:\PHP-5.6.0>php -m
          [PHP Modules]
          bcmath
          calendar
          Core
          ctype
          date
          dom
          ereg
          filter
          ftp
          hash
          iconv
          json
          libxml
          mcrypt
          mhash
          mysqlnd
          odbc
          pcre
          PDO
          Phar
          Reflection
          session
          SimpleXML
          SPL
          standard
          tokenizer
          wddx
          xml
          xmlreader
          xmlwriter
          zip
          zlib

          [Zend Modules]
          also sind diese Module wohl nicht bekannt.

          In einem älteren Buch habe ich gerade noch gefunden, dass wohl eine libmysql.dll und / oder libmysqli.dll in das Windows-Verzeichnis kopiert werden müssen.

          Dann sind diese als Extensions noch in der php.ini anzugeben.

          Das würde ich auch gerne machen - aber ich finde diese Dateien nicht wenn ich unter meinem PHP-Verzeichnis nach lib*.* suche.

          ????

          Gruß Jan

          Kommentar


          • #6
            PDO ist doch in der Liste (fehlender PDO-mysql-Treiber?), wenn du MySQL(i) nutzt liegts möglicherweise daran das du mysqlND installiert hast. Probiers mal mit dem nicht-nativen mysql(i) und werf mysqlnd raus, die neuen Module musst du dir schon runterladen wenn du sie nicht da hast

            Kommentar


            • #7
              extension=php_pdo_mysql.dll einkommentieren
              [URL="https://gitter.im/php-de/chat?utm_source=share-link&utm_medium=link&utm_campaign=share-link"]PHP.de Gitter.im Chat[/URL] - [URL="https://raindrop.io/user/32178"]Meine öffentlichen Bookmarks[/URL] ← Ich habe dir geholfen ? [B][URL="https://www.amazon.de/gp/wishlist/348FHGUZWTNL0"]Beschenk mich[/URL][/B].

              Kommentar


              • #8
                moin !

                ich hatte es vergessen - aber danke und Problem gelöst!

                Gruß Jan

                Kommentar

                Lädt...
                X