Ankündigung

Einklappen
Keine Ankündigung bisher.

Travis CI build error 127

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Travis CI build error 127

    Hallo leute,

    seit ich mein Projekt mit PHPStorm gepusht habe, funktioniert Travic Ci nicht mehr.

    Ich habe unter Settings -> Project Settings -> Deployment -> Options die Einstellungen "Override default permissions on files/folders" auf 644 und 755 eingestellt weil davor alle permissions automatisch auf 777 eingestellt wurden.

    Nun habe ich die Tage mit chmods rumexperementiert aber sowohl travis CI als auch scrutinizer-ci sind nicht in der lage die befehle make install-test und make full-test auszufuehren.

    https://travis-ci.org/Opentribes/Core/builds ab 349 ging es garnicht mehr, habe es dann auch noch mal versucht mit Netbeans das Projekt zu oeffnen und habe gehofft dass die Dateiberechtigung wiederhergestellt werden. Vielleicht suche ich aber an einer falschen stellen??

    Hat jemand eine Idee?

    Viele Gruesse
    apt-get install npm -> npm install -g bower -> bower install <package> YOLO https://www.paypal.me/BlackScorp | Mein Youtube PHP Kanal: https://www.youtube.com/c/VitalijMik


  • #2
    Komischer Fehler, die Datei existiert ja. Schonmal versucht es über "php path/file.php" zu starten? Vieleicht kommt der Server mit dem Shebang nicht klar, obwohl das auch eigentlich nicht sein sollte.
    Zitat von nikosch
    Macht doch alle was Ihr wollt mit Eurem Billigscheiß. Von mir aus sollen alle Eure Server abrauchen.

    Kommentar


    • #3
      Zitat von tkausl Beitrag anzeigen
      Komischer Fehler, die Datei existiert ja. Schonmal versucht es über "php path/file.php" zu starten? Vieleicht kommt der Server mit dem Shebang nicht klar, obwohl das auch eigentlich nicht sein sollte.
      probier ich mal heute abend aus, dachte ich brauch das ja nicht wegen https://github.com/Opentribes/Core/b.../config.php#L1
      apt-get install npm -> npm install -g bower -> bower install <package> YOLO https://www.paypal.me/BlackScorp | Mein Youtube PHP Kanal: https://www.youtube.com/c/VitalijMik

      Kommentar


      • #4
        Zitat von BlackScorp Beitrag anzeigen
        probier ich mal heute abend aus, dachte ich brauch das ja nicht wegen https://github.com/Opentribes/Core/b.../config.php#L1
        Ja, eigentlich nicht aber da ja irgendeine Datei nicht gefunden wurde, die .php datei aber 100%ig existiert bleibt nurnoch /usr/bin/env als Fehlerquelle.

        ggf. kannst du auch mal ein "ls -la cli" ins Makefile packen damit man beim build auch ganz sicher sein kann, dass die Datei da ist wo sie sein sollte und auch die Rechte hat, die sie haben sollte.

        E: Mal schnell geforked, so wie ich in #2 geschrieben hatte läuft es wieder: https://travis-ci.org/tkausl/Core
        Zitat von nikosch
        Macht doch alle was Ihr wollt mit Eurem Billigscheiß. Von mir aus sollen alle Eure Server abrauchen.

        Kommentar


        • #5
          Zitat von tkausl Beitrag anzeigen
          Ja, eigentlich nicht aber da ja irgendeine Datei nicht gefunden wurde, die .php datei aber 100%ig existiert bleibt nurnoch /usr/bin/env als Fehlerquelle.

          ggf. kannst du auch mal ein "ls -la cli" ins Makefile packen damit man beim build auch ganz sicher sein kann, dass die Datei da ist wo sie sein sollte und auch die Rechte hat, die sie haben sollte.

          E: Mal schnell geforked, so wie ich in #2 geschrieben hatte läuft es wieder: https://travis-ci.org/tkausl/Core
          oh gott wieso ist das denn nun? irgendwie merkwürdig dass es vorher lief, die haben wohl was am server verändert, machste ein pull request?
          apt-get install npm -> npm install -g bower -> bower install <package> YOLO https://www.paypal.me/BlackScorp | Mein Youtube PHP Kanal: https://www.youtube.com/c/VitalijMik

          Kommentar

          Lädt...
          X