Ankündigung

Einklappen
Keine Ankündigung bisher.

PHP Development Tools Framework for the Eclipse Platform

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • PHP Development Tools Framework for the Eclipse Platform

    Hallo,

    Nutzt das PHP Development Tools Framework for the Eclipse Platform jemand? Ich habe das All-in-one Packet runtergeladen aber in Eclipse ist nichts von PHP zu sehen...

    Muss ich da noch irgendeine Einstellung ändern?

    Gruß Thomas


  • #2
    EasyEclipse | Free, open source, easy-to-use Eclipse distributions and plugins for Windows, Mac and Linux - Easy Eclipse downloads
    ist der einfachste weg nen phpeclipse ans laufen zu kriegen meiner Meinung weis nicht ob dir das was nützt

    Kommentar


    • #3
      Hi,

      Ich hab mitlerweile eine Lösung gefunden und vergessen sie zu posten. Es liegt einfach daran, dass Java nicht in der Version 5 installiert war. Dadurch sieht man nichts von den PHP Funktionen in Eclipse.

      Gruß Thomas

      Kommentar


      • #4
        Tut mir leid das ich das Thema jetzt nochmal aufwärmen muss, aber ich bin heute schon den ganzen Nachmittag dabei dieses PHP Development Tool für Eclipse zu installieren. Die Installation von Eclipse klappt so weit problemlos, jedoch kommt es beim installieren von diversen Programmen immer zu folgendenden Fehlermeldungen ...

        Installation von Zend Debugger


        Code:
        Cannot complete the install because of a conflicting dependency.
          Software being installed: Zend Debugger Feature 5.3.18.v20110322 (org.zend.php.debug_feature.feature.group 5.3.18.v20110322)
          Software currently installed: Eclipse Platform 3.6.0.M20100909-0800 (org.eclipse.platform.ide 3.6.0.M20100909-0800)
          Only one of the following can be installed at once: 
            OSGi System Bundle 3.6.1.R36x_v20100806 (org.eclipse.osgi 3.6.1.R36x_v20100806)
            OSGi System Bundle 3.7.1.R37x_v20110808-1106 (org.eclipse.osgi 3.7.1.R37x_v20110808-1106)
            OSGi System Bundle 3.7.2.v20120110-1415 (org.eclipse.osgi 3.7.2.v20120110-1415)
            OSGi System Bundle 3.7.0.v20110613 (org.eclipse.osgi 3.7.0.v20110613)
          Only one of the following can be installed at once: 
            Workbench 3.7.1.v20120104-1859 (org.eclipse.ui.workbench 3.7.1.v20120104-1859)
            Workbench 3.7.0.I20110519-0100 (org.eclipse.ui.workbench 3.7.0.I20110519-0100)
            Workbench 3.6.1.M20100826-1330 (org.eclipse.ui.workbench 3.6.1.M20100826-1330)
          Cannot satisfy dependency:
            From: Core Runtime 3.7.0.v20110110 (org.eclipse.core.runtime 3.7.0.v20110110)
            To: bundle org.eclipse.osgi [3.7.0,4.0.0)
          Cannot satisfy dependency:
            From: EMF Common 2.7.0.v20110605-0747 (org.eclipse.emf.common 2.7.0.v20110605-0747)
            To: bundle org.eclipse.core.runtime [3.7.0,4.0.0)
          Cannot satisfy dependency:
            From: EMF Common 2.7.0.v20110912-0920 (org.eclipse.emf.common 2.7.0.v20110912-0920)
            To: bundle org.eclipse.core.runtime [3.7.0,4.0.0)
          Cannot satisfy dependency:
            From: EMF Common 2.7.0.v20120127-1122 (org.eclipse.emf.common 2.7.0.v20120127-1122)
            To: bundle org.eclipse.core.runtime [3.7.0,4.0.0)
          Cannot satisfy dependency:
            From: EMF Edit UI 2.7.0.v20110606-0949 (org.eclipse.emf.edit.ui 2.7.0.v20110606-0949)
            To: bundle org.eclipse.ui.workbench [3.7.0,4.0.0)
          Cannot satisfy dependency:
            From: EMF Edit UI 2.7.0.v20110913-1156 (org.eclipse.emf.edit.ui 2.7.0.v20110913-1156)
            To: bundle org.eclipse.ui.workbench [3.7.0,4.0.0)
          Cannot satisfy dependency:
            From: EMF Edit UI 2.7.0.v20120130-0943 (org.eclipse.emf.edit.ui 2.7.0.v20120130-0943)
            To: bundle org.eclipse.ui.workbench [3.7.0,4.0.0)
          Cannot satisfy dependency:
            From: PHP Development Tools (PDT) Runtime Feature 3.0.0.v20110516-1100-7V--F8NcJTTK4UE9TTJJ (org.eclipse.php.feature.group 3.0.0.v20110516-1100-7V--F8NcJTTK4UE9TTJJ)
            To: org.eclipse.wst.xml_ui.feature.feature.group [3.1.0,4.0.0)
          Cannot satisfy dependency:
            From: PHP Development Tools (PDT) Runtime Feature 3.0.1.v201201110400-7V-79F8NcJTcJTTTJwJJ (org.eclipse.php.feature.group 3.0.1.v201201110400-7V-79F8NcJTcJTTTJwJJ)
            To: org.eclipse.php.ui [3.0.1.v201201110400]
          Cannot satisfy dependency:
            From: PDT UI Plug-in 3.0.1.v201201110400 (org.eclipse.php.ui 3.0.1.v201201110400)
            To: bundle org.eclipse.emf.common 0.0.0
          Cannot satisfy dependency:
            From: Eclipse Platform 3.6.1.r361_v20100909-9pF78H4oFrRqnz-rr2sGKT6TX5Jjk3z0UdMaW (org.eclipse.platform.feature.group 3.6.1.r361_v20100909-9pF78H4oFrRqnz-rr2sGKT6TX5Jjk3z0UdMaW)
            To: org.eclipse.rcp.feature.group [3.6.1.r361_v20100827-9oBYFOtFkzKz-AxIz-fgWr5_V]
          Cannot satisfy dependency:
            From: Eclipse Platform 3.6.0.M20100909-0800 (org.eclipse.platform.ide 3.6.0.M20100909-0800)
            To: org.eclipse.platform.feature.group [3.6.1.r361_v20100909-9pF78H4oFrRqnz-rr2sGKT6TX5Jjk3z0UdMaW]
          Cannot satisfy dependency:
            From: Eclipse RCP 3.6.1.r361_v20100827-9oBYFOtFkzKz-AxIz-fgWr5_V (org.eclipse.rcp.feature.group 3.6.1.r361_v20100827-9oBYFOtFkzKz-AxIz-fgWr5_V)
            To: org.eclipse.osgi [3.6.1.R36x_v20100806]
          Cannot satisfy dependency:
            From: Eclipse RCP 3.6.1.r361_v20100827-9oBYFOtFkzKz-AxIz-fgWr5_V (org.eclipse.rcp.feature.group 3.6.1.r361_v20100827-9oBYFOtFkzKz-AxIz-fgWr5_V)
            To: org.eclipse.ui.workbench [3.6.1.M20100826-1330]
          Cannot satisfy dependency:
            From: Eclipse XML Editors and Tools 3.3.0.v201103310011-7H7EFZ-DxumTla66ahfUnHfpsz0u5Z92pU4TxSL (org.eclipse.wst.xml_ui.feature.feature.group 3.3.0.v201103310011-7H7EFZ-DxumTla66ahfUnHfpsz0u5Z92pU4TxSL)
            To: org.eclipse.wst.xsd.ui [1.2.404.v201105050216]
          Cannot satisfy dependency:
            From: Eclipse XML Editors and Tools 3.3.1.v201108102009-7H7EFZ3DxumTlaI6nheRdHo2p1KaDIL1Uz-S3PL (org.eclipse.wst.xml_ui.feature.feature.group 3.3.1.v201108102009-7H7EFZ3DxumTlaI6nheRdHo2p1KaDIL1Uz-S3PL)
            To: org.eclipse.wst.xsd.ui [1.2.404.v201105050216]
          Cannot satisfy dependency:
            From: Eclipse XML Editors and Tools 3.3.2.v201112072049-7H7EFZ7DxumTmce4khcSkIiqoD8eDMKlT8Oz011P (org.eclipse.wst.xml_ui.feature.feature.group 3.3.2.v201112072049-7H7EFZ7DxumTmce4khcSkIiqoD8eDMKlT8Oz011P)
            To: org.eclipse.wst.xsd.ui [1.2.404.v201105050216]
          Cannot satisfy dependency:
            From: XML Schema Editor 1.2.404.v201105050216 (org.eclipse.wst.xsd.ui 1.2.404.v201105050216)
            To: bundle org.eclipse.emf.edit.ui [2.2.0,3.0.0)
          Cannot satisfy dependency:
            From: Zend Debugger Feature 5.3.18.v20110322 (org.zend.php.debug_feature.feature.group 5.3.18.v20110322)
            To: org.eclipse.php.feature.group 0.0.0
        Installation von PHP Development Tools

        so ziemlich der gleiche Fehler

        Code:
        Cannot complete the install because of a conflicting dependency.
          Software being installed: PHP Development Tools (PDT) SDK Feature 3.0.0.v201201110400-77-184_2BEICRgM_fMVcz0M4Va9O (org.eclipse.php.sdk.feature.group 3.0.0.v201201110400-77-184_2BEICRgM_fMVcz0M4Va9O)
          Software currently installed: Eclipse Platform 3.6.0.M20100909-0800 (org.eclipse.platform.ide 3.6.0.M20100909-0800)
          Only one of the following can be installed at once: 
            OSGi System Bundle 3.6.1.R36x_v20100806 (org.eclipse.osgi 3.6.1.R36x_v20100806)
            OSGi System Bundle 3.7.1.R37x_v20110808-1106 (org.eclipse.osgi 3.7.1.R37x_v20110808-1106)
            OSGi System Bundle 3.7.2.v20120110-1415 (org.eclipse.osgi 3.7.2.v20120110-1415)
            OSGi System Bundle 3.7.0.v20110613 (org.eclipse.osgi 3.7.0.v20110613)
          Cannot satisfy dependency:
            From: Core Runtime 3.7.0.v20110110 (org.eclipse.core.runtime 3.7.0.v20110110)
            To: bundle org.eclipse.osgi [3.7.0,4.0.0)
          Cannot satisfy dependency:
            From: EMF Common 2.7.0.v20110605-0747 (org.eclipse.emf.common 2.7.0.v20110605-0747)
            To: bundle org.eclipse.core.runtime [3.7.0,4.0.0)
          Cannot satisfy dependency:
            From: EMF Common 2.7.0.v20110912-0920 (org.eclipse.emf.common 2.7.0.v20110912-0920)
            To: bundle org.eclipse.core.runtime [3.7.0,4.0.0)
          Cannot satisfy dependency:
            From: EMF Common 2.7.0.v20120127-1122 (org.eclipse.emf.common 2.7.0.v20120127-1122)
            To: bundle org.eclipse.core.runtime [3.7.0,4.0.0)
          Cannot satisfy dependency:
            From: PHP Development Tools (PDT) Runtime Feature 3.0.1.v201201110400-7V-79F8NcJTcJTTTJwJJ (org.eclipse.php.feature.group 3.0.1.v201201110400-7V-79F8NcJTcJTTTJwJJ)
            To: org.eclipse.php.ui [3.0.1.v201201110400]
          Cannot satisfy dependency:
            From: PHP Development Tools (PDT) SDK Feature 3.0.0.v201201110400-77-184_2BEICRgM_fMVcz0M4Va9O (org.eclipse.php.sdk.feature.group 3.0.0.v201201110400-77-184_2BEICRgM_fMVcz0M4Va9O)
            To: org.eclipse.php.feature.group [3.0.1.v201201110400-7V-79F8NcJTcJTTTJwJJ]
          Cannot satisfy dependency:
            From: PDT UI Plug-in 3.0.1.v201201110400 (org.eclipse.php.ui 3.0.1.v201201110400)
            To: bundle org.eclipse.emf.common 0.0.0
          Cannot satisfy dependency:
            From: Eclipse Platform 3.6.1.r361_v20100909-9pF78H4oFrRqnz-rr2sGKT6TX5Jjk3z0UdMaW (org.eclipse.platform.feature.group 3.6.1.r361_v20100909-9pF78H4oFrRqnz-rr2sGKT6TX5Jjk3z0UdMaW)
            To: org.eclipse.rcp.feature.group [3.6.1.r361_v20100827-9oBYFOtFkzKz-AxIz-fgWr5_V]
          Cannot satisfy dependency:
            From: Eclipse Platform 3.6.0.M20100909-0800 (org.eclipse.platform.ide 3.6.0.M20100909-0800)
            To: org.eclipse.platform.feature.group [3.6.1.r361_v20100909-9pF78H4oFrRqnz-rr2sGKT6TX5Jjk3z0UdMaW]
          Cannot satisfy dependency:
            From: Eclipse RCP 3.6.1.r361_v20100827-9oBYFOtFkzKz-AxIz-fgWr5_V (org.eclipse.rcp.feature.group 3.6.1.r361_v20100827-9oBYFOtFkzKz-AxIz-fgWr5_V)
            To: org.eclipse.osgi [3.6.1.R36x_v20100806]
        Die Anleitung von Luigi vom 23.03.2008 für EasyEclipse habe ich auch bereits probiert ...

        http://www.easyeclipse.org/site/distributions/php.html

        Jedoch kommt es da immer wieder zu einem Fehler beim entpacken, eigentich sollte die tar.gz-Datei auch nicht nur 1 MB gross sein, sondern 140 MB.


        Hat noch jemand Ideen wie ich es realisieren kann unter CentOS einen PHP-Debugger ans Laufen zu bekommen ?

        MfG fontsix

        Kommentar


        • #5
          Wenn du nur den debugger willst:
          http://jessesanford.com/2010/02/04/i...g-on-centos-5/

          Builds (auch für linux) gibts hier: http://www.zend.com/en/community/pdt/downloads
          Runterladen, nach opt entpacken und los gehts. Bin mir nicht sicher, ob openjdk ausreicht - zur not noch jre installieren.
          I like cooking my family and my pets.
          Use commas. Don't be a psycho.
          Blog - CoverflowJS

          Kommentar

          Lädt...
          X