Ankündigung

Einklappen
Keine Ankündigung bisher.

Frage zu einem Login Script

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Frage zu einem Login Script

    Hallo, ich habe meine Website bei Strato gehostet, eine Datenbank angelegt, tables angelegt, etc... also: Vorarbeit geleistet.
    Jetzt habe ich ein Script, welches wie folgt aussieht:
    PHP-Code:
    <?php

    require_once 'includes/constants.php';

    class 
    Mysql {
        private 
    $conn;
        
        function 
    __construct() {
            
    $this->conn = new mysqli (DB_SERVERDB_USERDB_PASSWORDDB_NAME) or 
                die(
    'There was a problem connecting to the database.');
            
        }
        
        function 
    verify_Username_and_Pass($un$pwd) {
                
            
    $query "SELECT *
                FROM clients
                WHERE username = ? AND password = ?
                LIMIT 1"
    ;
            if(
    $stmt $this->conn->prepare($query)) {
                
    $stmt->bin_param('ss'$un$pwd);
                
    $stmt->execute();
                
                if(
    $stmt->fetch()) {
                    
    $stmt->close();
                    return 
    true;
                }
                
            }
            

        }

    }
    ?>
    Die Einträge in der Constants.php sind auch korrekt, trotzdem bekomme ich bei Aufruf der login.php die folgende Meldung:

    mysqli::mysqli() [mysqli.mysqli]: (HY000/2003): Can't connect to MySQL server on 'rdbms.webmailer.de' (146)

    und das, obwohl der Server eigentlich rdbms.strato.de heisst. Aber die Fehlermeldung an sich: wo ist denn der Fehler? Denn lokal funktioniert es.

    Freue mich über Hilfe.


  • #2
    Zitat von strousberg Beitrag anzeigen
    Die Einträge in der Constants.php sind auch korrekt
    Das ist schwer vorstellbar, denn welchen Grund sollte es dann geben, dass beim Verbindungsaufbau ein anderer Servername verwendet wird?

    Stelle bitte das error_reporting auf E_ALL und display_errors auf 1, wenn nicht bereits geschehen.

    Kommentar


    • #3
      Probier doch Mal 'localhost' als Server aus.
      LG Sonic

      Kommentar


      • #4
        Zitat von Sonic Beitrag anzeigen
        Probier doch Mal 'localhost' als Server aus.
        LG Sonic
        Das wird nicht funktionieren! Der Server lautet rdbms.strato

        In deinem Script sind keine " um die Logindaten:

        $this->conn = new mysqli ("DB_SERVER", "DB_USER", "DB_PASSWORD", "DB_NAME") or .....

        Das der Server anscheinen zu rdbms.webmailer.de verbinden will hat denke ich nichts zu bedeuten. Das kommt auch wenn rdms.strato richtig angegeben ist.
        Ich vermute eher ein Problem bei den Logindaten (Passwort oder User) oder eben die fehlenden " s.o.

        hoffe geholfen zu haben
        gruß roest
        May the Source be with you.

        Kommentar


        • #5
          Wenn die Datenbank und das PHP Skript auf dem selben Host liegen kann "localhost" durchaus funktionieren!

          Und um die Logindaten gehört KEIN Anführungszeichen wenn es sich um Konstanten handelt!

          Und ich find es schon komisch wenn aus "rdms.strato" auf einmal "rdbms.webmailer.de" wird!

          Kommentar


          • #6
            Sollte die Namensauflösung abgestellt sein, funktionieren nur noch IP's oder localhost...
            Über 90% aller Gewaltverbrechen passieren innerhalb von 24 Stunden nach dem Konsum von Brot.

            Kommentar


            • #7
              Ich hab bei mir rdbms.strato.de stehen und funktioniert einwandfrei.

              Und ich find es schon komisch wenn aus "rdms.strato" auf einmal "rdbms.webmailer.de" wird!
              Der "Fehler" ist aber nicht ungewöhnlich.
              Wenn man mal nach "rdbms.strato rdbms.webmailer" googelt findet man mehrere vergleichbare Probleme

              Auch ich kann mich erinnern das ich zu anfangszeiten eine falsche connect funktion gebaut hatte und eben diesen "Fehler" hatte das er auf rdbms.webmailer als host verbinden wollte.

              Was genau da allerdings falsch war kann ich nicht mehr sagen (meinem Kopf sei dank ).
              May the Source be with you.

              Kommentar

              Lädt...
              X