Ankündigung

Einklappen
Keine Ankündigung bisher.

[Erledigt] IIS und PHP 4.3.7

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Erledigt] IIS und PHP 4.3.7

    Hallo,
    Gibt es irgendwo auf der Welt eine genaue Erklärung wie das PHP.ini aussehen soll wenn PHP mit IIS 5.1 funktionieren soll.
    Bei mir scheint er die superglobalen variablen $_POST, $_GET nicht richtig zu laden oder zu verwalten.

    Hat jemand eine Erklärung


  • #2
    Re: IIS und PHP 4.3.7

    Zitat von aals
    Gibt es irgendwo auf der Welt eine genaue Erklärung wie das PHP.ini aussehen soll wenn PHP mit IIS 5.1 funktionieren soll.
    Für PHP gibt es ein Handbuch, in dem die Konfiguration beschrieben wird.
    Bei mir scheint er die superglobalen variablen $_POST, $_GET nicht richtig zu laden oder zu verwalten.
    Die Abhängigkeit der Superglobals von der Config-Variablen register_globals ist Dir hoffentlich geläufig?

    Falls ja, ist es ein Bug.
    Falls nein, ist es eine Anfängerfrage.

    Kommentar


    • #3
      Danke für die Belehrungen

      Ich habe alles versucht und auch die register_globals auf on gesetzt, wie Sie wissen ist das auch ein Sicherheitrisiko. Es gibt eine bessere Installtionsanleitung als im Handbuch, nähmlcih unter info24.de, soviel zum Anfänger.
      Also haben Sie keine neuen Erkenntnise?

      Kommentar


      • #4
        Re: Danke für die Belehrungen

        Zitat von aals
        Ich habe alles versucht und auch die register_globals auf on gesetzt,
        Wenn in der php.ini
        Code:
        register_globals = Off
        die PHP Version >= 4.1.0 und die Formulardaten trotzdem nicht in $_GET/_POST/$_REQUEST verfügbar sind, hat die von Euch verwendete PHP Version für Windows offenbar einen Bug.

        Kommentar


        • #5
          Und denk an die Berechtigungen für IUSR_COMPUTERNAME !
          Dieser muss auch auf die php.ini Leserechte haben.

          Kommentar


          • #6
            Also ich hatte auch derbe probs mit der 4.3.7... hab wieder 4.3.6 drauf und alles läuft top.
            Die error_reporting funktion hat nicht funktioniert (sowohl php.ini, als auch in einem Skript =>php4ts.dll ist der Fehler drin...).

            Kommentar

            Lädt...
            X