Ankündigung

Einklappen
Keine Ankündigung bisher.

[Erledigt] $_SERVER['PHP_AUTH_USER'] etc wird nicht gesetzt?

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Erledigt] $_SERVER['PHP_AUTH_USER'] etc wird nicht gesetzt?

    Ich benutze 4.4.1 (http://www.sportpoint24.com/interface/info.php) ,
    habe aber das Problem das egal was ich mache die beiden Variablen nicht gesetzt werden. Register_Globals ist auf off.
    Irgendjemand eine Idee woran es liegen kann?
    Am Code kann es nicht liegen da es auf anderen Servern einwandfrei funktioniert


  • #2
    kannst ja mal phpinfo() machen und schauen was dort unter $_SERVER['PHP_AUTH_USER'] steht
    Wie man Fragen richtig stellt

    Kommentar


    • #3
      Leider gibt er mir nichts dazu aus , bin total Ratlos. Vieleicht hängt es an einem fehlenen Apache Modul?

      Kommentar


      • #4
        print_r($_SERVER);

        vielleicht heißts nur anders (wohl kaum, aber wer weiß)

        Kommentar


        • #5
          PHP-Code:
          if(!empty($_SERVER['PHP_AUTH_USER']) or !empty($_SERVER['PHP_AUTH_PW']) or !empty($PHP_AUTH_USER) or !empty($PHP_AUTH_PW)) {
          echo 
          "man bin ich doof";
          die;

          habe ich am anfang der kompletten Datei eingefügt , Variablen werden trotzdem nicht erstellt.

          Kommentar


          • #6
            also echo $_SERVER['PHP_AUTH_USER'] gibt bei mir auch nix aus..

            habs getestet auf Windows mit der neusten XAMPP version.

            print_r($_SERVER) gibt bei mir das aus:
            Code:
            Array
            (
                [HTTP_HOST] => localhost
                [HTTP_USER_AGENT] => Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051111 Firefox/1.5
                [HTTP_ACCEPT] => text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
                [HTTP_ACCEPT_LANGUAGE] => de-de,de;q=0.8,en-us;q=0.5,en;q=0.3
                [HTTP_ACCEPT_ENCODING] => gzip,deflate
                [HTTP_ACCEPT_CHARSET] => ISO-8859-1,utf-8;q=0.7,*;q=0.7
                [HTTP_KEEP_ALIVE] => 300
                [HTTP_CONNECTION] => keep-alive
                [HTTP_REFERER] => http://localhost/
                [HTTP_CACHE_CONTROL] => max-age=0
                [PATH] => C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Programme\ATI Technologies\ATI Control Panel;;C:\Programme\Gemeinsame Dateien\GTK\2.0\bin;C:\Programme\Microsoft SQL Server\80\Tools\Binn\;C:\Programme\QuickTime\QTSystem\
                [SystemRoot] => C:\WINDOWS
                [COMSPEC] => C:\WINDOWS\system32\cmd.exe
                [PATHEXT] => .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
                [WINDIR] => C:\WINDOWS
                [SERVER_SIGNATURE] => <address>Apache/2.0.54 (Win32) PHP/5.0.4 mod_ssl/2.0.54 OpenSSL/0.9.8 mod_perl/1.999.21 Perl/v5.8.6 Server at localhost Port 80</address>
            
                [SERVER_SOFTWARE] => Apache/2.0.54 (Win32) PHP/5.0.4 mod_ssl/2.0.54 OpenSSL/0.9.8 mod_perl/1.999.21 Perl/v5.8.6
                [SERVER_NAME] => localhost
                [SERVER_ADDR] => 127.0.0.1
                [SERVER_PORT] => 80
                [REMOTE_ADDR] => 127.0.0.1
                [DOCUMENT_ROOT] => C:/webserver
                [SERVER_ADMIN] => admin@localhost
                [SCRIPT_FILENAME] => C:/webserver/test2.php
                [REMOTE_PORT] => 3687
                [GATEWAY_INTERFACE] => CGI/1.1
                [SERVER_PROTOCOL] => HTTP/1.1
                [REQUEST_METHOD] => GET
                [QUERY_STRING] => 
                [REQUEST_URI] => /test2.php
                [SCRIPT_NAME] => /test2.php
                [PHP_SELF] => /test2.php
            )
            Wie man Fragen richtig stellt

            Kommentar


            • #7
              Ich benutze
              PHP-Code:
              <?php
              Header
              ("HTTP/1.1 401 Unauthorized"); 
              Header("WWW-Authenticate: Basic realm=\"KundenBereich Login\"");
              ?>
              als Header btw.

              Das ganze soll ein Login sein

              Kommentar


              • #8
                php läuft als cgi ... und damit geht das nicht.
                http://php-faq.de/q/q-php-passwort.html
                robo47.net - Blog, Codeschnipsel und mehr
                | Caching-Klassen und Opcode Caches in php | Robo47 Components - PHP Library extending Zend Framework

                Kommentar


                • #9
                  Danke....

                  Kommentar

                  Lädt...
                  X