Ankündigung

Einklappen
Keine Ankündigung bisher.

GnuPG E-Mails signieren.

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • GnuPG E-Mails signieren.

    Ich weis das es hier schon solch einen Thread im Anfänger bereicht gibt. Jedoch finde ich, der gehört dort nicht hin und wurde dort auch falsch aufgezogen.

    Naja nun stehe ich aber auch vor dem problem E-Mails signieren zu müssen.

    Das Problem, auf dne passphrase des priv key wollte ich nicht verzichten.

    Mein Lösungsansatz:

    Code:
    $descriptorspec = array(
       0 => array("pipe", "r"),  // stdin is a pipe that the child will read from
       1 => array("pipe", "w"),  // stdout is a pipe that the child will write to
       2 => array("file", "error-output.txt", "a") // stderr is a file to write to
    );
    
    $out="";
    
    $process = proc_open('/srv/www/htdocs/web100/html/gnupg/bin/gpg --clearsign /srv/www/htdocs/web100/html/test/rubriken.html', $descriptorspec, $pipes);
    
    if (is_resource($process)) {
       fwrite($pipes[0], 'geheim');
       fwrite($pipes[0], 'y');
       fclose($pipes[0]);
    
       while (!feof($pipes[1])) {
           $out .= fgets($pipes[1], 1024);
       }
       echo $out;
       fclose($pipes[1]);
    
       // It is important that you close any pipes before calling
       // proc_close in order to avoid a deadlock
       $return_value = proc_close($process);
    
       echo "command returned $return_value\n";
    } else { echo "FAILER"; }
    Also das proble ist, das daß error log folgendes zurück giebt:
    Code:
    gpg: WARNING: using insecure memory!
    gpg: please see http://www.gnupg.org/faq.html for more information
    gpg: fatal: can't create directory `/root/.gnupg': Permission denied
    secmem usage: 0/0 bytes in 0/0 blocks of pool 0/32768
    wobei ich nicht ganz verstehe wiso /root/.gnupg, da ich ja als --prefix beim compelieren von gnupg /srv/www/htdocs/web100/html/gnupg verwendet habe.

    Desweiteren sehe ich ein Problem darin, das das gnupg ja mit dne Rechten von wwwrun ausgeführt wird und nicht mit denen des webaccounts.

    Hat einer von euch das Problem schon einmal gelöst oder eine Ahnung, wie man da rann gehen sollte?
    www.keine-angst-vorm-pc.de/forum


  • #2
    So ich bin selbst noch ein stückchen weiter gekommen.

    --homedir /var/lib/wwwrun/.gnupg

    löst ein problem, doch das 2te besteht weiterhin.

    Code:
    gpg: please see http://www.gnupg.org/faq.html for more information
    gpg: cannot open `/dev/tty': No such device or address
    Da ja der user wwwrun aus Sicherheitsgründen auf bin/flase steht

    und ich mit dem Parameter --no-tty ja keine eingaben machen kann.


    ----------------------------------------------------------------------------------
    http://de.php.net/manual/de/function.proc-open.php
    Vorallem dort steht doch man kann als descriptorspec auch pty verwenden. Was PHP (4.3.11) aber verweigert? Kann das auch daran liegen das der wwwrun user auf bin/false ist?
    www.keine-angst-vorm-pc.de/forum

    Kommentar


    • #3
      --no-secmem-warning --quiet --batch und Du solltest Ruhe haben
      Cheers, Marco

      Kommentar


      • #4
        kk, danke aber ich habe es mitlerweile auch rausgefunden :-p
        www.keine-angst-vorm-pc.de/forum

        Kommentar

        Lädt...
        X