Ankündigung

Einklappen
Keine Ankündigung bisher.

Mails kommen nicht an mit Hamster/Mercury

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Mails kommen nicht an mit Hamster/Mercury

    Hi, würde gerne die mail()-Funktion unter Win mit eigenem Mailserver verwenden. Habe es mit Hamster und Mercury versucht. Das Skript gibt keinen Fehler, in den SMTP-Protokollen der Programme sieht auch alles gut aus. Nur kommen die Mails leider nicht an, auch nicht im Spam.
    Woran könnte das liegen?
    Ich dachte an die Firewall, aber bei lokalen Mails dürfte die doch keine Rolle spielen, oder? Bin hinter einem Router.
    Viele Grüße


  • #2
    Hat doch nix mit PHP zu tun, außerdem kann man bei der Fragestellung mal wieder nix wirklich informatives aus der Frage fischen.

    Kommentar


    • #3
      Naja, PHP gibt keine Fehler, das stimmt, aber es ist ja eng verknüpft mit dem Mailserver und vielleicht hat ja jemand ähnliche Erfahrungen oder eine Idee.
      Was ist an der Frage nicht informativ? Die mail()-Funktion gibt true, also alles klar. Der Mailserver schreibt in seinem Protokoll einen normalen SMTP-Dialog und ich finde die Mail sogar im sent-Ordner. Aber sie kommt einfach nicht an... Wie könnte ich das besser beschreiben?
      Hat jemand Hamster oder Mercury am Laufen und nicht so ein Problem gehabt, ging es auf Anhieb?
      Weiss jetzt nicht ob das an meinem Win liegt oder am Router oder am Server...
      Viele Grüße

      Kommentar


      • #4
        lokaler mail-server auf ner dnymaische IP ?
        sowas wird imho zu 99,9 % als spam eingeordnet und der mailserver nimmt es nicht an oder tritt es in die tonne würde ich mal sagen, such mal bissel dazu hier im forum, ein lokaler mailserver ist nicht wirklich ne möglichkeit zum entwickeln und testen.

        mfg
        robo47
        robo47.net - Blog, Codeschnipsel und mehr
        | Caching-Klassen und Opcode Caches in php | Robo47 Components - PHP Library extending Zend Framework

        Kommentar


        • #5
          Zitat von bicpi
          Was ist an der Frage nicht informativ? Die mail()-Funktion gibt true, also alles klar.
          Nein, es heißt nur, dass es syntaktisch richtig zu sein scheint. Schick halt mal ohne PHP ne Mail darüber weg.

          Kommentar


          • #6
            Also über Thunderbird und Hamster passiert das Gleiche wie bei PHP. Keine Fehlermeldung im MUA, schönes Protokoll im MTA und Mail verschwunden...
            Viele Grüße

            Kommentar


            • #7
              Dann ist es offenbar kein PHP-Problem. Und vielleicht hat ja robo47 recht. Frag doch mal bei deinem Mailprovider nach, ob es einen solchen Spamfilter gibt.

              Edit: Übrigens, warum verwendest du nicht deinen Mail-Provider zum Verschicken? Bei mir wurde es mal wunderbar verschickt, eben ohne lokalen Mailserver. Allerdings mußte ich vor dem Versenden mit meinem Mailclient Mails abrufen (der dann praktisch für den erfolgreichen Login gesorgt hat).

              Zum Testen hat das genügt.

              Kommentar


              • #8
                Aber im Spam-Ordner ist ja nichts oder gibts das auch, dass die Annahme komplett verweigert wird? Ansonsten ist die Mail ja korrekt abgeschickt, nur die Absenderadresse könnte den Unterschied machen.
                Ich versuchs jetzt mal mit einem Postfach meines eigenen Servers, vielleicht funkt das, bisher war alles über GMX und die sind wahrlich recht streng...
                Viele Grüße

                Kommentar


                • #9
                  Ja es gibt natürlich auch globale Spamfilter, die gleich von vornherein abblocken (zum Beispiel wenn der Absender als Spammer bekannt ist (Blacklist) oder vom Absender an verschiedene (also tausende) Adressen die gleiche Mail geschickt werden (Flooding)). Die siehste dann nicht mal in deinem Spam-Ordner.

                  Evtl. ist eben auch ein Filter drin, wie es robo47 gesagt hat.

                  Und das ganze auf deinen Server verfrachten, da hätteste nun wirklich früher drauf kommen können

                  Kommentar


                  • #10
                    Und das ganze auf deinen Server verfrachten, da hätteste nun wirklich früher drauf kommen können
                    Hast ja recht

                    Hab ich nun gemacht mit dem Server, aber es geht auch nicht, Mails kommen nicht an. Weder über PHP noch über MUA. Das gibts doch nicht, auf dem Server hab ich keinen Filter und ansonsten funkt der Account einwandfrei.
                    Viele Grüße

                    Kommentar


                    • #11
                      Ich denke trotzdem, dass du dann eher in ein anderes Forum gehen solltest (nicht weils mich persönlich stört, sondern weil hier nur PHP Freaks rumrennen und keine Mailserver-Admins :P )

                      Kommentar

                      Lädt...
                      X