Ankündigung

Einklappen
Keine Ankündigung bisher.

PHP verschluckt Fehlermeldungen

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • PHP verschluckt Fehlermeldungen

    Ich verwende den Injector von Auryn und Fastroute im Bootstrapper meiner Applikation:

    PHP-Code:
             foreach ( $listenerList as $qualifiedListener ) {              
    $Listener $injector->make$qualifiedListener );              
    $Listener->attach();        
     } 
    Gleich der erste Listener verursacht einen Fatal Error bzw. eine Exception - vermute ich zumindest, denn PHP erzeugt keine Fehlermeldung. Die erste Zeile Code am Einstiegspunkt der App besteht aus:

    PHP-Code:
    error_reportingE_ALL );
    ini_set'display_errors'); 
    Da ich vermutete, dass diese PHP-Datei gar nicht vollständig kompiliert wird, habe ich zudem diese Zeilen in die htaccess gepackt:

    Code:
    php_flag display_startup_errors on
    php_flag display_errors on
    php_flag html_errors on
    php_flag  log_errors on
    php_value error_log  /media/Entwicklung/Entwicklung.xyz/www/v2/wp-content/debug.log
    Ich sehe weder Fehler in der Antwort des AJAX-Requests, noch in der debug.log. Was kann/muss man hier noch versuchen?


  • #2
    Das Error-Logging sollte in der php.ini konfiguriert werden.

    Wie lautet eigentlich der HTTP Statuscode, den du erhältst?

    Kommentar


    • #3
      Zitat von hellbringer Beitrag anzeigen
      Das Error-Logging sollte in der php.ini konfiguriert werden.
      Wie lautet eigentlich der HTTP Statuscode, den du erhältst?
      500 Internal Server Error.

      Ich konnte den Fehler mittlerweile relativ mühsam beheben; es ist richtig, dass ich die Konfiguration zentral in der php.ini machen sollte.

      Kommentar


      • #4
        Zitat von hellbringer Beitrag anzeigen
        Das Error-Logging sollte in der php.ini konfiguriert werden.

        Wie lautet eigentlich der HTTP Statuscode, den du erhältst?
        Geht nur solange die Produktivumgebung nicht die gleiche PHP-Config hat die Entwicklungsumgebung. Und ich kann mir vorstellen, dass es einige Leute hier gibt, die beides auf dem gleichen Host mit der gleichen PHP-Config laufen lassen.

        Und das Problem war jetzt was genau paddelboot ? Ich denke es lag an einer htaccess

        Kommentar


        • #5
          Zitat von werwiewas Beitrag anzeigen
          Geht nur solange die Produktivumgebung nicht die gleiche PHP-Config hat die Entwicklungsumgebung. Und ich kann mir vorstellen, dass es einige Leute hier gibt, die beides auf dem gleichen Host mit der gleichen PHP-Config laufen lassen.
          Was halt absolut falsch ist. Da darf man sich nicht wundern.

          Kommentar


          • #6
            Zitat von hellbringer Beitrag anzeigen

            Was halt absolut falsch ist. Da darf man sich nicht wundern.
            Absolut. Aber vermutlich zu oft Realität.

            Kommentar


            • #7
              Am besten ist es ja im Log des jeweiligen Webservers nachzusehen / im PHP Log

              Kommentar

              Lädt...
              X