Ankündigung

Einklappen
Keine Ankündigung bisher.

[Erledigt] Upload-Fehler

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Erledigt] Upload-Fehler

    Hallo,

    ich habe seit kurzem einen VServer mit Plesk, und alle meine alten Upload-Scripts funktionieren nicht mehr. Der Upload an sich funktioniert noch, aber bei move_uploaded_file verschwindet die Datei auf einmal. Ich denke es liegt daran, dass php nicht auf das standardmäßige C:\Windows\Temp zugreifen kann. Eine Änderung von upload_tmp_dir in der php.ini hat $_FILES["file"]["tmp_name"] nicht geändert, obwohl ini_get("upload_tmp_dir") jetzt das richtige Verzeichnis liefert!
    Wie kann das sein?!

    Bitte um Hilfe


  • #2
    Bist du dir sicher, dass nicht das Zielverzeichnis das Problem macht?
    Im Error-Log sollte übrigens auch drinstehn, was für einen Fehler move_uploaded_file schmeißt...
    Zitat von nikosch
    Macht doch alle was Ihr wollt mit Eurem Billigscheiß. Von mir aus sollen alle Eure Server abrauchen.

    Kommentar


    • #3
      Ich finde es schon verwunderlich dass in der ini das eine Verzeichnis steht und die Datei dennoch im anderen landet... Der Fehler ist auf jeden Fall:
      PHP-Code:
      [function.move-uploaded-file]: failed to open streamPermission denied 
      Aber wie kann ich php jetzt Rechte für das Verzeichnis zuteilen?

      Kommentar


      • #4
        Vieleicht hilft das:
        http://stackoverflow.com/questions/5...o-php-on-iis-7

        Kenne mich mit Windows-Servern nicht wirklich aus...
        Wobei ich aber der Meinung bin, das Temp von jedem User beschreibbar und lesbar sein sollte, das Problem also beim Zielordner sein müsste. Kann mich aber auch irren.
        Zitat von nikosch
        Macht doch alle was Ihr wollt mit Eurem Billigscheiß. Von mir aus sollen alle Eure Server abrauchen.

        Kommentar

        Lädt...
        X