Ankündigung

Einklappen
Keine Ankündigung bisher.

[Erledigt] Php-Curl auf einer Seite einloggen.

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Erledigt] Php-Curl auf einer Seite einloggen.

    Hi,

    ich will mich mit Php und diesem Skript:

    PHP-Code:
    <?php

    //Die Session initialisieren
    $ch curl_init();

    //Variablen setzen
    $url ="http://www.beispiel.com/process.php";
    $arrSubmit="log=1&res=&hand=Name&pass=Passwort&submit=Login";
    $cookies="Cookiepfad";


    //Session Optionen setzen

    curl_setopt($chCURLOPT_URL,$url);
    curl_setopt ($chCURLOPT_POST1);
    curl_setopt($chCURLOPT_POSTFIELDS$arrSubmit);
    curl_setopt($chCURLOPT_HEADER0);
    curl_setopt($chCURLOPT_COOKIEJAR$cookies);
    curl_setopt($chCURLOPT_COOKIEFILE$cookies);
    curl_setopt($chCURLOPT_FOLLOWLOCATIONtrue);
    //curl_setopt($ch, CURLOPT_FILE, $fp);

    //Ausführen der Aktionen
    curl_exec($ch);



    //Session beenden
    curl_close($ch);
    ?>
    Kommt aus diesem Artikel: http://www.php.de/php-tipps-2008/511...il-parsen.html und ich habe naturlich meine Daten angegeben.

    auf einer Seite einloggen und die Daten dann weiter verarbeiten.

    Nur gibt es da ein Problem ich weiß nichts mit dieser Fehlermeldung anzufangen bzw. ich weiß nicht was ich noch machen könnte.

    Code:
    Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /home/www/ph10s841/html/konstantinpschera/schuelercc/index.php on line 20
    Bin für jede Hilfe Dankbar.
    Viele Grüße
    Konstantin


  • #2
    Die Meldung ist doch eindeutig.

    PHP läuft auf dem Server im safe_mode und der Curl Parameter CURL_FOLLOWLOCATION kann im safe_mode nicht benutzt werden. (ich liebe es den Übersetzer zu spielen)

    Logische Lösung: safe_mode abschalten?
    "Alles im Universum funktioniert, wenn du nur weißt wie du es anwenden musst".

    Kommentar


    • #3
      Das ist mir schon klar und ich hab den Safe-Mode in der php.ini abgeschalten.

      Kommentar


      • #4
        Zitat von Konsch Beitrag anzeigen
        Das ist mir schon klar und ich hab den Safe-Mode in der php.ini abgeschalten.
        Wenn dir das so klar ist warum sagst du du kannst mit der Fehlermeldung nichts anfangen bzw. weißt nicht was zu tun ist?

        Dann nehm mal dein open_basedir raus.

        (falls du das auch schon getan hast schau mal in phpinfo() rein ob es WIRKLICH ausgeschaltet ist).
        "Alles im Universum funktioniert, wenn du nur weißt wie du es anwenden musst".

        Kommentar


        • #5
          Zitat von Konsch Beitrag anzeigen
          Nur gibt es da ein Problem ich weiß nichts mit dieser Fehlermeldung anzufangen bzw. ich weiß nicht was ich noch machen könnte.
          Ich habe geschrieben was ich noch machen kann wie nehme ich open_basedir raus?

          Ich schau mal in phpinfo() ob es wirklich aus ist.

          Kommentar


          • #6
            Zitat von Konsch Beitrag anzeigen
            Ich habe geschrieben was ich noch machen kann wie nehme ich open_basedir raus?
            Du hast aber verschwiegen was du schon getan hast.

            open_basedir ist wie safe_mode eine PHP Einstellung.
            "Alles im Universum funktioniert, wenn du nur weißt wie du es anwenden musst".

            Kommentar


            • #7
              Hab gerade geschaut Safe-Mode ist aus.
              Openbasedir versuch ich jetzt aus zu bekommen.

              Kommentar


              • #8
                In der php.ini steht ein Eintrag:
                open_basedir = /home/www
                was muss ich da ändern?

                Kommentar


                • #9
                  Zitat von Konsch Beitrag anzeigen
                  In der php.ini steht ein Eintrag: was muss ich da ändern?
                  Setz ein ; davor um es auszukommentieren...
                  "Alles im Universum funktioniert, wenn du nur weißt wie du es anwenden musst".

                  Kommentar


                  • #10
                    So geht es.
                    Danke.

                    Kommentar

                    Lädt...
                    X