Ankündigung

Einklappen
Keine Ankündigung bisher.

[Erledigt] SOAP Problem ?

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Erledigt] SOAP Problem ?

    Ich habe eine Klasse von betfair die auf meinem Server super läuft nur lokal geht es nicht. Ich nutzte XAMPP und in der php.ini steht:

    extension=php_soap.dll
    Und mit phpinfo wird:
    Soap Client enabled
    Soap Server enabled
    angezeigt. Denoch bekomme ich die Fehlermeldung und ich weiß nicht woran es liegt, weil es auf dem Server funktioniert. Hier das Output:

    Login:

    Warning: domdocument::domdocument() [domdocument.domdocument]: Entity: line 1: parser error : Start tag expected, '<' not found in C:\xampp\htdocs\intern\odds2\classes\betfairutilit y.class.php on line 44

    Warning: domdocument::domdocument() [domdocument.domdocument]: 1.0 in C:\xampp\htdocs\intern\odds2\classes\betfairutilit y.class.php on line 44

    Warning: domdocument::domdocument() [domdocument.domdocument]: ^ in C:\xampp\htdocs\intern\odds2\classes\betfairutilit y.class.php on line 44

    Fatal error: Uncaught SoapFault exception: [Client] Call to undefined method domdocument::loadXML() in C:\xampp\htdocs\intern\odds2\classes\betfairutilit y.class.php:48
    Stack trace:
    #0 C:\xampp\htdocs\intern\odds2\classes\betfairutilit y.class.php(4: SoapClientExtended->__doRequest()
    #1 [internal function]: SoapClientExtended->__doRequest('<?xml version="...', 'https://api.bet...', 'login', 1, 0)
    #2 [internal function]: SoapClient->__call('login', Array)
    #3 C:\xampp\htdocs\intern\odds2\classes\betfairglobal api.class.php(116): SoapClientExtended->login(Array)
    #4 C:\xampp\htdocs\intern\odds2\simplebetfair.php(73) : BetfairGlobalApi->betfair_api_login('threesixes', 'warschau23', 82, false)
    #5 C:\xampp\htdocs\intern\odds2\test.php(13): SimpleBetfair->login('username', 'xxx')
    #6 {main}
    thrown in C:\xampp\htdocs\intern\odds2\classes\betfairutilit y.class.php on line 48


  • #2
    Irgendeine Klasse für dich debuggen können wir nicht, aber du kannst es. Lies doch mal die Fehlermeldung:
    parser error : Start tag expected, '<' not found in C:\xampp\htdocs\intern\odds2\classes\betfairutilit y.class.php on line 44
    Liegt doch nahe, sich mal anzuschauen, was in Zeile 44 dieser Datei so passiert, oder?
    "Mein Name ist Lohse, ich kaufe hier ein."

    Kommentar


    • #3
      Na das ist mir klar, aber auf dem Server läuft die Klasse und nur lokal geht es nicht. Ich vermute mal das irgendetwas an der Config nicht passt. Evt. läuft SOAP,XML oder sonst was nicht richtig.

      Meine Frage ist, woran könnte es an der Config von Xampp liegen. Die Klasse scheint okay zu sein.

      Kommentar


      • #4
        Arbeitest du für irgendeinen Geheimdienst und darfst daher noch nicht mal den Bereich um die Zeile 44 posten?
        PHP-Code:
        if ($var != 0) {
          
        $var 0;

        Kommentar


        • #5
          Sorry, das hatte ich vergessen!

          PHP-Code:
          43        function __doRequest($request$location$action$version) {
          44              $dom = new DOMDocument('1.0'); 

          Kommentar


          • #6
            Was übergibst du loadXML? Offenbar keinen XML-String!
            "Mein Name ist Lohse, ich kaufe hier ein."

            Kommentar


            • #7
              Ich habe nichts an der Datei geändert und auf dem Server funktioniert die Datei einwandfrei. D.h der String wird richtig übergeben und lokal erhalte ich diese Fehlermeldung. Liegt das evt. an einer XML-Einstellung oder so ?

              Kommentar


              • #8
                Ich hab dich jetzt oft genug darauf hingewiesen, dass du dir einmal anschauen sollst, was da eigentlich passiert. Irgendetwas verursacht es ja, mit deiner Einstellung kommen wir aber nicht weiter. Daher viel Erfolg, ich klinke mich aus.
                "Mein Name ist Lohse, ich kaufe hier ein."

                Kommentar


                • #9
                  Sorry ich kenn mich mit SOAP nicht so gut aus, deshalb Frage ich ja hier. Was soll ich den noch posten ?

                  Kommentar


                  • #10
                    Warning: domdocument::domdocument() [domdocument.domdocument]: Entity: line 1: parser error : Start tag expected, '<' not found in C:\xampp\htdocs\intern\odds2\classes\betfairutilit y.class.php on line 44

                    Warning: domdocument::domdocument() [domdocument.domdocument]: 1.0 in C:\xampp\htdocs\intern\odds2\classes\betfairutilit y.class.php on line 44

                    Warning: domdocument::domdocument() [domdocument.domdocument]: ^ in C:\xampp\htdocs\intern\odds2\classes\betfairutilit y.class.php on line 44

                    Fatal error: Uncaught SoapFault exception: [Client] Call to undefined method domdocument::loadXML() in C:\xampp\htdocs\intern\odds2\classes\betfairutilit y.class.php:48
                    Stack trace:
                    #0 C:\xampp\htdocs\intern\odds2\classes\betfairutilit y.class.php(4: SoapClientExtended->__doRequest()
                    #1 [internal function]: SoapClientExtended->__doRequest('<?xml version="...', 'https://api.bet...', 'login', 1, 0)
                    #2 [internal function]: SoapClient->__call('login', Array)
                    #3 C:\xampp\htdocs\intern\odds2\classes\betfairglobal api.class.php(116): SoapClientExtended->login(Array)
                    #4 C:\xampp\htdocs\intern\odds2\simplebetfair.php(73) : BetfairGlobalApi->betfair_api_login('threesixes', 'warschau23', 82, false)
                    #5 C:\xampp\htdocs\intern\odds2\test.php(13): SimpleBetfair->login('username', 'xxx')
                    #6 {main}
                    thrown in C:\xampp\htdocs\intern\odds2\classes\betfairutilit y.class.php on line 48
                    IMHO liegt dort der Fehler. Die DOMDocument Instanz kennt keine loadXML() Funktion. Möglicherweise ist die Extension nicht korrekt installiert, oder eine falsche Version (oder eine falsche Extension)?
                    Über 90% aller Gewaltverbrechen passieren innerhalb von 24 Stunden nach dem Konsum von Brot.

                    Kommentar


                    • #11
                      Achso, falsche DOM-Extension installiert? Gibt ne alte und ne neue.
                      "Mein Name ist Lohse, ich kaufe hier ein."

                      Kommentar


                      • #12
                        Sorry hatte den letzten Post garnicht gesehen.

                        Auszug aus phpinfo:
                        Extension Version 1.0.0
                        Das hört sich ziemlich alt an. Wie kann ich das neu bzw nachinstallieren ohne Xampp komplett neu drauf zumachen ?

                        Kommentar


                        • #13
                          http://www.php.net/manual/en/dom.setup.php

                          Kommentar


                          • #14
                            Danke für den Link, aber irgendwie bringt mich das nicht weiter. Muss ich irgendetwas downloaden und dann installieren ? Hab irgendwie nichts gefunden.

                            Kommentar


                            • #15
                              guck mal was phpinfo() zu libXML zu sagen hat !? - die müssen beide installiert sein
                              "Irren ist männlich", sprach der Igel und stieg von der Drahtbürste

                              Kommentar

                              Lädt...
                              X