Ankündigung

Einklappen
Keine Ankündigung bisher.

Fatal error: Maximum execution ... in Swiftmailer 4.0.3 ... Hilfe!?

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Fatal error: Maximum execution ... in Swiftmailer 4.0.3 ... Hilfe!?

    Hallo alle miteinander,
    ich habe ein Problem wie Ihr euch wahrscheinlich schon denken könnt.
    Also, ich habe für einen Freund eine Website gestaltet auf der man bei Ihm etwas bestellen kann. Wenn der Kunde etwas bestellt bekommt er per email eine Bestätigung und der Freund die Bestellung. So gestern ruft er mich an das das nicht geht und man einen Error erhält. Der Fehler ist auf dem localhost folgender :

    Fatal error: Maximum execution time of 60 seconds exceeded in C:\xampp\htdocs\Bestellung\classes\Swift\Transport \StreamBuffer.php on line 167

    Ich hab den Fehler in der Bestelldatei auf folgende Zeile eingegrenzt

    PHP-Code:
    $swift->send($mail$recipient); 
    dabei wird die oben genannte Datei aufgerufen. Ich hab mit SwiftMailer die Emails versand. Das hat einmal anstandslos funktioniert bis mir wie gesagt angerufen wurde das es nicht geht. Ich fühle mich nach langem suchen nun ein wenig überfordert und würde mich über ein wenig Hilfe freuen.
    Wenn ich etwas vergessen habe sagt es einfach.
    vielen dank im vorraus

    ps.: Es läuft auf xampp 1.7.2 mit php 5 und das ganze Problem tritt auf dem localhost so wie auf dem Server auf.


  • #2
    Vlt. ist kein Mailserver lokal installiert?

    Kommentar


    • #3
      aber auf dem localhost hat es doch immer anstandslos funktioniert. Und die Emails werden ja via smtp über web oder googlemail versand, nicht vom einer servereigenen emailadresse.

      Kommentar


      • #4
        Hat sich der SMTP Server geändert, bzw. is dieser erreichbar? Könnte sein, dass swift einen längeren timeout für die Verbindung als 60 Sekunden hat. Sprich: swift versucht z.B. 90 Sekunden lang den Server zu erreichen, aber PHP macht nach 60 Sekunden dicht. Daher keine Fehlermeldung zum nicht erreichbaren Server, sondern eben die, die du bekommst.

        Ist aber nur eine Vermutung. Da ich swift nicht benutze, hab ich keine Ahnung wie das intern arbeitet.

        Kommentar


        • #5
          Zitat von Faror Beitrag anzeigen
          aber auf dem localhost hat es doch immer anstandslos funktioniert. Und die Emails werden ja via smtp über web oder googlemail versand, nicht vom einer servereigenen emailadresse.
          Na wunderbar das du uns diese Information erst jetzt gibst ... wie sollen wir dir helfen wenn du die das meiste verschweigst?

          Wahrscheinlich ist dann eben wie bereits gesagt der SMTP nicht erreichbar ...

          Kommentar


          • #6
            ich habe nun einmal den server geändert von dem server der verschicht. von googlemail auf web.de und nun geht es. Die Frage die sich mir nun nur noch stellt ist warum es unter googlemail nicht funktioniert hat aber das werde ich auch noch heraus bekommen vielen Dank euch

            Kommentar


            • #7
              Wie kommen die Kunden deines Freundes auf den lokalen PC, auf dem XAMPP läuft? Steht der in einem Ladenlokal?
              PHP-Code:
              if ($var != 0) {
                
              $var 0;

              Kommentar


              • #8
                nein natürlich nicht ^^ die software ist schon online auf einem server, aber um an der software zu arbeiten sitze ich natürlich am localhost. Und wenn es nicht mal da funktioniert brauch ich es online gar nicht erst aus zu probieren war vielleicht ein wenig unglücklich formuliert. mitlerweile bekomme ich auch den Kontakt zu googlemail hergestellt. jetzt spuckt er mir nur noch einen

                Fatal error: Uncaught exception 'Swift_TransportException' with message 'Expected response code 250 but got code "530", with message "530 5.7.0 Must issue a STARTTLS command first. x19sm911330bkv.21 "' in C:\xampp\htdocs\hartmann\Bestellung\classes\Swift\ Transport\AbstractSmtpTransport.php:406 Stack trace: #0 C:\xampp\htdocs\hartmann\Bestellung\classes\Swift\ Transport\AbstractSmtpTransport.php(290): Swift_Transport_AbstractSmtpTransport->_assertResponseCode('530 5.7.0 Must ...', Array) #1 C:\xampp\htdocs\hartmann\Bestellung\classes\Swift\ Transport\EsmtpTransport.php(197): Swift_Transport_AbstractSmtpTransport->executeCommand('MAIL FROM: <bre...', Array, Array) #2 C:\xampp\htdocs\hartmann\Bestellung\classes\Swift\ Transport\EsmtpTransport.php(26: Swift_Transport_EsmtpTransport->executeCommand('MAIL FROM: <bre...', Array) #3 C:\xampp\htdocs\hartmann\Bestellung\classes\Swift\ Transport\AbstractSmtpTransport.php(441): Swift_Transport_EsmtpTransport->_doMailFromCommand('brennholz.hartm...') #4 C:\xampp\htdocs\hartmann\Bestell in C:\xampp\htdocs\hartmann\Bestellung\classes\Swift\ Transport\AbstractSmtpTransport.php on line 406

                aus. Den hatte ich vorher schonmal ist dann aber verschwunden nachdem ich alle email adressen auf eine bestimmte gestellt hatte. Das habe ich jetzt auch getan aber irgendwie will das noch nicht so wie ich.

                Kommentar


                • #9
                  Dann google die Meldung bitte.
                  --

                  „Emoticons machen einen Beitrag etwas freundlicher. Deine wirken zwar fachlich richtig sein, aber meist ziemlich uninteressant.
                  Wenn man nur Text sieht, haben viele junge Entwickler keine interesse, diese stumpfen Texte zu lesen.“


                  --

                  Kommentar


                  • #10
                    Jetzt brech ich bald zusammen.
                    Ich habe es bei googlemail gelassen die machen da irgen einen murks (oder ich blick es nicht) mittlerweile lasse ich über eine emailadresse bei unserem Server (strato) die emails verschicken und wenn jemand eine Antwort schickt wird die per weiterleitung auf das google-Postfach geschickt. Schön und gut das funktioniert auch alles wenn ich das script auf dem localhost teste, bekommen alle die emails die sie bekommen sollen. Wenn ich das script aber genau in dem selben Zustand hochlade und auf dem Server ausführe hagelt es immer 2 Fehler:

                    Warning: fsockopen() [function.fsockopen]: unable to connect to post.strato.de:25 (Connection timed out) in /mnt/web7/40/66/51860966/htdocs/Bestellung/classes/Swift/Transport/StreamBuffer.php on line 233

                    und

                    Fatal error: Uncaught exception 'Swift_TransportException' with message 'Connection could not be established with host post.strato.de [Connection timed out #145]' in /mnt/web7/40/66/51860966/htdocs/Bestellung/classes/Swift/Transport/StreamBuffer.php:235 Stack trace: #0 /mnt/web7/40/66/51860966/htdocs/Bestellung/classes/Swift/Transport/StreamBuffer.php(70): Swift_Transport_StreamBuffer->_establishSocketConnection() #1 /mnt/web7/40/66/51860966/htdocs/Bestellung/classes/Swift/Transport/AbstractSmtpTransport.php(101): Swift_Transport_StreamBuffer->initialize(Array) #2 /mnt/web7/40/66/51860966/htdocs/Bestellung/classes/Swift/Mailer.php(74): Swift_Transport_AbstractSmtpTransport->start() #3 /mnt/web7/40/66/51860966/htdocs/Bestellung/index.php(654): Swift_Mailer->send(Object(Swift_Message), Array) #4 {main} thrown in /mnt/web7/40/66/51860966/htdocs/Bestellung/classes/Swift/Transport/StreamBuffer.php on line 235

                    ich verzweifel langsam echt ich such mich wund und komm einfach nicht drauf was falsch ist. Bitte helft mir.

                    Kommentar

                    Lädt...
                    X