Ankündigung

Einklappen
Keine Ankündigung bisher.

Bei new-aufruf bleibt Screen weiß

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Bei new-aufruf bleibt Screen weiß

    Moinz.
    Ich hab ne wunderschöne php-Datei, die recht simpel ist.

    PHP-Code:
    <?php
    include (Datei1.php);
    $myVar = new Start;
    $myVar->test();
    ?>
    und in meiner Datei1.php sieht es so aus:

    PHP-Code:
    <?php
    class Start {
      function 
    test(){
        echo(
    "Läuft");
      }
    }
    ?>
    Jetzt der Clou: Auf meinem localhost läuft alles rund. Lade ich beides auf einem Firmenserver hoch, dann kriege ich nur einen weißen Bildschirm.
    Wenn ich ein echo vor und nach dem "new.." setze, sehe ich nur das davor...nach dem "new" wird kein echo mehr ausgegeben.

    Hab ich was verpasst? Die Dateien haben die Standart-Rechte -rwxr-xr-x
    Ich bin verwirrt...


  • #2
    Hab ich was verpasst?
    Ja. Das Kapitel zum Thema error_reporting
    --

    „Emoticons machen einen Beitrag etwas freundlicher. Deine wirken zwar fachlich richtig sein, aber meist ziemlich uninteressant.
    Wenn man nur Text sieht, haben viele junge Entwickler keine interesse, diese stumpfen Texte zu lesen.“


    --

    Kommentar


    • #3
      Sieh dir mal dein include nochmal an...
      PHP: include - Manual
      Besonders Example #3
      Signatur:
      PHP-Code:
      $s '0048656c6c6f20576f726c64';
      while(
      $i=substr($s=substr($s,2),0,2))echo"&#x00$i;"

      Kommentar


      • #4
        Lustigerweise kommt beim error_reporting(-1); so rein gar nix...weder vor, noch nach dem new...
        Freaky.

        Kommentar


        • #5
          Unlustigerweise kann das gar nicht sein, da dein Script definitiv einen Fehler enthält.
          http://hallophp.de

          Kommentar


          • #6
            du hast ne constante namens Datei1.php ? cool.....


            edit: @asipak: kann passieren, ich hatte letztin auch auf nem server probleme weil einfach keine fehler angezeigt wurden trotz error reporting, da war irgend ein fieser .ini eintrag der alles blockiert hat

            Kommentar


            • #7
              Grins...schön umschrieben für "es fehlen Hochkommas"!

              Wolf29
              while (!asleep()) sheep++;

              Unterschätze nie jemanden der einen Schritt zurück geht! Er könnte Anlauf nehmen.

              Kommentar


              • #8
                display_errors!
                --

                „Emoticons machen einen Beitrag etwas freundlicher. Deine wirken zwar fachlich richtig sein, aber meist ziemlich uninteressant.
                Wenn man nur Text sieht, haben viele junge Entwickler keine interesse, diese stumpfen Texte zu lesen.“


                --

                Kommentar


                • #9
                  Zitat von Screeze Beitrag anzeigen
                  edit: @asipak: kann passieren, ich hatte letztin auch auf nem server probleme weil einfach keine fehler angezeigt wurden trotz error reporting, da war irgend ein fieser .ini eintrag der alles blockiert hat
                  Gut, im Kapitel zu error_reporting wird aber auch auf display_errors hingewiesen! Oder meinst du noch etwas anderes?

                  [edit] zu spät...
                  http://hallophp.de

                  Kommentar


                  • #10
                    ne da war noch was andres, ich weis ehrlich gesagt nicht was es war, nachdem ich alles was mir eingefallen war ausprobiert hatte hab ich einfach ne .ini genommen die vor neuinstallation drauf war, damit hats wieder funktioniert.

                    was aber nicht thema des threads ist

                    Kommentar


                    • #11
                      Ich werde es wohl nie erfahren...da das System frisch war, hab jetzt noch ma alles neu aufgesetzt und nu läuft´s. Frag mich mal einer....aber ich danke trotzdem.

                      Kommentar


                      • #12
                        Ich werde es wohl nie erfahren...
                        PHP-Code:
                        include 'Datei1.php'
                        http://hallophp.de

                        Kommentar


                        • #13
                          Das war´s nich, das hab ich gleich vorne weg probiert. ^^

                          Kommentar


                          • #14
                            Gut, das hast du uns aber nicht mitgeteilt.

                            Woher sollen wir wissen, dass du stattdessen bereits den Server neu aufsetzt!?
                            http://hallophp.de

                            Kommentar


                            • #15
                              Mja, da haste nich ganz unrecht mit. Für´s nächste Mal sag ich Bescheid.

                              Kommentar

                              Lädt...
                              X