Ankündigung

Einklappen
Keine Ankündigung bisher.

.htaccess und sendmail problem

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • .htaccess und sendmail problem

    Hallo an alle,

    ich hab ein Problem und hoffe ihr könnt mir helfen.
    Mein Hoster kann es nicht.

    Hab einen Vserver mit Debian 5 32bit minimal
    Installiert ist php5, SQL und phpmyadmin sowie sendmail.

    Mein Problem sind folgende:

    1.) wenn ich einen Verzeichnisschutz anlege, funktioniert dieser nicht.
    Hab es x mal nach x Anleitungen gemacht und bin mir sicher das Pfad etc alles stimmt.

    Ich kann mich, egal von welchem Rechner aus, immer im Admin bereich einloggen und hab einfach nur das gefühl, mein Server kann keine htaccess Dateien lesen.

    2.) sendmail
    Ich kann per script keine Emails versenden, es will einfach nicht. Und ich hab null plan wieso.
    Es ging alles, bis ich umgezogen bin, jetzt auf dem neuen geht nichts.

    Ich weiss, diese Themen sind hier schon x mal angesprochen worden hab cuh viel geselen haber nichts deckt sich mit meinem Problem so wirklich.

    Kann mir bitte jemand helfen?

    Danke schon jetzt im Voraus.


  • #2
    PHP-Code:
    error_reporting(E_ALL
    Ja / nein / keine ahnung was du von mir willst?

    Bekommst du eine Fehlermeldung?

    Kommentar


    • #3
      Die Fragen sind viel zu allgemein. Die erste Problemanalyse muss von Dir kommen - Fehlermeldungen u.ä.
      Die Aussage mit dem Login finde ich total unverständlich. Wieso sollte der Rechner entscheidend für das Login sein?
      --

      „Emoticons machen einen Beitrag etwas freundlicher. Deine wirken zwar fachlich richtig sein, aber meist ziemlich uninteressant.
      Wenn man nur Text sieht, haben viele junge Entwickler keine interesse, diese stumpfen Texte zu lesen.“


      --

      Kommentar


      • #4
        also zu sendmail:

        so wenn ich die Email per phpscript mit sendmail versenden lass bekomme ich keinen fehler angezeigt.
        Wo ich serverseitig nachsehen muss? SRY keine Ahnung

        Hab eben die Datei sendmail.cf.error gefunden, hilft die weiter?

        *** ERROR: FEATURE() should be before MAILER()
        *** MAILER(`local') must appear after FEATURE(`always_add_domain')*** ERROR: FEATURE() should be before MAILER()
        *** MAILER(`local') must appear after FEATURE(`allmasquerade')*** ERROR: FEATURE() should be before MAILER()
        .htaccess funktioniert definitiv nicht, ich hab volgendes auf dem Server im verzeichniss:

        www.deine-domain.de/admin/
        entspricht bei mir dem pfad: /var/www/admin/

        .htaccess

        PHP-Code:
        AuthUserFile /var/www/admin/.htpasswrd
        AuthName Lite ACP
        AuthType Basic
        require user Admin 
        .htpasswrd

        PHP-Code:
        Username:passwort 
        wobei Passwort crypt ist und ich nur nicht poste um es geheim zu halten.

        Kommentar


        • #5
          Zitat von Adryan Beitrag anzeigen
          .htaccess funktioniert definitiv nicht, ich hab volgendes auf dem Server im verzeichniss:

          [url entfernt]
          Bitte nutze example.com/.net/.org für Beispiele - die sind extra dafür gedacht!


          PHP-Code:
          AuthUserFile /var/www/admin/.htpasswrd
          AuthName Lite ACP
          AuthType Basic
          require user Admin 
          .htpasswrd

          PHP-Code:
          Username:passwort 
          Wenn das keinen Internal Server Error gibt, werden vermutlich .htaccess-Dateien gar nicht berücksichtigt - denn der angegebene AuthName müsste m.W. in Anführungszeichen stehen, da er ein Leerzeichen enthält.

          Und wenn der Nutzername in deiner .htpasswd tatsächlich Username heißt, dann passt das auch nicht zum geforderten User.

          (Mag sein, dass das alles in der Realität bei dir gar nicht der Fall ist - aber dann machst du hier mit deiner Geheimniskrämerei die Problemanalyse schwieriger als nötig.)

          Kommentar


          • #6
            Hallo, ne Username ist Admin, hab das nur angepasst.
            Ne ich bekomme keinen Error oder so.
            Das ist es ja und einen log kann ich nicht kontrolliere da ich wie gesagt nicht weiss wo?

            und du hast recht, hab die falsche datei hier reinkopiert:

            AuthName "LiteACP"
            AuthType Basic
            AuthUserFile /var/www/admin/.htpasswd

            require valid-user

            Kommentar


            • #7
              Zitat von Adryan Beitrag anzeigen
              Das ist es ja und einen log kann ich nicht kontrolliere da ich wie gesagt nicht weiss wo?
              Einen VServer haben, aber nicht mal wissen, wo sich die relevanten Logfiles befinden ...?
              Das Error-Log des Apachen wäre in so einem Falle erste Anlaufstelle. Wo das liegt - bestimmt die Konfiguration.

              Ich kann mich, egal von welchem Rechner aus, immer im Admin bereich einloggen
              Was genau bedeutet denn jetzt „einloggen“?
              Kommt das Abfragefenster für die Zugangsdaten, und du kommst immer rein, egal was für Daten du angibst?
              Oder kommt gar keine Abfrage, und du kannst die Ressource ganz normal aufrufen?

              Kommentar


              • #8
                Zitat von ChrisB Beitrag anzeigen
                Einen VServer haben, aber nicht mal wissen, wo sich die relevanten Logfiles befinden ...?
                Das Error-Log des Apachen wäre in so einem Falle erste Anlaufstelle. Wo das liegt - bestimmt die Konfiguration.


                Was genau bedeutet denn jetzt „einloggen“?
                Kommt das Abfragefenster für die Zugangsdaten, und du kommst immer rein, egal was für Daten du angibst?
                Oder kommt gar keine Abfrage, und du kannst die Ressource ganz normal aufrufen?
                Zu frage 1:
                Ja ich habe eine Vserver - gzungernermassen da mein Admin seit wochenn icht mehr erreichbar ist und sein Server dowon ist.
                Ich bin nur der INhaber der seite und Ideengeber/Investor programmiert und gepflegt wurde nicht von mir.

                Configs ist gut, die sind alle Standart also Debian, ich hab nur nach Anleitung php5, SQL und phpmyAdmin installiert.

                Zu Frage 2:

                Ok einloggen ist ungünstig gewählt, ich habe zugrff auf die Admin seiten trotz htaccess schutz

                Kommentar


                • #9
                  Ja ich habe eine Vserver - gzungernermassen da mein Admin seit wochenn icht mehr erreichbar ist und sein Server dowon ist.
                  Ich bin nur der INhaber der seite und Ideengeber/Investor programmiert und gepflegt wurde nicht von mir.
                  #FAIL
                  Dann such Dir bitte einen Entwickler/Admin, anstatt mit uns über Urschleim zu diskutieren, den Du nicht mal richtig beschreiben kannst. Das bringt doch niemanden weiter.

                  Beweis:
                  Ok einloggen ist ungünstig gewählt, ich habe zugrff auf die Admin seiten trotz htaccess schutz
                  Du kannst Dich einfach nicht ausdrücken. Klar hast Du Zugang, das ist der Sinn einer Zugangsbeschränkung. Die Frage ist, ob dieser Zugang beschränkt ist und wenn nicht, wie sich das äußert.
                  --

                  „Emoticons machen einen Beitrag etwas freundlicher. Deine wirken zwar fachlich richtig sein, aber meist ziemlich uninteressant.
                  Wenn man nur Text sieht, haben viele junge Entwickler keine interesse, diese stumpfen Texte zu lesen.“


                  --

                  Kommentar


                  • #10
                    danke, super Forum....ihr habt mir wirklich geholfen.

                    Statt mir vielleicht einmal einen pfad zu geben oder so, kommen hier nur neumalkluge sprüche.
                    das ich kein Linux/PHP Admin bin ist mir selbst klar.

                    Das muss mir aber keine aufs Brot schmieren, vorallem nicht, wenn man höfflich fragt.
                    Aber nun gut, das war mehr als eindeutig das ich hier im flaschen Forum bin.


                    CLOSED

                    Kommentar

                    Lädt...
                    X