Ankündigung

Einklappen
Keine Ankündigung bisher.

PHP LDAP in Active Directory Forest(mehrere DC´s)

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • PHP LDAP in Active Directory Forest(mehrere DC´s)

    Hallo,
    nachdem ich es geschafft habe das script soweit zu modfizieren, das ich ein Ergebnis bekomme, stehe ich vor dem Problem das ich kein Ergbebnis bekomme wenn ich ich als DN dc=domain,dc=forest,dc=toplevel verwende.

    Mit DN dc=forest,dc=toplevel funktioniert es einwandfrei.
    Mit DN cn=Users,dc=forest,dc=toplevel funktioniert es einwandfrei.

    (Die fehlenden Definitionen der Variablen hab ich im Post weggelassen...)
    PHP-Code:
    // Mit Server verbinden:
    if (!($ds=ldap_connect($ldap_server))) {
    die(
    "Keine Verbindung zum Verzeichnis-Server möglich.");
    }
    // Diese Parameter sind nötig für den Zugriff auf ein Active Directory:
    ldap_set_option($dsLDAP_OPT_PROTOCOL_VERSION3);
    ldap_set_option($dsLDAP_OPT_REFERRALS0);

    // An Server binden:
    if (!($bind=@ldap_bind($ds$auth_user$auth_pass))) {
       die(
    "Bind fehlgeschlagen.");
    }
    // $ds gültige Verbindungs-Kennung für einen Verzeichnis-Server

    //$ds = ldap_connect( $ldap_server );
    $dn "DC=domain,DC=forest,DC=toplevel";

    // LDAP filter setzen: Nur Kontakt- und Benutzer-Objekte sollen zurückgegeben werden
    $filter "(|(cn=*))";

    // Suche starten:
    if (!($search=@ldap_search($ds,$dn,$filter))) {
         die(
    "Durchsuchen des LDAP-Servers fehlgeschlagen.");
    }
    $anzahl ldap_count_entries($ds,$search);
    echo 
    $anzahl
    Mache ich hier einen Fehler oder kann es evtl. an der Konfiguration des Domain Controllers liegen?


  • #2
    Zitat von PerHaPs Beitrag anzeigen
    Hallo,
    nachdem ich es geschafft habe das script soweit zu modfizieren, das ich ein Ergebnis bekomme, stehe ich vor dem Problem das ich kein Ergbebnis bekomme wenn ich ich als DN dc=domain,dc=forest,dc=toplevel verwende.

    Mit DN dc=forest,dc=toplevel funktioniert es einwandfrei.
    Mit DN cn=Users,dc=forest,dc=toplevel funktioniert es einwandfrei.

    Wenn ich das ganze mit dem "LDAP Browser" versuche klappt es auch wunderbar, somit vermute ich das es auch nicht an den Berechtigungen des angemeldeten Users liegen kann.

    (Die fehlenden Definitionen der Variablen hab ich im Post weggelassen...)
    PHP-Code:
    // Mit Server verbinden:
    if (!($ds=ldap_connect($ldap_server))) {
    die(
    "Keine Verbindung zum Verzeichnis-Server möglich.");
    }
    // Diese Parameter sind nötig für den Zugriff auf ein Active Directory:
    ldap_set_option($dsLDAP_OPT_PROTOCOL_VERSION3);
    ldap_set_option($dsLDAP_OPT_REFERRALS0);

    // An Server binden:
    if (!($bind=@ldap_bind($ds$auth_user$auth_pass))) {
       die(
    "Bind fehlgeschlagen.");
    }
    // $ds gültige Verbindungs-Kennung für einen Verzeichnis-Server

    //$ds = ldap_connect( $ldap_server );
    $dn "DC=domain,DC=forest,DC=toplevel";

    // LDAP filter setzen: Nur Kontakt- und Benutzer-Objekte sollen zurückgegeben werden
    $filter "(|(cn=*))";

    // Suche starten:
    if (!($search=@ldap_search($ds,$dn,$filter))) {
         die(
    "Durchsuchen des LDAP-Servers fehlgeschlagen.");
    }
    $anzahl ldap_count_entries($ds,$search);
    echo 
    $anzahl
    Mache ich hier einen Fehler oder kann es evtl. an der Konfiguration des Domain Controllers liegen?

    Kommentar


    • #3
      Die Lösung war relativ einfach:

      ($ds1=@ldap_connect($ldap_server1,"3268")

      Somit verbindet sich der Server zum globalen Katalog und muss keinen referals mehr folgen.

      Kommentar

      Lädt...
      X