Ankündigung

Einklappen
Keine Ankündigung bisher.

php Ldap Abfrage Problem mit Attributen

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • php Ldap Abfrage Problem mit Attributen

    Hallo zusammen,

    Ich bin neu hier und hoffe, dass ich das richtige Forum erwischt habe. Falls dieser Thread falsch gelandet ist, bitte ich euch mir dieses zu verzeihen.
    Nun aber zu meinen Problem. Ich habe eine Ldap Abfrage geschrieben bzw. mehrere. ALle laufen einwandfrei. Der Benutzer kann beispielsweise, Name, Durchwahl, kostenstelle etc eingeben und die dazugehörigen Benutzer werden ausgegeben. Nun habe ich ein weiteres Kriterium vorgelegt bekommen. Es wird hier in sehr komplexer Ausführung ein OCS Server System eingesetzt (weltweit). Sobald einer der User "Voice enabled" wird, bekommt er im ActiveDirectory einen EIntrag "msRTCSIP-Line". Dort ist dann die OCS-Rufnummer eingetragen wie z.B. "tel.: xxxxxxx8329". Ich schaffe es einfach nicht, diesen Wert abzurufen. Habe testweise einfach nach einem Namen gesucht, der garantiert "Voice-enabled" ist und dann den Namen + diese Rufnummer ausgeben soll. Leider funktioniert es nicht. Gibt es seitens php probleme mit Attributen in Verbindung mit einem Bindestrich oder ähnliches ? Wäre super, wenn ihr mir weiterhelfen könntet. Falls euch die Beschreibung des Problems nicht ausreicht, kann ich euch gerne mein Skript posten.

    Danke schonmal in voraus!


  • #2
    kannst du denn einen kompletten Array eines Satzes ausgeben lassen? evtl steht das ding da ja drin, nur unter anderem namen

    Kommentar


    • #3
      Hallo

      Danke für Deine Antwort. Wenn ich die Suche auf einige Attribute beschränke wie z.b. cn, sn, displayname etc. Dann gibts keine Probleme das Array auszugeben. Wenn ich nun auch noch mein Problemattribut mit in die Einschränlung einbeziehe, dann ist dieses auch leer. Also kein Rückgabewert. Somit wieder falsch. ICh habe auch zum Gegentest mit c# diese abfrage gemacht, mit csvde und dem ldapbrowser. Bei allen ist dieses Attribut msRTCSIP-Line korrekt angelegt udn kann ausgelesen werden. Der Inhalt des Strings ist auch ein String, also sollte es auch keine Formatprobleme geben. Selbst mit utf8 umwandlung funktioniert es nicht. Leider :/

      Gruß Manuel

      Kommentar


      • #4
        tja, kA.. schlimmstenfalls würd ich mich mal mit dem ldap-zulieferer in verbindung setzen.. aber die idee hattest du sicher schon selbst

        Kommentar

        Lädt...
        X