Ankündigung

Einklappen
Keine Ankündigung bisher.

[Erledigt] CakePHP .hataccess oder Config?

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Erledigt] CakePHP .hataccess oder Config?

    Hallo Leute,

    ich wollte mich ein wenig in Cake einarbeiten um das MVC Pattern zu verstehen. Nach dem Download stoße ich bereits auf die ersten Probleme.

    es geht um folgendes. Wenn ich erstmal die Datenbank einstellungen vorgenommen habe, wird zwar bei mir die standard Seite von Cake angezeigt , jedoch ist die URL zu dem css layout sowie zu dem icon falsch gesetzt.

    wenn ich in der app/configs/core.php diese Zeile reinschreibe

    PHP-Code:
    Configure::write('App.baseUrl'env('SCRIPT_NAME')); 
    dann wird das Layout richtig geladen, jedoch ist die URL "unschön" beim aufrufen von controllern. Die URL sieht dann so aus:

    http://example.com/index.php/Control...hode/Parameter

    wenn ich die Configure zeile weglasse, so ist die URL dann so , wie ich die gerne haben möchte

    http://example.com/Controllername/Methode/parameter

    jedoch ist dann die URL zu der css Datei falsch.

    das Framework habe ich nicht direkt in den htdocs ordner kopiert, sondern in xampp\htdocs\share\cakePHP

    laut der doku, musste ich einige sachen in der http.conf umstellen
    Apache und mod_rewrite :: Installation :: Entwickeln mit CakePHP :: Das Handbuch :: 1.2 Collection :: Das Cookbook

    habe ich alles gemacht und trotzdem funktioniert es nicht.

    muss vllt noch was verändern? woran könnte es liegen dass die css und icon und js pfade nicht richtig sind?

    Ich denke ich müsste etwas in der .htaccess noch zusätzlich ändern, weis aber nicht was und trau mich da noch nicht ran.

    MFG BlackScorp
    apt-get install npm -> npm install -g bower -> bower install <package> YOLO https://www.paypal.me/BlackScorp | Mein Youtube PHP Kanal: https://www.youtube.com/witalimik


  • #2
    Versuch mal
    PHP-Code:
    Configure::write('App.baseUrl'dirname(env('SCRIPT_NAME'))); 
    evtl geht es so.

    Kommentar


    • #3
      ach ich habe mein Problem gefunden. ich habe bei mir local Virtual Hosts eingerichtet, wie es aussieht ist http.conf mit ModRewrite all nicht mehr gültig sondern die einstellungen aus httpd-vhosts.conf. dort habe ich das umgestellt und scheint zu funktionieren

      MFG
      apt-get install npm -> npm install -g bower -> bower install <package> YOLO https://www.paypal.me/BlackScorp | Mein Youtube PHP Kanal: https://www.youtube.com/witalimik

      Kommentar

      Lädt...
      X