Ankündigung

Einklappen
Keine Ankündigung bisher.

Variablendeklaration

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Variablendeklaration

    hallo liebes forum.

    ich hab heute ein programm geschrieben, es aufgerufen, es funktionierte.
    dann guck ich in den quelltext und da hat sich ein fehler eingeschlichen.

    anstatt:

    $c = 0;

    hab ich aus versehen

    $c´ = 0;

    geschrieben, doch das programm wurde ohne fehler ausgeführt.
    dann hab ich es noch mit strings ausprobiert z.b.

    $hi´ = "hallo";

    und das klappte auch, trotz dieses " hochkomma "....
    ist das ein bug, ist das geplant? weil sowas taucht eig. nirgendswo auf.

    lg Johnny


  • #2
    keine ahnung wird vermutlich ignoriert nimms einfach alls gegeben hin ^^

    Kommentar


    • #3
      Wahrscheinlich liegt es an der eingestellten Fehlertoleranz.

      Kommentar


      • #4
        Das Hochkomma wird hier zum Teil des Identifiers.


        Code:
        $d´=0;
        echo $d´; // Richtiger Identifier
        echo $d;  // Falscher Identifier
        MfG

        Hroudtwolf
        Computer-Training kostenlos, gemeinnützig bis günstig.

        Kommentar


        • #5
          Zitat von PTC Beitrag anzeigen
          Wahrscheinlich liegt es an der eingestellten Fehlertoleranz.
          Nein das ist (wie auch Hroudtwolf schon festgestellt hat) kein Fehler, sondern das ´ ist ein für Variablennamen erlaubtes Zeichen
          Gruss
          L

          Kommentar

          Lädt...
          X