Ankündigung

Einklappen
Keine Ankündigung bisher.

phpBB2-Forum läßt sich nicht installieren

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • phpBB2-Forum läßt sich nicht installieren

    Hallo,

    ich hab mir unter Suse 9.2 ein phpBB2-Forum (phpBB-2.0.23.tar.gz)
    auf /usr/share/phpBB2 installiert.
    Weiterhin habe ich folgendes installiert:
    apache2-2.0.50-7.3 apache2-doc-2.0.50-7.3
    apache2-example-pages-2.0.50-7.3 apache2-mod_fastcgi-2.4.2-2.1
    apache2-mod_perl-1.99_12_20040302-38.1 apache2-mod_python-3.1.3-37.1
    apache2-prefork-2.0.50-7.3 mod_php-4.0.3pl1-1
    php-4.0.3pl1-1 postgresql-7.4.5-6
    postgresql-docs-7.4.5-6 postgresql-libs-7.4.5-6
    postgresql-server-7.4.5-6

    In der INSTALL.htm steht folgendes:
    2. Requirements
    Installation of phpBB2 requires the following:
    * A webserver or web hosting account running on any major Operating System
    * A SQL database system, one of:
    o MySQL (3.22 or higher)
    o PostgreSQL 7.0.3 or higher (preferably 7.1.x or 7.2.x)
    o MS SQL Server (7 or 2000) directly or via ODBC
    o MS Access (2000 or XP) via ODBC
    * PHP (4.0.3 and above) with support for the database you intend to use above

    Es ist also alles erforderliche vorhanden.
    Auszug aus der /etc/apache2/httpd.conf:
    Alias /wiki/ "/usr/share/moin/htdocs/"
    ScriptAlias /meinWiki "/usr/share/moin/server/moin.cgi"
    Alias /phpbb /usr/share/phpBB2
    ScriptAlias /meinForum "/usr/share/phpBB2/index.php"

    Wenn ich jetzt firefox localhost/phpbb/install/install.php aufrufe
    kommt nur ein Dialog zum Abspeichern der Datei. Der Apache weiß also
    offenbar mit php-Dateien nichts anzufangen.

    Ich hätte nun gerne gewußt welche Einträge in den diversen Apache-
    Konfigurationsdateien noch einzufügen sind damit es funktioniert.
    Das installierte MoinMoin-Wiki funktioniert einwandfrei.
    Was ist eigentlich der Unterschied zwischen php und php4 ?
    Auf der Suse-DVD ist nämlich apache2-mod_php4 drauf aber kein php.

    Im Voraus Vielen Dank für Eure Antworten !

    Grüße

    Jörg


  • #2
    Erstmal eine Gegenfrage: Bist Du auf SuSE 9.2 angewiesen? Das wird noch mit php4 ausgeliefert, nicht mit php5.

    Kommentar


    • #3
      Hallo,

      vielen Dank für die Rückmeldung.
      Ja ich bin auf Suse 9.2 angewiesen,das läuft wunderbar,never touch
      a running system.
      Ich hab die Suse 10.3 hier liegen und bin davon sehr enttäuscht.
      Die Systemreparatur läuft direkt vom Bootbildschirm auf Abbruch wegen Fehlers.
      --> tolle Aussagekraft
      Er kann selbstbespielte DVD's m DVD-ROM nur nach minutenlanger Wartezeit
      mounten. Im DVD-Brenner geht es wesentlich schneller.
      Ich kann keine ZIP-Disketten mounten.
      Weiterhin gibt es Probleme mit dem pata-Treiber bei IDE-PLatten.
      Bei solchen gravierenden Problemen bleibt mein stabil laufendes 9.2
      auf der Platte.
      Ich hab mit Mühe php und mod_php ohne Abhängigkeitskonflikte
      installieren können.
      Was ist eigentlich der Unterschied zwischen php,php4 und php5 ?

      Grüße

      Jörg

      Kommentar


      • #4
        php5 hat gegenüber php4 einen neuen Unterbau bekommen (Zend Engine 2) und in diesem Zuge wurden auch neue Spracheigenschaften eingeführt. php4 wird nicht mehr weiterentwickelt, PHP 4 end of life announcement

        Kommentar

        Lädt...
        X