Ankündigung

Einklappen
Keine Ankündigung bisher.

Formularproblem bei Umlauten

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Formularproblem bei Umlauten

    Hallo ich versuche ein Formular per email zu sendne.
    Dies geht auch einwandfrei jedoch werden umlaute nur als ?? angezeigt in der Email.

    Email senden mache ich so:
    Code:
    mail("Email@meinheimemail.de","Test Forumlar",$text);

    Wenn ihc mir die Variable $text anzeigen lasse, sehe ich jedoch ä ö ü etc


  • #2
    Hört sich an, wie ein UTF-8-Text, der als ISO-Text ausgegeben wird.
    Du musst mit dem Header Content-Type sicherstellen, dass die Mail mit UTF-8 angezeigt wird oder sie gleich als ISO-8859-15 senden.
    Refining Linux: “Performing Push Backups – Part 1: rdiff-backup

    Kommentar


    • #3
      habe ich beides schon versucht bei Iso bekomme ich ? bei UTF8 ??

      Kommentar


      • #4
        Eventuell musst du im Formular noch die Zeichenkodierung angeben, siehe Zeichenkodierung der Formulardaten.
        Außerdem kommen nicht alle String-Funktionen mit UTF-8 klar.

        Kommentar


        • #5
          Wenn Du SwiftMailer verwendest, erhälst Du iso-8859-1 und utf-8 Unterstützung "gratis".
          Andere Zeichensätze musst Du allerdings auch dort markieren.
          siehe Basics of Swift_Message [SwiftMailer Docs]

          Kommentar


          • #6
            Wenn du mit echo $text vor der mail()-Anweisung die Umlaute richtig bekommst, dann schau dir mal an, mit welchem Zeichensatz dein Script kodiert ist. Diesen Zeichensatz musst du entweder als header der mail()-Anweisung mitgeben, oder der Mailklasse die du nutzt (Swiftmailer, Phpmailer)
            PHP-Code:
            if ($var != 0) {
              
            $var 0;

            Kommentar

            Lädt...
            X