Ankündigung

Einklappen
Keine Ankündigung bisher.

[Erledigt] Wechsel der Headerbildes

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Erledigt] Wechsel der Headerbildes

    Hallo,

    ich habe hier ein kleines Problem, bei dem ich mir nicht ganz sicher bin, ob es an meinem PC liegt oder am Script.

    Für den Wechsel des Headerbilds bei refresh benutze ich folgenden Code:

    PHP-Code:
    <?
    srand ((double)microtime()*1000000);
    $zufallszahl = rand(1, 10);
    echo "<img src=\"bllogo$zufallszahl.jpg\" alt=\"Logo\" />";
    ?>
    bllogo1 - 10 sind definitiv vorhanden. Dennoch erscheint hin und wieder der Alternativtext "Logo". Klicke ich dann auf Grafik anzeigen, erscheint das richtige Bild.
    Wie gesagt, ich bin nicht sicher, ob das bei jedem Besucher der Fall ist oder nur bei mir. Vielleicht findet sich ein Fehler im Code?

    Vielen Dank im Voraus!

    MfG
    Dude


  • #2
    Klicke ich dann auf Grafik anzeigen, erscheint das richtige Bild.
    Dann scheint dein HTML Code ja wie gewünscht auszusehen, könnte also entweder tiefer im Server liegen, also Dateisystem, Auslastung etc. oder wie du schon sagtest bei Client. Vielleicht solltest du auch mal einen anderen Browser bei dir ausprobieren und auch mal bei Nachbarn testen.

    [edit]
    Achja: Tritt der Fehler denn bei verschiedenen Bildern auf oder kommt wenn du auf "Grafik anzeigen" klickst immer die selbe?

    Kommentar


    • #3
      Also zunächst sieht es so aus, als würde das Problem nur bei Firefox auftreten. Im IE lief bisher alles reibungslos.

      Der Fehler tritt bei verschiedenen Grafiken auf, aber auch völlig willkürlich. D.h. es kann sein, dass dieselbe Grafik, die gerade noch angezeigt wurde und z.B. nach 3x refresh wieder angezeigt werden soll, dann nicht geladen wird.

      Kommentar


      • #4
        Klingt nach Cache. Als ob zu irgendeinem Zeitpubnkt früher, die Grafik noch nicht im Dateisystem verfügbar war.
        --

        „Emoticons machen einen Beitrag etwas freundlicher. Deine wirken zwar fachlich richtig sein, aber meist ziemlich uninteressant.
        Wenn man nur Text sieht, haben viele junge Entwickler keine interesse, diese stumpfen Texte zu lesen.“


        --

        Kommentar


        • #5
          Nach Cache leeren funktioniert es jetzt anscheinend. Vielen Dank.
          Und entschuldigt, dass ich eine solche Lappalie hier im PHP-Forum breitgetreten habe

          Kommentar


          • #6
            Ist wohl jedem schon passiert.
            --

            „Emoticons machen einen Beitrag etwas freundlicher. Deine wirken zwar fachlich richtig sein, aber meist ziemlich uninteressant.
            Wenn man nur Text sieht, haben viele junge Entwickler keine interesse, diese stumpfen Texte zu lesen.“


            --

            Kommentar


            • #7
              Ich hab meinem FF ganze 0 mb cache gegeben xD ich meine im Zeitalter von DSL brauch doch Clientseitig nichts mehr gecached werden....

              Kommentar

              Lädt...
              X