Ankündigung

Einklappen
Keine Ankündigung bisher.

Problem mit Post ?

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Problem mit Post ?

    Nabend,

    habe folgendes Problem und zwar hab ich nen Script, welches Daten aus nem Formular in eine Db eintragen soll.

    Code:
    <!-insert.php->
    <html>
    <body>
    
    <?PHP
    if ($button==" OK ") {
    include ("db_login.php");
    mysql_query("INSERT INTO cds(titel,interpret)VALUE('$titel','$interpret')");
    mysql_close();
    ?>
    Die Daten wurden eingetragen
    
    neuer Eintrag
    
    zur Übersicht
    <?
    }
    else {
    ?>
    <form method="post" action="insert.php">
    <input type="text" name="interpret" value="interpret">
    
    <input type="text" name="titel" value="titel">
    
    <input type="submit" name="button" value=" OK ">
    </form>
    <?
    }
    ?>
    
    </body>
    </html>
    Nur funktioert das irgendwie nicht, da er die Daten aus dem Formular nicht übergibt, wenn ich die Daten ($titel, $interpret) manuell eintrage funktioniert, also denke ich mal das es nicht an der Verbindung zu db liegt.
    Würde mich über Hilfe sehr freuen.

    MFG


  • #2
    Pass dein Script an register_globals = Off an.

    Kommentar


    • #3
      Re: Problem mit Post ?

      Zitat von Sargera
      Code:
      if ($button==" OK ") {
      mach
      Code:
       if ($_SERVER['REQUEST_METHOD'] == 'POST') {
      oder
      Code:
       if($button == "OK")

      Kommentar


      • #4
        Re: Problem mit Post ?

        Zitat von zwerg
        Zitat von Sargera
        Code:
        if ($button==" OK ") {
        mach
        Code:
         if ($_SERVER['REQUEST_METHOD'] == 'POST') {
        oder
        Code:
         if($button == "OK")
        Als HTML-Value hat er aber " OK " gesetzt. Und ein
        Code:
        if(isset($_POST['button']))
        würd's auch tun.

        Kommentar


        • #5
          danke, jetzt funzts^^

          Edit: oder auch nicht, nun erstellt das Script zwar neue Spalten in der Tabelle, nur steht nix darin

          Ich bin total Ratlos...

          MFG

          Kommentar


          • #6
            Du musst deine Abfrage natürlich auch entsprechend an deaktiviertes register_globals anpassen.

            Kommentar


            • #7
              Such über Google/Forensuche nach "php register_globals off" und lass dir wichtige Variablen zu Debug-Zwecken per echo oder print ausgeben.

              Kommentar


              • #8
                danke an alle. daran hab ich natürlich nicht gedacht

                Kommentar


                • #9
                  Re: Problem mit Post ?

                  Zitat von Michigras
                  Und ein
                  Code:
                  if(isset($_POST['button']))
                  würd's auch tun.
                  ...Stimmt naütrlich...

                  Kommentar

                  Lädt...
                  X